Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Android 4.4 - Nexus - Not playing

  1. #1

    Default Android 4.4 - Nexus - Not playing

    Hi guys

    I'm at a bit of a loss here, i hope that you can provide me with an answer or at least some insight. I have been running my trial edition of Wowza for 14 days now and with good results. Every IOS and android device has been playing what i wanted it to play. The other day though i updated one of our test devices from 4.3 (jelly bean) to Android 4.4 (kit kat) and suddenly it can't play anything provided by wowza. I checked and rechecked my settings but to no avail. Finally i went to your website wowza.com/demo and tried playing the demos you have there, just to get a peace of mind. But to my astonishment the only thing i can get working is the "Direct URL to sample file".

    what's gone wrong?

    Thanks

  2. #2
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    Hi,
    Looking at the Android Developer page for KitKat
    There have been significant changes, if you look under the "New media capabilities" section.
    There are mentions updates to HLS supported version, now supporting version 4. This may be significant.

    What browsers did you try? Just Chrome, or other. I heard that 4.4 does not ship with a browser, but rather this is up to
    the vendors to add browser when shipping devices?
    What is the device (manufacture/model) you are using?

    Does the RTSP link still work on this mobile page?


    Daren
    Last edited by daren_j; 12-02-2013 at 05:41 PM.

  3. #3

    Default

    Hi Daren

    Thanks for returning my question.

    It's the google model on some kind of Asus hardware , latest generation. It ships with Chrome, but i have also tried Dolphin but to no avail

    http://www.google.com/nexus/7/

    The link in question opens a window and you have to choose a player. The only player i have found that it is working with is VLC. The one it ships with from the factory does not work nor does VPlayer. Needless to say that i would hate to explain to some of my Android users that they have to download VLC in order to see my content.
    Last edited by flemming.johannesen; 12-03-2013 at 05:09 AM.

  4. #4
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    Hi
    This is something that we are going to try and test.
    Please open a ticket, by sending an email to support@wowza.com
    and reference this thread URL and attach zips of your conf and logs folders
    (if too large then share and link to the files instead). Make sure the logs
    are from dates/times when you have accessed the server with the 4.4 device.

    We will post our findings back to this thread for the community.

    Daren

  5. #5

    Default

    I am having no problems viewing HLS, or RTSP content on my Google Nexus 5 running 4.4 (Stock)

    I've tried with both Chrome and Firefox, and I'm prompted to pick a media player as you would expect (i.e. open once vs always) - and content playback starts up.

    Do you have logcat installed or anything? Not sure you'd get much useful out of it, but it may be worth a shot.

    Either that, or, install the ADT bundle, http://developer.android.com/sdk/installing/bundle.html, turn on dev tools on your phone and check it out and see if you get any useful debug when trying to start a stream on your phone.

    EDIT - Well - I hooked this up to my IDE and tracing logcat at debug; make sure in the logcat filter settings, you're not filtering on whatever module you throw in debug, i.e. "All Messages". I'd imagine there are some specific filters we'd want to set up to try and track this down easily. I just don't have time to look at it today!
    Last edited by willwh; 12-05-2013 at 11:14 AM.

  6. #6

    Default

    Android 4.4 doesn't do rtsp playback from web browser anymore, you need to build an app for rtsp playback, else it will show as a broken link.

    i am trying to work to find a work around for that when done i will post the solution.

    Regards,

  7. #7

    Default

    HLS support in 4.4 seems to be good; I'm just doing some switching of playback based on useragent and minor/major device version - working well.

  8. #8

    Default

    Hello,

    rtsp playback is working on Android 4.4.2 using nexus 4 phone, i have did the implementation using href <a href="rtsp://wowzaip/instance/streamname"></a>

    Regards,

  9. #9
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    There is actually such a link here on the Wowza mobile test page

    The video/audio stream that the link provides is encoded such that it plays on a wide range of hardware and Android OS versions.

    Daren

  10. #10
    Join Date
    Dec 2013
    Posts
    1

    Default

    Hi Guys there is a known problem with Android 4.4 see here . I'm seeing a massive difference between 4.4 and (4.3 & below) for live streaming - it appears to be a codec issue. I'm currently playing around with the server settings to see if I can find what specifically kills it.

Page 1 of 2 12 LastLast

Similar Threads

  1. Nexus 7 and Nexus 10 HLS issue
    By pirateMan in forum General Forum
    Replies: 1
    Last Post: 02-20-2014, 06:10 PM
  2. Playing rtsp in android without native player
    By stream4life in forum General Forum
    Replies: 2
    Last Post: 12-19-2013, 12:46 AM
  3. Recorded mp4 not playing on android
    By Xegagon in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 01-29-2012, 01:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •