Results 1 to 5 of 5

Thread: IMediaCasterNotify2 + IMediaStreamNameAliasProvider = probleme

  1. #1
    Join Date
    Mar 2012
    Posts
    25

    Default IMediaCasterNotify2 + IMediaStreamNameAliasProvider = probleme

    Hello,
    I created a little module, and I use two module example :
    1) StreamAliasName
    2) IMediaCasterNotify
    When they work together, work bad.. they conflict...

    My udp.stream don't work and repeat that:

    INFO server comment - onSetSourceStream
    INFO stream publish *.stream -
    INFO server comment - onConnectSuccess

    I think the problem is due to onAppStart():

    public void onAppStart(IApplicationInstance appInstance)
    {
    String fullname = appInstance.getApplication().getName() + "/" +
    appInstance.getName();
    getLogger().info("onAppStart mediacasterNotify : " + fullname);
    appInstance.addMediaCasterListener(new mediacasterNotify());
    }

    public void onAppStart(IApplicationInstance appInstance)
    {
    appInstance.setStreamNameAliasProvider(this);
    }



    Thank you

  2. #2

    Default

    Hi,

    When you use IMediaStreamNameAliasProvider interface, it replaces the *.stream files so you need to use the resolveStreamAlias method to return what would normally be in the *.stream file.

    Roger.

  3. #3
    Join Date
    Mar 2012
    Posts
    25

    Default

    thanks for your reply,
    problem is when I use : appInstance.setStreamNameAliasProvider(this) in setStreamNameAliasProvider class.

    public void onAppStart(IApplicationInstance appInstance)
    {
    String fullname = appInstance.getApplication().getName() + "/" +
    appInstance.getName();
    appInstance.setStreamNameAliasProvider(this)
    }

    IMediaCasterNotify2 don't work...

    public void onAppStart(IApplicationInstance appInstance)
    {
    String fullname = appInstance.getApplication().getName() + "/" +
    appInstance.getName();
    getLogger().info("onAppStart mediacasterNotify : " + fullname);
    }


    *stream not work, not found.. :/
    Last edited by a5lan98; 12-11-2013 at 07:40 AM.

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    These modules should not interfere with each other.

    If stilll a problem, what we need to sort this out are the logs of a short test and a your /conf folder. First delete the current access log (so we have clean, short log to review), then start Wowza and start your stream and test playback in the Wowza Flash RTMP example player.

    Then zip up the /conf and current access log showing the above tests and send to support@wowza.com

    Please make sure the /conf files are exactly as they were when you run this test, as I think you are trying many different things as you work. We have to see /conf folder as it was when you tested and generated the logs.

    Richard

  5. #5
    Join Date
    Mar 2012
    Posts
    25

    Default

    Ok thank I send now.

Similar Threads

  1. When myStream.stream not work = probleme
    By a5lan98 in forum Video On Demand Streaming Discussion
    Replies: 3
    Last Post: 12-10-2013, 03:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •