Results 1 to 3 of 3

Thread: weird log error, hack attemp ?

  1. #1

    Default weird log error, hack attemp ?

    Hello

    since a few days i've got this kind of lines in my logs:

    ERROR server comment 2013-12-07 09:52:34 - - - - - 2059526.931 - - - - - - - - HTTPRequest: decodeValue (%2D%64+%61%6C%75%6F%6E+%2D%64+%6D%6F%64+%2D%64+%73%75%68%6F%6E%3D%6F%6E+%2D%64+%75%6E%63%74%73%3D%2 2%22+%2D%64+%64%6E%65+%2D%64+%61%75%74%6F%5F%70%72%%74+%2D%64+%63%67%69%2E%66%6F%72%63%65%5F%72%65%6 4%69%72%65%63%74%3D%30+%2D%64+%74%5F%3D%30+%2D%64+%75%74+%2D%6E): java.lang.IllegalArgumentException: URLDecoder: Illegal hex characters in escape (%) pattern - For input string: "%7"


    using latest wowza version....googled it and seems related to php5 injections, any clue about this + wowza ?

    thank you !

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    I'm not sure. All I can tell is some playback URL includes illegal characters, something your systems may be doing mistakenly somehow, or might others on purpose for some reason. If you need to filter HTTP requests, you can use onHTTPSessionCreate.

    Richard

  3. #3

    Default

    Was there any further resolution to this? We have also found ourselves with these log messages, but no real clue as to why we are really getting them.

    Jesse

Similar Threads

  1. Wowza hack
    By moehareb in forum General Forum
    Replies: 1
    Last Post: 10-11-2014, 08:05 AM
  2. Weird Error invoke(onHTTPCupertinoEncryptionKeyLiveChunk)
    By f.hernandez.b in forum Wowza Streaming Server Java API
    Replies: 1
    Last Post: 07-08-2014, 08:06 PM
  3. Replies: 1
    Last Post: 09-24-2012, 03:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •