Results 1 to 2 of 2

Thread: HELP - Recording to UNC paths in Wowza service-mode.

  1. #1

    Question HELP - Recording to UNC paths in Wowza service-mode.

    Hi. I'm trying to solve one issue for several hours, without success. I was hoping someone could help me. Here is the thing:

    What I need:
    I have a Wowza Server setup as a live-record. It should record the FLV files to a network drive (using UNC paths) and create folders as needed, in case they don't exist.

    What I did:
    - The storagedir paramenter at Application.xml is already configured with the proper UNC path.
    - Authorization on the UNC path is set to Everyone.

    The problem:
    - When I try to run Wowza in command-line mode, I get the error message "Error writing to file: \\drivepath\folder\VIDEOS\video1.flv \\drivepath\folder\VIDEOS\video1.flv (The system cannot find the path specified).
    - However, if I manually create that path, the video1.flv file does get recorded. This is not what I want. I need Wowza to automatically create the necessary folders instead of having to manually create them.

    - The same thing happens when I run Wowza as a service, using domain admin credentials.

    What does work
    - If I manually map the UNC path (say, drive Z and run Wowza again in command-line mode, everything works fine. File gets recorded and folders are created properly.
    - If I run as a service (again, using domain admin credentials), the error persists.

    In other words, apparently I can only record to remote folders if:

    a. They are mapped as a drive, instead of UNC path.
    b. Wowza runs in command-line mode.

    Our goal is to have Wowza running as a service, so that it can be auto-started when Windows boots (independently of having to have a user manually logging into the machine).

    Am I missing something? I've searched forums up and down and tried everything I could think of about authorization. I've spent several hours on this without any success.

    Any help is greatly appreciated.

    Thanks in advance!

    Helder Conde

  2. #2
    Join Date
    Sep 2011


    This sounds like a permissions problem, I recommend you research the EnabledLinkedConnections registry which may help.


Similar Threads

  1. Replies: 3
    Last Post: 08-28-2014, 11:31 PM
  2. RequestFilter, *, and absolute paths
    By karlrasche in forum General Forum
    Replies: 2
    Last Post: 01-06-2014, 04:18 PM
  3. MediaCache Can't Resolve HLS Paths
    By odrilon in forum Video On Demand Streaming Discussion
    Replies: 2
    Last Post: 02-15-2013, 11:00 AM
  4. Modules/Module/Class paths
    By newtriks in forum Wowza Media Server 3 for Amazon EC2 Discussion
    Replies: 7
    Last Post: 12-15-2011, 09:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts