Results 1 to 5 of 5

Thread: RTMP VOD caption problem

  1. #1
    Join Date
    Dec 2013
    Posts
    3

    Default RTMP VOD caption problem

    Wowza upgraded from 3.0.2 to latest 3.6.3 using patch WowzaMediaServer-3.x.x-3.6.3.zip. All went successfully.

    Configured captions from article http://www.wowza.com/forums/content.php?431. Captions failed to work using JWPlayer 6 and Flowplayer. Modified Application.xml according to article.

    Finally noticed what could be duplicate Application.xml files in both the vod and live directories under /conf. I renamed the one in the vod directory and now RTMP VOD captions work in both players. Could something be conflicting? Are the Application.xml files even necessary in vod and live?

    Have spent over two days trying to get this to work. Very frustrated. Would like proper solution.

    Steve
    Last edited by SteveBiddle; 01-01-2014 at 10:26 PM.

  2. #2

    Default

    When creating a new application, the process is to:
    Create application folder [install-dir]/applications/newApp.
    Create configuration folder [install-dir]/conf/newApp and copy [install-dir]/conf/Application.xml to this new folder.


    So you should have a folder structure that goes like this:
    /conf/live/Application.xml
    /conf/vod/Application.xml

    If you do not copy the Application.xml file into /conf/newApp Wowza will use the default Application.xml file that is located in the /conf folder. This Application.xml file will work as a VOD application, and will also allow you to start a live stream, but will shortly stop streaming.
    To extend Wowza's functionality beyond the default settings you will need to copy Application.xml file into the newApp directory.

    Likewise, if you change the name of the Application.xml file in the /conf/newApp directory, for example, Application1.xml, Wowza will use the default Application.xml file from the /conf directory.

    So I am curious about your setup. You say you "renamed" the VOD Application.xml file and the captions are now working?

    Salvadore

  3. #3
    Join Date
    Dec 2013
    Posts
    3

    Default

    Here is the real problem. The article states that the wrong file be edited. It specifically indicates "The [install-dir]/conf/Application.xml file contains a <TimedText> section....". Actually, the file in /conf/vod does not even contain a <TimedText> section.

    The application VOD was originally created during the install of 3.0.5. The Application.xml file in the /conf/vod folder is much different than the one installed with 3.6.3. These differences should have been pointed out in the upgrade instructions with the patch.

    Evidently, when I renamed the file in the /conf/vod directory, it reverted to using the one in the /conf directory, which is why it now works.

    I thought that maybe the file in the /conf/vod directory contained specific settings for vod, but from what you are saying, the /vod one overrides the /conf one. That explains why the instructions in the article never worked.

    I have now copied the Application.xml file from the /conf directory to /conf/vod and it seems to be working correctly.

    Can you have the article corrected to remove the confusion?

    Steve

  4. #4

    Default

    Steve, thanks for the clarification and update. I am glad it is working for you now.

    To be fair to the Wowza team, at the top of the article it does state:
    "Note: Wowza Media ServerŪ 3.5.0 or later is required."

    Salvadore

  5. #5
    Join Date
    Dec 2013
    Posts
    3

    Default

    That is why I ran the upgrade patch.

    Steve

Similar Threads

  1. closed caption help
    By pdevine999 in forum Closed Captioning
    Replies: 9
    Last Post: 08-11-2015, 05:50 AM
  2. closed caption cann't work using rtmp with jwplayer 6.8
    By steven.du in forum Closed Captioning
    Replies: 2
    Last Post: 04-16-2015, 02:27 AM
  3. Caption file from S3
    By cc0004 in forum Closed Captioning
    Replies: 5
    Last Post: 04-08-2013, 07:40 AM
  4. Having problem with setting up caption for iOS device
    By gotofbi in forum Closed Captioning
    Replies: 1
    Last Post: 11-15-2012, 12:54 AM
  5. Same directory for RTMP VOD and VOD to iOS Devices
    By bobmax48 in forum Video On Demand Streaming Discussion
    Replies: 3
    Last Post: 05-23-2012, 04:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •