Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Encryption in wowza

  1. #1

    Default Encryption in wowza

    All,

    I want to make secure streaming in my wowza server, can anyone please suggest me the right way to get this? I am having valid key and RTMPE addon package with me.
    Read me file in the addon package says that only need to place the jar file in the library of wowza installation. But I have no luck. I am able to play rtmp but not rtmpe.

    Kind regards
    Skansa
    Last edited by skakska; 01-08-2014 at 12:25 AM.

  2. #2

    Default

    Hi, did you copy the .jar file in the Addon package, to the [install-dir]/lib folder and re-start Wowza.

    Salvadore

  3. #3

    Default

    Thank you, it works for me. Failed to restart the server, Thanks again

    For all my videos, audio is not matched with video. Its always happened while streaming by wowza with rtmp protocol and it s not happened while using CDN to stream the same content in rtmp.

    Can you please help me out in this also.

    Kind regards
    Skaksa
    Last edited by skakska; 01-08-2014 at 12:31 AM.

  4. #4

    Default

    Your welcome, glad I could help.

    On your second question, can you explain what you mean by audio is not matched with video? What are the symptoms?
    For VOD are you using a StreamType of "default" in your Application.xml file?

    Salvadore

  5. #5

    Default

    I mean audio is ahead of video about 5 seconds (the speech of the person in video is not perfectly match to audio). Dialog is delivered before the person speeches in that video, By this way the video is not understandable.

    Yes, I am using "default" streamType for the VOD application

    Kind regards
    Skaksa
    Last edited by skakska; 01-09-2014 at 12:10 AM.

  6. #6

    Default

    Is the delivery from the CDN progressive download? If so this indicates the sync problem is encoded into the file. You will need to fix the encoding process and/or correct these files, this can be done with ffmpeg:
    How to encode video on demand content

    Salvadore

  7. #7

    Default

    No, delivery is from wowza only. If I went to CDN delivery, this issue won't happen.

    Kind regards
    Skaksa

  8. #8

    Default

    I think at this point, the Wowza support team is going to need a sample file and more information to troubleshoot this.

    Please open a support ticket by emailing support@wowza.com. Zip up the /conf and /logs folders and send them along with a sample file for testing. Also please include a link to this thread as reference, and as much detail about your setup as possible.

    Salvadore

  9. #9

    Default

    Thanks for your guide Salvadore.I will do the things, what you advised.

    Kind regards
    Skaksa

  10. #10

    Default

    May I know one last thing from your advises and suggestions, please?
    How many users can watch a video at a time without buffering?
    Also, My wowza server is placed on Sanjose. If a user plays a video in California, it doesn't buffer and plays well, but users having buffering issue when playing videos from UAE and Australia.

    Kind regards
    Skaksa

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 3
    Last Post: 11-09-2014, 03:57 PM
  2. Encryption between encoder and Wowza server
    By myboynoy in forum Server-side Modules and Code Samples Discussion
    Replies: 3
    Last Post: 12-17-2013, 08:31 AM
  3. GoCoder to Wowza Server encryption
    By RobLudEng in forum Suggestions
    Replies: 1
    Last Post: 07-23-2013, 10:31 AM
  4. Setup AES Encryption Wowza streaming to Roku
    By malimar in forum Media Players and Devices Discussion
    Replies: 3
    Last Post: 04-18-2013, 11:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •