Results 1 to 6 of 6

Thread: RTSP Mobile test VS my own

  1. #1
    Join Date
    Dec 2013
    Posts
    8

    Default RTSP Mobile test VS my own

    When streaming the mobile file from the wowza's test page : http://www.wowza.com/html/mobile.html

    Using
    rtsp://184.72.239.149/vod/mp4:BigBuckBunny_115k.mov
    it take about 5-8 seconds to load on Android. This device is connected to 4g.

    However using my own test: (Feel free to try it)

    rtsp://162.228.248.20:1935/liveaudio/aac:ffmpeg_source
    it takes about ~20 seconds to load on Android. (I have also tried a vod file of mine with the same result)

    I have followed the tutorial at http://www.wowza.com/forums/content....-(RTSP-RTP-out.

    Still I get the same result. What is different on Wowza's configuration than would be on mine?

  2. #2
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    Hi,
    The Wowza server that hosts that mobile demo is an EC2 instance.
    Is your server also an EC2 instance? If so it should be fairly well tuned already.
    If it's another type of server or instance, did you also flow this guide to tune the application for use with RTSP?

    Daren

  3. #3
    Join Date
    Dec 2013
    Posts
    8

    Default

    Quote Originally Posted by daren_j View Post
    Hi,
    The Wowza server that hosts that mobile demo is an EC2 instance.
    Is your server also an EC2 instance? If so it should be fairly well tuned already.
    If it's another type of server or instance, did you also flow this guide to tune the application for use with RTSP?

    Daren
    I have, and I also completed the performance tuning. Still a ~20 second wait.

  4. #4
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    Hi,
    When I tried your link the other day:
    rtsp://162.228.248.20:1935/liveaudio/aac:ffmpeg_source
    on my tablet running Android 4.2 I think I was able to play in about 5 seconds.
    Right now I can't play at all, so perhaps the stream is not live?
    Anyway, it would be useful to know what device manufacturer and model, plus
    Android OS version you are running. Not sure but perhaps there's a known issue with that device?

    What EC2 instance size/type are you running?

    Try downloading this file to your own Wowza server 'content' folder:
    Then try to stream/play from your Android devices with:
    rtsp://Wowza-IP-Address:1935/vod/mp4:BigBuckBunny_115k.mov
    Do you get the same performance with that as you did when you tried from Wowza's own instance earlier?

    Daren

  5. #5
    Join Date
    Dec 2013
    Posts
    8

    Default

    Yes it is down right now. I am connecting on a Droid DNA on 4.2. When I am on my wifi it is 5 seconds. When connected to the Verizon network over cell signal its ~20. Thought my cell network is faster than my WiFi. I am not currently using an EC2 server. I am using a custom server running CentOS 6.4 with all the configuration done and needed ports opened.

  6. #6
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    Is your WiFi testing local to the Wowza server? So same LAN? Or is the Wowza server still remote?
    If Wifi is local to server then I'd expect that to be fairly quick.
    What may be happening is that UDP ports are not open and the Android player may be trying UDP first
    and about 10 or so seconds later, failing over to TCP before playing back.
    This was covered in the rtsp troubleshooting guide you mentioned in the first post.
    Some Android players, earlier ones I think, were not even capable of failing over to tcp and would just flat-out fail.

    Daren

Similar Threads

  1. Wowza v3.0.5 RTSP test stream
    By solotajs in forum Tutorials Discussion
    Replies: 2
    Last Post: 03-20-2012, 03:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •