Results 1 to 4 of 4

Thread: Not able to play live streaming with no audio on iPhone

  1. #1
    Join Date
    Jul 2010
    Posts
    14

    Default Not able to play live streaming with no audio on iPhone

    Live streaming with no audio is not playable on iPhone.

    Is this a iPhone is limitation, I am sure there no issues with Wowza.

    If limitation with iPhone, is there any work around for this?

  2. #2

    Default

    I am not noticing the behavior you are referring to, live stream works fine with no audio on iPhone for me.

    Does your stream not include audio? Or is the audio not being delivered to the device?

    What is the source of the stream?
    And what are the details of the stream?

    Salvadore

  3. #3
    Join Date
    Jul 2010
    Posts
    14

    Default

    Does your stream not include audio? Or is the audio not being delivered to the device?
    • Source stream does not have audio.
    • This is a RTSP re-streaming.



    What is the source of the stream?

    rtmp://146.185.148.20:1935/dhcam/dhcam1.stream

    rtsp://146.185.148.20:1935/dhcam/dhcam1.stream

    http://146.185.148.20:1935/dhcam/dhc.../playlist.m3u8

    And what are the details of the stream?
    2014-01-23 15:15:01 UTC comment server INFO 200 - LiveStreamPacketizerCupertino.handlePacket[dhcam/_definst_/dhcam1.stream][avc1.66.40]: H.264 (Video may not be playable on older iPhone and iPod touch devices where Main/Level 3.1 or lower is required) Video info: {H264CodecConfigInfo: codec:H264, profile:Baseline, level:4.0, frameSize:1280x960, displaySize:1280x960, frameRate:7.5} - - - 24.366 - - - - - - - -

    Framerate is 7.5, I am not sure if this could be a issue.

    2014-01-23 15:16:23 UTC comment server INFO 200 - LiveStreamPacketizerCupertino.endChunkTS[dhcam/_definst_/dhcam1.stream]: Add chunk: id:7 mode:TS[H264,NOAUDIO] a/v/k:0/91/13 duration:12129 - - - 106.369 - - - - - - - - - - -
    2014-01-23 15:16:36 UTC comment server INFO 200 - LiveStreamPacketizerCupertino.endChunkTS[dhcam/_definst_/dhcam1.stream]: Add chunk: id:8 mode:TS[H264,NOAUDIO] a/v/k:0/91/13 duration:12130 - - - 118.471 - - - - - - - - - - -
    2014-01-23 15:16:48 UTC comment server INFO 200 - LiveStreamPacketizerCupertino.endChunkTS[dhcam/_definst_/dhcam1.stream]: Add chunk: id:9 mode:TS[H264,NOAUDIO] a/v/k:0/91/13 duration:12130 - - - 130.606 - - - - - - - - - - -
    2014-01-23 15:17:00 UTC comment server INFO 200 - LiveStreamPacketizerCupertino.endChunkTS[dhcam/_definst_/dhcam1.stream]: Add chunk: id:10 mode:TS[H264,NOAUDIO] a/v/k:0/91/13 duration:12130 - - - 142.725 - - - - - - - - - - -
    2014-01-23 15:17:12 UTC comment server INFO 200 - LiveStreamPacketizerCupertino.endChunkTS[dhcam/_definst_/dhcam1.stream]: Add chunk: id:11 mode:TS[H264,NOAUDIO] a/v/k:0/91/13 duration:12130 - - - 154.852 - - - - - - - - - - -
    Last edited by rush0143; 01-23-2014 at 08:21 AM.

  4. #4

    Default

    First off, you should change the profile to "baseline 3.1" you have a profile of "baseline 4". Also, the frame size is very large, I suggest reducing this by half and see if that helps.

    It looks like you have a keyframe every second, so you can configure cupertinostreamingpackeization to better match the keyframe interval with this guide:
    How to configure Apple HTTP Live Streaming packetization (cupertinostreaming)

    Set the cupertinoChunkDurationTarget to 1000:
    <Property>
    	<Name>cupertinoChunkDurationTarget</Name>
    	<Value>1000</Value>
    	<Type>Integer</Type>
    </Property>
    Salvadore

Similar Threads

  1. unable to play audio with video on IPhone/IPad
    By kapil.khandal in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 10-07-2013, 08:30 AM
  2. Nokia Devices and Blacberry cannot play Live stream but Andriod and Iphone can play
    By ravish in forum Live Streaming and Encoder Discussion
    Replies: 3
    Last Post: 09-11-2012, 06:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •