Results 1 to 2 of 2

Thread: Transcoder not working on Linux 64bit?

  1. #1
    Join Date
    Feb 2014
    Posts
    1

    Default Transcoder not working on Linux 64bit?

    Hello,
    I need to test the Trascoder Add-on with the VOD application supplied.

    When I start Wowza on my machine, I get this:

    INFO server comment - Transcoder Streams Available: Transcoder Not Available (linux-32)
    INFO server comment - nDVR Available: Yes
    INFO server comment - DRM Available: Yes
    INFO server comment - Hardware Available Processors: 1
    INFO server comment - Hardware Physical Memory: 538MB/1655MB
    INFO server comment - Max File Descriptor Count: 20000
    INFO server comment - Open File Descriptor Count: 50
    INFO server comment - OS Name: Linux
    INFO server comment - OS Version: 2.6.32-358.2.1.el6.x86_64
    INFO server comment - OS Architecture: i386
    INFO server comment - Java Name: Java HotSpot(TM) Server VM
    INFO server comment - Java Vendor: Oracle Corporation
    INFO server comment - Java Version: 1.7.0_04
    INFO server comment - Java VM Version: 23.0-b21
    INFO server comment - Java Spec Version: 1.7

    Why is it saying Transcoder Not Available (linux-32)? I have a 64 bit machine, as shown later in the log (OS version ends with x86_64).

    Any explanation? I can't get the transcoder to work on VOD... I tried setting <LiveStreamTranscoder>transcoder</LiveStreamTranscoder> and <Templates>${SourceStreamName}.xml,transcode.xml</Templates> in Application.xml but when I play the stream, I do not see any transcoding happening (and the video does not play, only the sound does):

    INFO cupertino connect 77621856 -
    INFO stream create mp4.mp4 -
    INFO server comment - MediaReaderH264Cupertino.indexFile[vod/_definst_/mp4.mp4][mp4a.40.2]: AAC Audio info: {MediaCodecInfoAudio: codec:AAC, channels:2, frequency:48000, samplesPerFrame:1024, objectType:LC}
    INFO cupertino connect 1129284078 -
    INFO stream create mp4.mp4 -
    INFO server comment - MediaReaderH264Cupertino.indexFile[vod/_definst_/mp4.mp4][mp4a.40.2]: AAC Audio info: {MediaCodecInfoAudio: codec:AAC, channels:2, frequency:48000, samplesPerFrame:1024, objectType:LC}
    INFO stream play mp4.mp4 -
    INFO stream seek mp4.mp4 -
    INFO stream destroy mp4.mp4 -

    Thanks,

    fabrizio

  2. #2
    Join Date
    Jul 2012
    Posts
    299

    Default

    Hello Fabrizio,

    It sounds like you may be using a 32-bit version of Java on your 64-bit OS. This is a common issue. Please investigate and upgrade, as required.

    -Tim

Similar Threads

  1. Transcoder, CUDA & Linux
    By bighenry in forum AddOn: Transcoder
    Replies: 0
    Last Post: 02-25-2014, 02:23 AM
  2. Transcoder not working and stop working live streaming
    By silas_i in forum AddOn: Transcoder
    Replies: 5
    Last Post: 03-18-2013, 04:55 PM
  3. linux 64 but Transcoder not Avalible
    By AlSoft in forum AddOn: Transcoder
    Replies: 4
    Last Post: 11-13-2012, 07:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •