Results 1 to 10 of 10

Thread: Cannot connect to Wowza via Filezilla - ripping hair out!!!

  1. #1
    Join Date
    Mar 2013
    Posts
    9

    Question Cannot connect to Wowza via Filezilla - ripping hair out!!!

    Hi

    trying to set up Wowza on EC2 and just trying to st up the HTTP caching. I cannot get Filezilla ftp to connect to change the required files. This is what I have done/get so far:

    I am using a laptop via a wireless router.

    Switched off AVG.
    Switched off Windows Firewall
    Set up Filezilla to Active Mode
    Limited ports to 5000-5100
    Set External IP address to mine (checked its correct with Google :-) )

    Set up Security Group as per instructed via Wowza tutorial

    This is what I get when trying to connect:

    Status: Resolving address of ec2-**-***-***-***.eu-west-1.compute.amazonaws.com
    Status: Connecting to 54.194.219.114:21...
    Status: Connection established, waiting for welcome message...
    Response: 220 (vsFTPd 2.2.2)
    Command: USER wowza
    Response: 331 Please specify the password.
    Command: PASS **********
    Response: 230 Login successful.
    Command: SYST
    Response: 215 UNIX Type: L8
    Command: FEAT
    Response: 211-Features:
    Response: EPRT
    Response: EPSV
    Response: MDTM
    Response: PASV
    Response: REST STREAM
    Response: SIZE
    Response: TVFS
    Response: UTF8
    Response: 211 End
    Command: OPTS UTF8 ON
    Response: 200 Always in UTF8 mode.
    Status: Connected
    Status: Retrieving directory listing...
    Command: PWD
    Response: 257 "/home/wowza"
    Command: TYPE I
    Response: 200 Switching to Binary mode.
    Command: PORT 82,21,166,201,19,220
    Response: 200 PORT command successful. Consider using PASV.
    Command: LIST
    Error: Connection timed out
    Error: Failed to retrieve directory listing

    PLEASE can anyone help???

  2. #2
    Join Date
    Nov 2012
    Posts
    103

    Default

    In FileZilla settings under Connection SFTP add your keypair file (.pem) associated with your instance. FileZilla will offer to convert it for you, say yes.

    Now, in site manager make sure that you connect using the SFTP protocol and not the standard FTP protocol. Remove port number.

    Make sure that your EC2 security group allows inbound connections on port 22.

  3. #3
    Join Date
    Mar 2013
    Posts
    9

    Default

    Thanks for your quick reply

    Tried that - also added in as logging in with password added user wowza and password (instance ID) got this:

    Status: Connecting to ec2-**-***-***-***.eu-west-1.compute.amazonaws.com...
    Response: fzSftp started
    Command: keyfile "C:\Downloads\Keypair file CW.ppk"
    Command: open "wowza@ec2-**-***-***-***.eu-west-1.compute.amazonaws.com" 22
    Error: Disconnected: No supported authentication methods available (server sent: publickey)
    Error: Could not connect to server

    Any ideas?

  4. #4
    Join Date
    Nov 2012
    Posts
    103

    Default

    What kind of Amazon Machine Image (AMI) are you using?

    And what do you provide for "User" and "Password"? For Amazon Linux the user name is ec2-user and blank password.
    Last edited by niemion; 02-11-2014 at 03:23 PM.

  5. #5
    Join Date
    Mar 2013
    Posts
    9

    Thumbs up Solved

    YAAAAAYYYYYY!!!!!!

    I am using ami-eaf01a9d

    BUT what solved it was using your system and changing user and password as you said - THANK YOU xxxxxxxxx

  6. #6
    Join Date
    Mar 2013
    Posts
    9

    Default

    Spoke too soon

    Managed to download and make adjustments to application.xml BUT can't upload it with changes to overight existing file. :-( Tried changing file permissions from 775 to 777 in Filezilla but unable to - how and where can I change file permissions please?

  7. #7
    Join Date
    Nov 2012
    Posts
    103

    Default

    Connect using SSH. Terminal on OSX, Putty on Windows.

    sudo chmod 777 /path/filename.xml

  8. #8
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    This was helpful to me, and timely. I will suggest adding it to our EC2 Guide.

    Thanks,
    Richard

  9. #9
    Join Date
    Mar 2013
    Posts
    9

    Default

    Hi

    Phew!!!
    Got there ...... in the end!!! Also downloaded WinSCP and used file transfer this way rather than Filezilla.

    For someone new to all this I have no idea how others manage this without your help niemion - THANK YOU xxx and rrlanham I agree this needs to be added to your EC2 guide. I am not stupid but the guide just didn't work for me - surely, I can't be the only one unable to get this done by following the guide??????????????????

    Off to work on the next stage now - thank you again

  10. #10
    Join Date
    Nov 2012
    Posts
    103

    Default

    I'm glad I could help you butchx5.

    When it comes to EC2 and Linux in general there are many subjects it would be great to cover in the Wowza User's Guide. But it is important to remember that the scope of the User's Guide is - and should be, quite narrow.

    With that said I agree that some more essential how to's could be included in the WowzaMediaServerForEC2_UsersGuide and in the WOWZA FOR AMAZON EC2 articles.

    I think serverfault.com would be a great place to ask generic Linux questions. Technical support from the Amazon Web Service support team is great, but it will cost you at least $49.00 / month.


    Various posts and commands you might find useful at some point


    http://blog.ianbeyer.com/2013/02/10/...c2-qa-session/
    http://blog.ianbeyer.com/2013/07/05/...on-cloudfront/
    http://blog.ianbeyer.com/2013/02/26/...pacity-update/
    http://sharadchhetri.com/2013/03/08/...-ec2-instance/
    http://devnumbertwo.com/mounting-an-...-ec2-instance/
    http://www.wowza.com/forums/showthre...aneous-viewers
    http://serverfault.com/questions/570...gabit-instance
    http://alestic.com/2009/06/ec2-user-data-scripts


    Set time zone at start-up (so the time in the Wowza logs is not completely off)

    nano /etc/sysconfig/clock
    Then write:

    ZONE='Europe/Copenhagen'
    Substitute Europe/Copenhagen with your own zone.


    Output logs realtime (the name of the logs has changed in Wowza ver. 4)

    tail -f /usr/local/WowzaMediaServer/logs/wowzamediaserver_access.log
    tail -f /usr/local/WowzaMediaServer/logs/wowzamediaserver_error.log
    Run wowza service on startup (the name of the service has changed in Wowza ver. 4)

    chkconfig WowzaMediaServer on
    Wowza service commands (the name of the service has changed in Wowza ver. 4)

    service WowzaMediaServer status
    service WowzaMediaServer stop
    service WowzaMediaServer start
    service WowzaMediaServer restart
    Check disk usage

    df -h
    Delete folder

    rm -r -f /folderpath
    How to reboot Linux (not the same as restarting instance)

    reboot

    Wowza interfaces

    http://serveripaddress:8086/streammanager
    http://serveripaddress:8086/livestreamrecord/index.html
    Last edited by niemion; 02-13-2014 at 04:08 PM.

Similar Threads

  1. How to check source stream status - MediaCasterConnection.connect: Failed to connect
    By herkules in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 11-20-2013, 07:11 PM
  2. How to connect to Wowza EC2 via FileZilla, URGENT
    By sebastianreg in forum Wowza Media Server 3 for Amazon EC2 Discussion
    Replies: 1
    Last Post: 08-09-2013, 06:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •