Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Cannot access to the manger

  1. #1
    Join Date
    Feb 2014
    Posts
    7

    Default Cannot access to the manger

    Hi, I recently purchased a trial license for v3 and today I see that a new version is out. I installed the v4 in a new server and everything gone well. After that I went to the http://my-ip-server:8088/enginemanager address and I put the username and password that I introduced in the installation process but showed me this error:

    Could not connect to server: http://localhost:8087

    This is a fresh installation. I have a webmin panel in the server. Java installed.

    Need I to purchase a free v4 license?
    What is going on?
    Can you help me?

    Thank you.

  2. #2
    Join Date
    May 2013
    Posts
    680

    Default

    Can you verify if your Wowza server was started? It looks as though the enginemanager was started but possibly not the Wowza Server Engine. Try restarting your server engine.

  3. #3
    Join Date
    Feb 2014
    Posts
    7

    Default

    Hi,
    yes I have verified that wowza was started.
    WowzaStreamingEngine stopped [ OK ]

    WowzaStreamingEngine: starting...
    WowzaStreamingEngine started PID5715) [ OK ]
    I tried to reboot the server but didnīt helped.
    What am I missing?

    Thanks for the help.

  4. #4
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    Hi,
    Is this installation using a Version 4.0 license that you requested, or did you install using your existing 3.0 License?
    Your access log located [install-dir]/logs should verify if the Engine is actually running or not. Sometimes the service appears to start at the OS level
    but the Engine process doesn't necessarily keep running, especially if there's a license problem.
    The upgrade process is given on this page.
    You can also get a free Trial license here to try it out, prior to upgrading.

    Daren

  5. #5

    Default

    @alvaroarp
    have you tried to check if your server is running on port 1935?
    you can check your password settings which you have set on installation (for the streammanager) in /usr/local/WowzaStreamingEngine/conf/admin.password

    if you indeed use a Version 3 license it doesnt work. as far as i know a license for 3.5 also doesnt work on a 3.6.4 installation. So the license keys depend on the server version of Wowza. it should be compatible in my opinion, but that's another discussion


    edited post:
    sorry havent read this part of the installation. is solving my issue
    Whitelist remote browser clients

    By default, Wowza Streaming Engine is configured to accept connections from a web browser that is running on the localhost. If you need to connect to Wowza Streaming Engine instance that's running on a remote server, you must add the IP address of the remote computer, in reference of where the browser is connecting, to the IPWhitelist settings in the Wowza Streaming Engine security configuration. To do so, open the [install-dir]/conf/Server.xml file in a text editor and make the following changes:
    Last edited by nlmaca; 02-12-2014 at 01:53 PM.

  6. #6
    Join Date
    Feb 2014
    Posts
    7

    Default

    Hi, thanks for your replay.

    The license I was using was for the previous version of Wowza. Then I went back to get a new license for v4.

    I uninstalled Wowza with this command:
    rpm-e WowzaStreamingEngine-4.0.0-ga

    After that y use:
    rm -rf /usr/local/WowzaStreamingEngine-4.0.0

    Then I rebooted the server and started the installation again with the new license. This is the installation log:
    Do you agree to the above license terms? [yes or no]
    yes
    Wowza Streaming Engine Manager is a browser-based application for managing the Wowza Streaming Engine software. Enter an Administrator user name and password that you want to use to sign in to the manager.
    Note: User Name and Password are case-sensitive.
    User Name: xxxxx
    Password:
    Confirm Password:
    Please enter a Wowza Streaming Engine license key in this format:
    XXXXX-XXXXX-XXXXX-XXXXX-XXXXX-XXXXX[-XXXXXXXXXXXX] ET1A4-r747a-TDEjT-uxRmu-7kP8N-ydpUf[-XXXXXXXXXXXX]
    Wowza Streaming Engine license key accepted. Thank you!
    Installing Wowza Streaming Engine
    Preparando... ########################################### [100%]
    1:WowzaStreamingEngine ########################################### [100%]

    Start Wowza Streaming Engine automatically when this system reboots? [yes or no]
    yes
    Starting WowzaStreamingEngine (via systemctl):
    WowzaStreamingEngine: stopping...
    WowzaStreamingEngine stopped

    WowzaStreamingEngine stopped

    WowzaStreamingEngine: starting...
    WowzaStreamingEngine started PID2941) [ OK ]
    Starting WowzaStreamingEngine (via systemctl):
    WowzaStreamingEngineManager: stopping...
    WowzaStreamingEngineManager stopped
    WowzaStreamingEngineManager stopped
    WowzaStreamingEngineManager: starting...
    WowzaStreamingEngineManager started PID2982) [ OK ]
    Install Location:
    /usr/local/WowzaStreamingEngine.

    To access Wowza Streaming Engine Manager, go to http://localhost:8088/enginemanager in a web browser.
    [root@localhost /]#
    After that I went to http://my-IP-server:8088 and I had the same problem.
    I looked at the log and there is a problem with the license:

    #Software: Wowza Streaming Engine 4.0.0.00 build10425
    ...
    ERROR server comment 2014-02-13 09:46:32 - - - - - 0.633 - - - - - - - - ERROR: License key is not valid or license file does not exist and running as a service (exiting)
    At first I thought the problem was that I had a different version of license but after uninstall and install again I thought that would solve.
    Any suggestions?
    Thanks in advance.

  7. #7

    Default

    can you check /conf/Server.license file?
    it should state that only your license key is on 1 line. an enter should NOT be there

  8. #8
    Join Date
    Feb 2014
    Posts
    7

    Default

    Hi,
    yes I've already checked this. Only one line with the key in the license file.
    As I mentioned in my first thread I use Webmin, is it may need some additional configuration on my server? MySQL, Apache, Firewall ...

    thanks

  9. #9

    Default

    You dont need MySQL for it. It requires Java 7 though.
    If you have a firewall installed you should check your ports which have to be open. (1935, 8087,8088)


    btw i've tried your serial too. the problem is in your license key. Get a new one because you're missing some characters
    if this is yours: ET1A4-r747a-TDEjT-uxRmu-7kP8N-ydpUf it is to short.

    advice: dont use public ip addresses and license keys in your posts

    if you need a developer license go to this page to get one (it is valid for 180 days):
    https://www.wowza.com/media-server/developers/license

    edit:
    to update your license key just edit the /conf/Server.license file and put in your new license. after that restart the WowzaStreamEngine
    Last edited by nlmaca; 02-13-2014 at 12:59 PM.

  10. #10
    Join Date
    Feb 2014
    Posts
    7

    Default

    Hi,
    I was able to install the 3 packages of Java without problems.

    I'll look for that ports, thanks, but this is a fresh server install...
    The license was edited for this thread , thank you anyway.

    I'm sorry for the trouble.
    What I'm missing?

    Thanks

Page 1 of 2 12 LastLast

Similar Threads

  1. adobe access?
    By jasonp in forum General Forum
    Replies: 2
    Last Post: 02-06-2013, 06:26 AM
  2. Replies: 1
    Last Post: 09-24-2012, 03:00 PM
  3. Unable to create DVR Manger
    By IrwanBD in forum AddOn: Wowza nDVR
    Replies: 1
    Last Post: 02-29-2012, 04:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •