Results 1 to 5 of 5

Thread: Solved: Cannot Start WSE 4.0.0 on 32 bit OS

  1. #1

    Default Solved: Cannot Start WSE 4.0.0 on 32 bit OS

    Hi Everyone,
    Well, the first Impression about WSE 4.0.0 - WOW! A lot of pain and effort has gone into its development. Kudos to everyone behind it. Richard/Charlie, please pass on the message!

    Anyone coming from 3.x, installing new version on 32 bit OS and are facing the error while starting:
    Error: missing `server' JVM at `C:\Program Files\Java\jre7\bin\server\jvm.dll'.
    Please install or use the JRE or JDK that contains these missing components.
    That's because the default JVM options setting is -server now which earlier used to be present in the /bin/setenv.bat but commented out.
    To fix the issue:

    Edit /conf/Tune.xml file and comment out the -server setting towards the end of the file. It should look like:
    <!-- <VMOption>-server</VMOption> -->

    Now you can start Wowza and proceed to rest of the setup via the Streaming Engine Manager
    http://<your_wowza_ip>:8088/

    Advanced users can probably make this out, but for the rest, I thought posting this might help.

    Happy Streaming!
    -Inderjeet
    Last edited by swexpert; 02-12-2014 at 07:15 AM.

  2. #2
    Join Date
    Sep 2011
    Posts
    1,920

    Default

    Hi,
    Thank you for posting the above information. I'm sure a lot of users using a 32-bit OS will benefit from your post.
    One correction, Wowza Streaming Engine Manager is accessed via
    http://<yourwozaip>:8088
    Jason

  3. #3

    Default

    Hi Jason,
    Thanks for pointing that out. Corrected.

    Sincerely
    Inderjeet

  4. #4

    Default

    I'm on 4.0.1 and actually running on Server 2008R2 64bit and ran into the same issue and happy to help anyone else in the community with the following info that wasn't so easy to find:
    By default, since Java only saw my 32bit Chrome browser, that's what I ended up with and got the following message when trying to sign in:

    "Wowza Streaming Engine Manager could not connect to the Wowza Steaming Engine (http://localhost:8087). Verify that the Wowza Streaming Engine service has started and is running."
    or
    "The Wowza Streaming Engine 4.0.1 service on [my server name] started and then stopped. Some services stop automatically if they are not in use by other services or programs"

    I.e., this isn't just a 32bit OS issue.

    When I couldn't run either the engine service or the standalone, I ran the "startup.bat & pause" in a terminal which revealed the above java error. I installed 64bit Java, verified it, but it didn't make a difference and then came across two solutions.
    First and foremost, you'll want to update the Tune.conf as Inderjeet recommends, but since Wowza (for whatever reason) did not to fix this in 4.0.1, others may want/need to do the following instead:

    To Fix The "Missing "server" JVM at `C:\Program Files\Java\jre7\bin\server\jvm**.dll'. Please install or use the JRE or JDK that contains these missing components. Press any key to continue . . "
    follow the steps:
    Go to oracle.com and install java jre7 (check not be installed java 6 plz)
    After that go to C:/Program files/java/jre7/bin
    Here create an folder called "server" (without " ")
    Now go into the C:/Program files/java/jre7/bin/client folder
    COPY all data of this folder into the new C:/Program files/java/jre7/bin/Server


    -SA
    Last edited by SojourningAlien; 03-24-2014 at 03:52 PM.

  5. #5
    Join Date
    Aug 2012
    Posts
    12

    Default

    Thanks Inderjeet and SA for your input on this. I'd like to provide some clarification on what you have seen and done to get your installs working.

    Wowza recommends an 64-bit JVM and OS for optimum performance but is not required. See http://www.wowza.com/forums/content.php?217#installJava

    In the past, Oracle bundled 2 versions of the JVM for Windows in their default installations for both 32 bit and 64 bit installs:

    - A "client" runtime that's optimized for faster loading which improves performance when used in conjunction with webpages and other short lived applications

    - A "server" runtime that's optimized for long term stability.

    Oracle has been making some changes and I'll try and cover them here. (These are assumptions by me and found by empirical testing, not any insider knowledge from Oracle)

    When you go to www.java.com and click on the big red "Free Java Download" button, they are doing their best to make the experience easy for the average consumer. They can determine the platform (Windows, OSX, Linux ) and the architecture of your web browser (32-bit vs. 64-bit), which is typically 32-bit because of legacy applications/needs even though your under lying OS is 64-bit, and provide you, with the click of a button, a JVM that will work within your browser. That's because it's most likely what the average user is there for, get java working in their browser. Another thing they have done to make this easier on the average consumer is to remove the “Server” optimized version of the JVM to make the download smaller and faster since most customers don’t need it.

    However, for your Wowza needs, you really want the JVM that best fits your OS and architecture (not your web browser). This is where you, the Streaming Ninjas that use Wowza, need to dig a little deeper into Oracle's JAVA offerings. We need to go beyond the easy button and get what we really want.

    If you're using a 32-bit version of Windows, you're out of luck in getting a version of Oracle Java (1.6 or later) that contains the "Server" version of the JVM from Oracle. They just don't offer it anymore. But wait! Don't despair, this doesn't mean you can't use Wowza, it just means you have to do a little customization and realize you aren't in the "optimum" environment to run Wowza.

    You can use the methods described by Inderjeet and SA above and summarized below:

    remove "-server" from the conf/Tune.xml

    -or-

    copy the contents of the [java-install-dir]\bin\client folder to the [java-install-dir]\bin\server folder, which you have to create.

    The first option just indicates to java.exe that it should use the client version, the second makes Java.exe think there is a "server" optimized version available when in reality it's using the "client" optimized version. In either case, just remember, you're now using the "client" version instead of the "server" version and your mileage may vary. Certainly good enough to prototype and evaluate Wowza Streaming Engine, but we encourage the use of a 64-bit OS when used in a production/everyday available environment.

    If you're using a 64-bit version of Windows, you're in luck. You just need to dig deeper into www.java.com to find what you need. Instead of going to www.java.com and clicking on the easy button (Free Java Download), we need to use the "Downloads" link and follow about 9.4 more links (I won't bore you with all the links to links to links) to get to http://www.java.com/en/download/manual.jsp where you can find what you need. Then you can click on the "Windows Offline (64-bit)" and download the installer that has the "server" version of the JVM included in it. You're probably going "What", but I thought you said I'm using a 32 bit browser?" And you most likely are if you are reading this. What we are doing is getting a JVM that matches your OS architecture (32-bit vs 64-bit)and not your browser. You can have both installed on your system so don't worry, stay with me and have some faith.

    Then open the downloaded installer and go through the installation and last but not least, update your JAVA_HOME variable (System Properties->Advanced->Environment Variables->System Variables)
    to where you installed the version you downloaded (default install location is C:\Program Files\java\jre7 as of the writing of this).

    If you are needing Java to work in your web-browser, go ahead and use the red button (Free Java Download) and when your done, just make sure your JAVA_HOME environment variable still points to the install you did with the "Server" version included.

    Thanks for your patience and thumbs up to Inderjeet and SA for digging into this issue and sharing with the rest of us. It's pretty awesome to see everyone helping everyone else do so much cool stuff with Wowza.

    If you are still having issues after going through these steps, please feel free to open a support ticket with us by emailing us at support@wowza.com.

    Eric

Similar Threads

  1. WSE 4.0.4 Upgrade Questions
    By SETVproducer in forum General Forum
    Replies: 4
    Last Post: 06-26-2014, 04:28 PM
  2. Replies: 3
    Last Post: 05-01-2014, 08:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •