Results 1 to 5 of 5

Thread: where did flush interval goes ?

  1. #1
    Join Date
    Dec 2013
    Posts
    14

    Default where did flush interval goes ?

    There was a variable called flush interval inside stream.xml ... in wowza 4.0 i can not find it ! i used to tweak it to have a great latency
    anyone know where it is now ? under what page ?

  2. #2
    Join Date
    Sep 2011
    Posts
    1,931

    Default

    Hi,
    In the [Wowza-Install]/conf/Streams.xml this only defined the values for each of the stream types in the Application.xml and was only for Flash RTMP streams.
    When creating or editing an application in Wowza Streaming Engine you can check the box for Low-Latency which will give a lower latency for Flash connections.

    The StreamType can be set to live-lowlatency in the Application.xml in any current version of Wowza.
    The How to achieve the lowest latency from capture to playback article may help with your needs.

    Jason

  3. #3
    Join Date
    Sep 2011
    Posts
    1,931

    Default

    Hi,
    To do this in the Wowza Streaming Engine Manager, click "Server" in the tab at the top then "Users", edit your user by clicking the pencil and under Preferences check the tic box "Allow access to advanced properties and features".
    This will allow you to see more options when viewing the applications configured using the Manager.

    When on the application you should be able to see the Properties section at the top, scroll down to the very bottom and you will see "Custom", click Edit and then "Add Custom Property"
    In this case you will need to change the "path" in the drop-down menu to Root/Application/Streams, call it "flushInterval" and set the "Type" as Integer and "Value" 25.
    Repeat the process for adding the Property "onFlushNotifyClients" to the same application.

    Regards,
    Jason

  4. #4
    Join Date
    Dec 2013
    Posts
    14

    Thumbs up Thanks !!

    Thanks Jason , It worked perfectly with 0 latency and smooth with the flushInterval
    But the onFlushNotifyClients messed up the server ( i dont know what it does but after i added it , the video became jitter and non-watchable)
    took it off and it workef perfectly.


    Quote Originally Posted by JasonH View Post
    Hi,
    To do this in the Wowza Streaming Engine Manager, click "Server" in the tab at the top then "Users", edit your user by clicking the pencil and under Preferences check the tic box "Allow access to advanced properties and features".
    This will allow you to see more options when viewing the applications configured using the Manager.

    When on the application you should be able to see the Properties section at the top, scroll down to the very bottom and you will see "Custom", click Edit and then "Add Custom Property"
    In this case you will need to change the "path" in the drop-down menu to Root/Application/Streams, call it "flushInterval" and set the "Type" as Integer and "Value" 25.
    Repeat the process for adding the Property "onFlushNotifyClients" to the same application.

    Regards,
    Jason

  5. #5
    Join Date
    Dec 2013
    Posts
    14

    Default

    I dont know how to close the threat with success. i dont know if thats a admin priviledge only
    Thanks Jason again and i need your help in another thread when you can please
    http://www.wowza.com/forums/showthre...330#post133330

Similar Threads

  1. Error: Over flush iteration limit
    By markmn12 in forum Live Streaming and Encoder Discussion
    Replies: 5
    Last Post: 08-14-2013, 02:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •