Results 1 to 7 of 7

Thread: Can't make Wowza Streaming Engine work

  1. #1

    Default Can't make Wowza Streaming Engine work

    Hello,

    I'm on Linux Debian.

    I upgraded from Wowza Media Server 3.5.2 to Wowza Streaming Engine 4.0 today.
    I uninstalled Wowza Media Server, asked for a new licence key and installed Wowza streaming engine.

    Once done I tried to access http://server@:1935 but got nothing but network error. I tried to access http://server@:8088/enginemanager and successed but when I tried to connect with user and pwd it failed.
    I white listed all ip, restarted the two services an tried again but same result.

    I read all threads related in here but didn't find solution. I can ping the wowzalicenceX.wowza.com servers, I checked the license key in the Server.license file and it seems ok. I just have a doubt about the key format. I received a key like : XXXXX-XXXXX-XXXXX-XXXXX-XXXXX-XXXXX by mail and were asked to enter something like XXXXX-XXXXX-XXXXX-XXXXX-XXXXX-XXXXX[-XXXXXXXXX] during the installation.

    I think that Wowza Streaming Engine don't start well but don't know where the problem is located.

    Any help would be greatly appreciated.

    Thanks.
    Last edited by Glenn Feunteun; 02-17-2014 at 10:54 AM.

  2. #2

    Default

    Glenn, are you including the opening and closing brackets "[]" when entering the license key? If so, you should omit them.
    Are there any clues in the access or error logs to help pin point the issue?

    Salvadore

  3. #3

    Default

    My license key is like this : XXXXX-XXXXX-XXXXX-XXXXX-XXXXX-XXXXX so I entered it as is (without [] and anything inside which is optional I think) during the installation.
    I tried to launch the Wowza Streaming Engine in standalone mode and I got this in the error logs : "The Wowza Media Systems Software licensing system was not able to connect to the licensing server to validate your licence. Please validate that your machine is able to send HTTP data over TCP port 80 to the internet? If this problem persists, please visit ..."
    So it seems to be a connection problem. I'm behind a proxy which I configured and as I said before I can ping the wowza licence servers. The Wowza Streaming Engine Manager runs well with port 8088 open.

    Still investigating for the problem.

    Thanks for your help.

  4. #4

    Default

    This article may help to communicate with the licensing server:
    How to configure Wowza Media Server to use proxy server to communicate with license server

    Salvadore

  5. #5

    Default

    I read and applied what is said in the article, unfortunately it doesn't work. My proxy is well configured because I can get packages via apt-get or do wget without problems. Maybe there were some changes in the 4.0 version (the article is still related to the Wowza Media Server versions).

  6. #6

    Default

    I have finally found the solution. In fact I had to configure Java to use the proxy. The solution is here : http://stackoverflow.com/questions/2...iable-in-linux.

    Setting the proxy in the variable : export _JAVA_OPTIONS='-Dhttp.proxyHost=[proxy] -Dhttp.proxyPort=[proxy port]'

    Thanks for your help.

  7. #7
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Glenn,

    Zip up /conf and /logs folders and send to support@wowza.com, so we can take a closer look. Include a link to this thread for reference.

    Richard

Similar Threads

  1. Please help me make my ip camera work across devices!
    By onyx808 in forum Media Players and Devices
    Replies: 3
    Last Post: 05-20-2014, 02:52 PM
  2. multicast publish not able to make it to work
    By Necchi in forum AddOn: Other AddOns
    Replies: 1
    Last Post: 03-12-2013, 08:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •