Results 1 to 4 of 4

Thread: Updating my module from WMS 3.6 to Wowza Streaming Engine

  1. #1
    Join Date
    Jun 2013
    Posts
    6

    Default Updating my module from WMS 3.6 to Wowza Streaming Engine

    Hi everyone,
    I am trying to update my custom module (that worked well with Wowza Media Server 3.x) to Wowza Streaming Engine.
    Most of my code still works with Wowza Streaming Engine except the thumbnail generator
    BufferedOutputStream out = new BufferedOutputStream(new FileOutputStream(new File(filePath), false));
    FLVUtils.writeHeader(out, 0, null);
    AMFPacket codecConfig = thestream.getVideoCodecConfigPacket(packet.getAbsTimecode());
    if (codecConfig != null)
            FLVUtils.writeChunk(out, codecConfig.getDataBuffer(), codecConfig.getSize(), 0, (byte)codecConfig.getType());
    ...
    Related error with Wowza Streaming Engine log :
    java.lang.NoSuchMethodError: com.wowza.util.FLVUtils.writeChunk(Ljava/io/OutputStream;Ljava/nio/ByteBuffer;IJB)V
    So I checked the difference between the API :

    // From Wowza Media Server 3 API : 
    static void writeChunk(java.io.OutputStream ds, java.nio.ByteBuffer data, int size, long timecode, byte type)
    // From Wowza Streaming Engine API
    public static com.wowza.wms.mediawriter.MediaWriterStatus writeChunk(java.io.OutputStream ds,java.nio.ByteBuffer data,int size, long timecode,byte type)
    So from what I can see, the only difference is this return type "com.wowza.wms.mediawriter.MediaWriterStatus" that my IDE doesn't want to import. I feel I need some library upgrade or something but I can't find any documentation about it - I Have an 1 year old version of Wowza IDE 2.

    Any help would be appreciated,
    Best regards,
    Hane

  2. #2
    Join Date
    May 2013
    Posts
    680

    Default

    Is your project in eclipse referencing the Wowza 3 libraries at compile time? If so, you can import the new Wowza 4 jar files into to your java build path->libraries.

  3. #3
    Join Date
    Jun 2013
    Posts
    6

    Default

    Uhh forgot that these .jar were under the WowzaStreamingEngine/lib directory (i'm not very good with eclipse&java). I removed these old .jar and added the new one and now it works like a charm !
    Thank you !!

  4. #4
    Join Date
    May 2013
    Posts
    680

    Default

    Great, glad you got it working. Thanks for the update.

Similar Threads

  1. Google Compute Engine trouble when trying to set up wowza streaming engine
    By CBBrewCo in forum Wowza Streaming Engine in the Cloud
    Replies: 1
    Last Post: 06-27-2014, 02:55 PM
  2. Writing custom input module for wowza streaming engine
    By dnyanesh.gate in forum Tutorials
    Replies: 6
    Last Post: 06-20-2014, 06:39 PM
  3. com.wowza.wms.module.IModuleOnHTTPMPEGDashSession doen't exists
    By Gpolox in forum Server-side Modules and Code Samples Discussion
    Replies: 5
    Last Post: 06-29-2013, 05:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •