Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Live steam will record, but i cant view it live

  1. #1

    Default Live steam will record, but i cant view it live

    I am having a problem with my live steam. I set the stream file and i can record the stream file and play it back. but i cannot use one of the test players to see the live stream. I do have another thread below this one. If someone has more insight on this please give me a hand

    Thank you in advance!

    Joe

  2. #2

    Default

    Hi Joe,
    Are you following this guide:
    How to re-stream video from an IP camera (RTSP/RTP re-streaming)

    What example player are you testing playback in?
    What is the playback URL you are using?

    For example, if you are testing playback in the [install-dir]/examples/LiveVideoStreaming/FlashRTMPPlayer/player.html, you would use
    Server:rtmp://[wowza-ip]/live
    Stream: someFile.stream
    Or, FlashHTTPPlayer would be:
    http://[wowza-ip]:1935/live/someFile.stream/manifest.f4m
    NOTE: the .stream file should contain the full URL to the camera. For example:
    rtsp://userName:password@[camera-ip-address]:554/cam/realmonitor?channel=[CHANNEL]&subtype=1
    Salvadore

  3. #3

    Default

    C:\Program Files (x86)\Wowza Media Systems\Wowza Streaming Engine 4.0.0\content
    this is where the recorded video plays.

    My stream file has the full URL for the camera with the username and password, it show as active in the incoming streams section on the Wowza streaming engine.

    I am trying to test the playback through the test players button on the streaming engine

    i am not sure what you mean by the playback URL can you explain the more please

    Thank.

    Joe

  4. #4

    Default

    Okay, so if testing in an example player through the Streaming Manager, what are you entering as the "Media File Name"?
    It should be the .stream file, for example camera.stream, or what ever the name of your .stream file is.

    Salvadore

  5. #5

    Default

    my stream file name is cam.stream

  6. #6

    Default

    yes, sorry, I was thinking about the VoD player, it should have been "Stream" instead of "Media File Name"

    So the stream gets recorded but you can not view it in the example player. Do you still get the same error when attempting to play the stream?
    WARN Server comment - RTPSession DescriptionDAtaProviderBasicRTPSWorker.process
    authentication required [401] username and password not available
    Or do you get any other errors?

    Salvadore

  7. #7

    Default

    [CODE] Info Server comment - MPEGDashWirterHandler.createChunkM$S[Crew/_definst_/cam.stream]: Add chunk: id:9 typem4s_video v/k:194/1 duration 340000
    this is what it is putting out now.

    if i use the adobe test player it gives me the error 2048 on the bottom of the player.

    if i go to the examples folder and open one of the test players ( I uesd the HTTP Player) it says "Source stream or file could not be found or access was denied"

    this is the URL http://localhost:1935/Crew/cam/manifest.f4m

  8. #8

    Default

    Try this URL
    http://localhost:1935/Crew/cam.stream/manifest.f4m
    Salvadore

  9. #9

    Default

    Salvadore that worked!!!! I can steam it through that HTTP player now

  10. #10

    Default

    Great! I am glad it is working for you now! Thanks for the update.

    Salvadore

Page 1 of 2 12 LastLast

Similar Threads

  1. Live streaming pay per view
    By steveitl in forum General Forum
    Replies: 2
    Last Post: 09-14-2012, 08:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •