Results 1 to 3 of 3

Thread: Single stream of Smooth Streaming not working

  1. #1
    Join Date
    Feb 2014
    Posts
    129

    Default Single stream of Smooth Streaming not working

    Hi
    This is a strange one.
    I have successfully managed to stream Smooth Streaming ABR to a silverlight player on my website with the transcoder option. I called this application "startup2"
    Then I tried to do the same thing but without the transcoder under application "startup1". I can not play this

    Obviously with the ABR version I am using a smil file

    Question is, does a single stream of Smooth also need a smil file? I thought not
    When I use the test smooth streaming player included in Wowza I can connect and view the stream http://IP ADDRESS/startup1/myStream/Manifest but using this source in my website player it does not work... "could not open media xxx manifest location, an error 4001 occurred"

    I also created a smil file for this application and removed all but the single stream like this but it too did not work
    <?xml version="1.0" encoding="UTF-8"?>
    <smil title="">
    <body>
    <switch>
    <video height="360" src="myStream"
    systemLanguage="en" width="640">
    <param name="videoBitrate" value="867000" valuetype="data"></param>
    </video>

    </switch>
    </body>
    </smil>

    So I am starting to think that it is a limitation of the silverlight player I am using ( from Expression Encoder templates)? Is this possible, that it does not support single stream Smooth Streaming ?

  2. #2

    Default

    Hi,

    the url you have for your single rendition silverlight stream does look correct so it may be the player.

    Please try with the sample players here, http://www.wowza.com/gettingstarted or the test players in the Wowza Streaming Engine Manager.

    Some things to note,

    Silverlight does require that the stream has both an audio and video track.
    The video key frame interval should be between 1 & 4 seconds.
    Make sure you are running the latest Silverlight plugin for your browser.

    Roger.

  3. #3
    Join Date
    Feb 2014
    Posts
    129

    Default

    Hi
    Yes, I already tried the test players and they work.
    There is audio and video. The video key frame interval is the same as whatevcer is set for the ABR testing I was doing, I did not change it.
    Plugin ok,

    So it must be the player.

Similar Threads

  1. nDVR not working with Smooth Streaming
    By german in forum AddOn: Wowza nDVR
    Replies: 1
    Last Post: 01-09-2012, 01:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •