Results 1 to 5 of 5

Thread: Application created in Enginemanager cannot be found with sftp client!

  1. #1

    Default Application created in Enginemanager cannot be found with sftp client! [Solved]

    Hi,

    I just created a new application by the engine manager, when I test the player (in the manager) I can see the video.
    But If I try accessing the application folder with a sftp client, the applications folder is empty (/usr/local/WowzaStreamingEngine/).

    So I was wondering where I can put my own videos?

    Have a nice week,
    David.
    Last edited by David_Lafeuille; 03-06-2014 at 12:39 AM. Reason: SOLVED

  2. #2
    Join Date
    Jun 2012
    Posts
    724

    Default

    Hello,

    When creating an application, you have the option to specify the application's content folder.
    The default content folder is [wowza-install-dir]/content/.

    It is described in step 3.c from the How to set up video on demand streaming tutorial article.

    Zoran

  3. #3

    Default

    Hello Zoran,

    Thank you for your answer!

    I listed the content of /content/ folder using the command find ... and I could see the sample.mp4
    but If I try to access it using FileZilla, for example, I have "Empty directory listing"

    I used the command ls -a /usr/local/WowzaStreamingEngine-4.0.1 and it clearly shows that "applications, content, legal, transcoder, conf,..."folders have their content hidden.

    Any glue on this ?

    David.

  4. #4

    Default

    Hi David,

    Wowza runs as the root user so will create or modify any folders or files as that user. If you are logging in as a different user then that user may not have permissions to access the folders.

    I would suggest the following, as root user.

    ssh in and cd to the /usr/local/WowzaStreamingEngine folder.

    run the following as root user.

    find . -type d -exec chmod 775 {} \;
    This will set the permissions on the directories so at least you can view & download the files.

    You can also fun the following command in the main Wowza install dir to change the owner on everything.

    chown -R <your-username>:<your-group-name> *
    New files will still be created as the root user but existing files will be owned and modified by you.

    Roger.

  5. #5

    Default

    Thank you Roger, it works as a charm!
    Have a nice day,
    David.

Similar Threads

  1. Problem in enginemanager
    By kleberrvf in forum General Forum
    Replies: 3
    Last Post: 09-18-2014, 07:12 AM
  2. enginemanager not listening on port 8088?
    By dmahoney in forum Server Administration
    Replies: 2
    Last Post: 07-25-2014, 11:13 AM
  3. http://localhost:8088/enginemanager
    By AhmedFaraz in forum General Forum
    Replies: 2
    Last Post: 07-09-2014, 09:11 PM
  4. Replies: 2
    Last Post: 02-27-2014, 09:35 AM
  5. Replies: 1
    Last Post: 02-18-2014, 07:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •