Results 1 to 2 of 2

Thread: No audio while re-streaming with RTP/RTCP

  1. #1
    Join Date
    Nov 2012
    Posts
    12

    Default No audio while re-streaming with RTP/RTCP

    Hello,

    I have 2 streams, audio (AAC) and video (H264), which I re-stream using Wowza. The media is streamed using RTP, while I also have RTCP per stream. Here is a wowza log, after my encoder sends RTSP announce/setup and play

    INFO rtsp connect 854861329 -
    INFO server comment - sortPackets[1]: sortBufferSize:500
    INFO stream create - -
    INFO rtsp announce 854861329 -
    INFO server comment - RTPUDPTransport.bind[53158ecb69702d46f11e0000/_definst_]: 0.0.0.0/0.0.0.0:6970
    INFO server comment - RTPUDPTransport.bind[53158ecb69702d46f11e0000/_definst_]: 0.0.0.0/0.0.0.0:6971
    INFO server comment - RTPUDPTransport.bind[53158ecb69702d46f11e0000/_definst_]: 0.0.0.0/0.0.0.0:6972
    INFO server comment - RTPUDPTransport.bind[53158ecb69702d46f11e0000/_definst_]: 0.0.0.0/0.0.0.0:6973
    INFO stream publish 53158f0069702d46f1200000.sdp -
    INFO rtsp publish 854861329 -
    INFO server comment - UDPTransport.firstPacket: bind:0.0.0.0/0.0.0.0:6972 msg:/46.129.80.198:39165
    INFO session connect-pending 31.55.16.164 -
    INFO session connect 31.55.16.164 -
    INFO server comment - sortPackets[1]: sortBufferSize:500
    INFO stream create - -
    INFO server comment - RTCPHandler.sendFirstRTCPRR[721386311,6973,/46.129.80.198:43360]
    INFO server comment - UDPTransport.firstPacket: bind:0.0.0.0/0.0.0.0:6973 msg:/46.129.80.198:43360
    INFO server comment - LiveStreamPacketizerSanJose.init[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp]: chunkDurationTarget: 10000
    INFO server comment - LiveStreamPacketizerSanJose.init[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp]: chunkDurationTolerance: 500
    INFO server comment - LiveStreamPacketizerSanJose.init[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp]: playlistChunkCount:4
    INFO server comment - MediaStreamMap.getLiveStreamPacketizer[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp]: Create live stream packetizer: sanjosestreamingpacketizer:53158f0069702d46f1200000.sdp
    INFO server comment - SanJosePacketHandler.startStream[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp]
    INFO server comment - LiveStreamPacketizerSanJose.handlePacket[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp]: Video codec: H264
    INFO server comment - LiveStreamPacketizerCupertino.init[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp]: chunkDurationTarget: 10000
    INFO server comment - LiveStreamPacketizerCupertino.init[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp]: audioGroupCount: 3
    INFO server comment - LiveStreamPacketizerCupertino.init[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp]: playlistChunkCount:3
    INFO server comment - MediaStreamMap.getLiveStreamPacketizer[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp]: Create live stream packetizer: cupertinostreamingpacketizer:53158f0069702d46f1200000.sdp
    INFO server comment - CupertinoPacketHandler.startStream[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp]
    INFO server comment - LiveStreamPacketizerCupertino.handlePacket[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp]: Video codec:H264 isCompatible:true
    INFO server comment - LiveStreamPacketizerCupertino.handlePacket[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp][avc1.66.31]: H.264 Video info: {H264CodecConfigInfo: codec:H264, profile:Baseline, level:3.1, frameSize:1280x720, displaySize:1280x720}
    INFO server comment - RTCPHandler.sendFirstRTCPRR[2403357502,6971,/46.129.80.198:58597]
    INFO server comment - UDPTransport.firstPacket: bind:0.0.0.0/0.0.0.0:6971 msg:/46.129.80.198:58597
    INFO server comment - LiveStreamPacketizerSanJose.handlePacket[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp]: Audio codec: AAC
    INFO server comment - LiveStreamPacketizerCupertino.handlePacket[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp]: Audio codec:AAC isCompatible:true
    INFO server comment - LiveStreamPacketizerCupertino.handlePacket[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp][mp4a.40.4]: AAC Audio info: {AACFrame: codec:AAC, channels:1, frequency:8000, samplesPerFrame:1024, objectType:LongTermPrediction}
    INFO server comment - UDPTransport.firstPacket: bind:0.0.0.0/0.0.0.0:6970 msg:/46.129.80.198:55623
    INFO stream play 53158f0069702d46f1200000.sdp -
    INFO server comment - LiveStreamPacketizerSanJose.endChunkTS[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp]: Add chunk: id:1 a/v/k:44/181/6 duration:6687
    INFO server comment - LiveStreamPacketizerCupertino.endChunkTS[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp]: Add chunk: id:1 mode:TS[H264,AAC] a/v/k:14/180/6 duration:6687
    INFO server comment - LiveStreamPacketizerSanJose.endChunkTS[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp]: Add chunk: id:2 a/v/k:82/301/10 duration:10149
    INFO server comment - LiveStreamPacketizerCupertino.endChunkTS[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp]: Add chunk: id:2 mode:TS[H264,AAC] a/v/k:27/300/10 duration:10149
    INFO server comment - LiveStreamPacketizerSanJose.endChunkTS[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp]: Add chunk: id:3 a/v/k:77/301/10 duration:10153
    INFO server comment - LiveStreamPacketizerCupertino.endChunkTS[53158ecb69702d46f11e0000/_definst_/53158f0069702d46f1200000.sdp]: Add chunk: id:3 mode:TS[H264,AAC] a/v/k:25/300/10 duration:10153

    However, when I play the video using flash player, I only get video, but no Audio. I don't see any errors in the logs regarding this. I saw some related posts, but no clear answer so far why this might happen.

    Perhaps this is related http://www.wowza.com/forums/showthre...AC_LTP-support
    since above in the log the is "objectType:LongTermPrediction" which stays for AAC_LTP.
    Last edited by dr.gigabit; 03-04-2014 at 11:12 AM.

  2. #2
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    Hi,
    This may well be the case with AAC LTP. Did you attempt playback on different players? See if VLC is able to play over RTSP for instance.
    Also, it does look like the audio is packetized, so this may or may not playback with HTTP streaming players like iOS devices or Silverlight player
    for instance.
    Would you provide info about the camera manufacturer and model? Perhaps we can find others that have tried this model.

    Daren

Similar Threads

  1. Live Streaming of Audio Only starting with RTP/PCMA
    By macropanther in forum Live Streaming and Encoder Discussion
    Replies: 4
    Last Post: 05-22-2013, 06:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •