Results 1 to 5 of 5

Thread: Transcoded stream won't start on CentOS 5.8

  1. #1

    Default Transcoded stream won't start on CentOS 5.8

    I have a WSE Server version 4.0.1 freshly installed on CentOS 5.8.
    uname output:
    Linux 2.6.18-308.13.1.el5 #1 SMP Tue Aug 21 17:10:18 EDT 2012 x86_64 x86_64 x86_64 GNU/Linux

    release output:
    CentOS release 5.8 (Final)

    Java -v output:
    java version "1.6.0_37"
    Java(TM) SE Runtime Environment (build 1.6.0_37-b06)
    Java HotSpot(TM) 64-Bit Server VM (build 20.12-b01, mixed mode)

    When I publish to the "live" application, I have no trouble seeing the stream in the test viewer as well as my flash viewer in our site, but as soon as I turn on any form of transcoding, publishing stops. I can see from the logging without the transcoding that each chunk of content is logged as the stream progresses. With the default transcoding enabled, with either the transcode or transrate template selected, as soon as the publishing software connects, everything stops.

    When I do the same setup/test on a local VM that has ubuntu 13.10, it works just fine, transcoding to multiple rates and adding the Wowza logo in whatever location the template specifies.

    There are no exceptions logged, and the only stuff about transcoding that's logged is as follows:
    wowzastreamingengine_access.log:2014-03-06	16:05:41	EST	comment	server	INFO	200	-	Transcoder Streams Available: 1	-	-	-	0.738	-	-	-	-	-	-	-	-	-
    wowzastreamingengine_access.log:2014-03-06	16:05:41	EST	comment	server	INFO	200	-	Transcoder Watermark: Yes	-	-	-	0.738	-	-	-	-	-	-	-	-	-
    wowzastreamingengine_access.log:2014-03-06	16:05:46	EST	comment	server	INFO	200	-	TranscoderSessionNative.loadLibrary: Load transcoder list file: /usr/local/WowzaStreamingEngine/lib-native/linux64/transcoder.list	-	-	-	5.68	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
    Logging in my application for when the stream attempts to publish looks like:
    2014-03-06	16:31:11	EST	connect	session	INFO	401	10.1.3.226	-	_defaultVHost_	live	_definst_	0.249	[any]	1935	rtmp://servername:1935/live	10.1.3.226	rtmp	rtmp://servername:1935/live	FMLE/3.0 (compatible; FMSc/1.0)	1319791328	3253	3073	-	-	-	-	-	-	-	-	-	-	-	-	-	rtmp://servername:1935/live	-
    2014-03-06	16:31:11	EST	disconnect	session	INFO	200	1319791328	-	_defaultVHost_	live	_definst_	0.375	[any]	1935	rtmp://servername:1935/live	10.1.3.226	rtmp	rtmp://servername:1935/live	FMLE/3.0 (compatible; FMSc/1.0)	1319791328	3269	3331	-	-	-	-	-	-	-	-	-	-	-	-	-	rtmp://servername:1935/live	-
    2014-03-06	16:31:11	EST	connect-pending	session	INFO	100	10.1.3.226	-	_defaultVHost_	live	_definst_	0.041	[any]	1935	rtmp://servername:1935/live?authmod=adobe&user=username	10.1.3.226	rtmp	rtmp://servername:1935/live?authmod=adobe&user=username	FMLE/3.0 (compatible; FMSc/1.0)	2011944756	3334	3073	-	-	-	-	-	-	-	-	-	-	-	-	-	rtmp://servername:1935/live	authmod=adobe&user=username
    2014-03-06	16:31:11	EST	connect	session	INFO	401	10.1.3.226	-	_defaultVHost_	live	_definst_	0.042	[any]	1935	rtmp://servername:1935/live?authmod=adobe&user=username	10.1.3.226	rtmrtmp://servername:1935/live?authmod=adobe&user=username	FMLE/3.0 (compatible; FMSc/1.0)	2011944756	3334	3073	-	-	-	-	-	-	-	-	-	-	-	-	-	rtmp://servername:1935/live	authmod=adobe&user=username
    2014-03-06	16:31:12	EST	disconnect	session	INFO	200	2011944756	-	_defaultVHost_	live	_definst_	0.128	[any]	1935	rtmp://servername:1935/live?authmod=adobe&user=username	10.1.3.226	rtmp	rtmp://servername:1935/live?authmod=adobe&user=username	FMLE/3.0 (compatible; FMSc/1.0)	2011944756	3350	3389	-	-	-	-	-	-	-	-	-	-	-	-	-	rtmp://servername:1935/live	authmod=adobe&user=username
    2014-03-06	16:31:12	EST	connect-pending	session	INFO	100	10.1.3.226	-	_defaultVHost_	live	_definst_	0.042	[any]	1935	rtmp://servername:1935/live?authmod=adobe&user=username&challenge=######==&response=######==&opaque=######==	10.1.3.226	rtmp	rtmp://servername:1935/live?authmod=adobe&user=username&challenge=######==&response=######==&opaque=######==	FMLE/3.0 (compatible; FMSc/1.0)	1451883909	3543	3073	-	-	-	-	-	-	-	-	-	-	-	-	-	rtmp://servername:1935/live	authmod=adobe&user=username&challenge=######==&response=######==&opaque=######==
    2014-03-06	16:31:12	EST	connect	session	INFO	200	10.1.3.226	-	_defaultVHost_	live	_definst_	0.044	[any]	1935	rtmp://servername:1935/live?authmod=adobe&user=username&challenge=######==&response=######==&opaque=######==	10.1.3.226	rtmp	rtmp://servername:1935/live?authmod=adobe&user=username&challenge=######==&response=######==&opaque=######==	FMLE/3.0 (compatible; FMSc/1.0)	1451883909	3543	3073	-	-	-	-	-	-	-	-	-	-	-	-	-	rtmp://servername:1935/live	authmod=adobe&user=username&challenge=######==&response=######==&opaque=######==
    2014-03-06	16:31:12	EST	create	stream	INFO	200	-	-	_defaultVHost_	live	_definst_	0.029	[any]	1935	rtmp://servername:1935/live?authmod=adobe&user=username&challenge=######==&response=######==&opaque=######==	10.1.3.226	rtmp	rtmp://servername:1935/live?authmod=adobe&user=username&challenge=######==&response=######==&opaque=######==	FMLE/3.0 (compatible; FMSc/1.0)	1451883909	3694	3413	1	0	0	0	-	-	-	-	-	-	rtmp://servername:1935/live	rtmp://servername:1935/live	-	rtmp://servername:1935/live	authmod=adobe&user=username&challenge=######==&response=######==&opaque=######==
    2014-03-06	16:31:12	EST	publish	stream	INFO	200	MattStream	-	_defaultVHost_	live	_definst_	0.083	[any]	1935	rtmp://servername:1935/live?authmod=adobe&user=username&challenge=######==&response=######==&opaque=######==	10.1.3.226	rtmp	rtmp://servername:1935/live?authmod=adobe&user=username&challenge=######==&response=######==&opaque=######==	FMLE/3.0 (compatible; FMSc/1.0)	1451883909	3790	3608	1	0	0	0	MattStream	videoKeyframeFrequency=5&totalDatarate=4128	-	-	-	-	rtmp://servername:1935/live/MattStream?videoKeyframeFrequency=5&totalDatarate=4128	rtmp://servername:1935/live/MattStream	videoKeyframeFrequency=5&totalDatarate=4128	rtmp://servername:1935/live	authmod=adobe&user=username&challenge=######==&response=######==&opaque=######==
    2014-03-06	16:31:13	EST	comment	server	INFO	200	-	TranscoderSessionNative.loadLibrary: Load transcoder list file: /usr/local/WowzaStreamingEngine/lib-native/linux64/transcoder.list	-	-	-	4.718	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
    Anybody else seen something like this? I was able to use the transcoding on my 3.6.x harness, and need to get the basic setup working so I can move to customizing the transcoding. I didn't see anything about hardware or software requirements that would indicate this environment is a problem, but it would be good to know if I'm barking up a wrong tree.

  2. #2

    Default

    Another thing to note is that the attempt to stream to the server with the Transcoder add-on enabled, hangs the related application. To attempt to stream anything after that requires restarting the app or the server, although it seems to accept the connections.

  3. #3

    Default

    Hi Matt.

    I've come across exactly the same behaviour with CentOS 5.8. I've just tested on CentOS 6.4 and the latest version of Linux Mint and it works fine. We had been using the transcoder in production with CentOS 5.8 with Wowza 3.6.x without issue.

    It would be useful to have an officially supported list of linux distros/versions, not sure if that's something Wowza can supply ... ?

    Yours,

    Henry

  4. #4

    Default

    Ugh,
    Thanks Henry. I was afraid it was something like that, but was hoping it wasn't, since upgrading my distro is something of a pain.

    How about it Wowza folks? Any chance of a list of supported distros, or maybe a dependency that I'm missing and can be resolved on CentOS?

  5. #5
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    Hi, Matt,

    No, there isn't such a list. Most Linux distros work for most use cases, but the Wowza Transcoder is more limited.

    Richard

Similar Threads

  1. Replies: 2
    Last Post: 08-09-2012, 09:55 AM
  2. Replies: 1
    Last Post: 03-05-2012, 07:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •