Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Wowza 4.0.1 VOD streaming error: File is missing 'moov' atom.

  1. #1
    Join Date
    Mar 2014
    Posts
    2

    Post Wowza 4.0.1 VOD streaming error: File is missing 'moov' atom.

    Hi Wowza Team,

    I upgraded from wowza 3.6 to wowza 4.0.1 and getting below error when i try to run it using file:///C:/Program%20Files%20%28x86%29/Wowza%20Media%20Systems/Wowza%20Streaming%20Engine%204.0.1/examples/VideoOnDemandStreaming/FlashRTMPPlayer/player.html, I dropped the file in content folder -

    2014-03-11 11:59:56 EDT comment server WARN 404 audio-video.flv MediaReaderH264.open[2]: java.lang.Exception: QTUtils.parseQTMediaContainer: File is missing 'moov' atom.: java.lang.Exception: QTUtils.parseQTMediaContainer: File is missing 'moov' atom.|at com.wowza.wms.mediareader.h264.util.QTUtils.parseQTMediaContainer(QTUtils.java:195)|at com.wowza.wms.mediareader.h264.MediaReaderH264.open(MediaReaderH264.java:319)|at com.wowza.wms.stream.file.PlaylistPlayer.play(PlaylistPlayer.java:777)|at com.wowza.wms.stream.file.MediaStreamFilePlay.play(MediaStreamFilePlay.java:111)|at com.wowza.wms.response.ResponseStreams.output(ResponseStreams.java:51)| - - - 714.11

    we have been using wowza for years, while integrating with our application I am seeing below error, even though file exists there at location C:/myfolder/flash/9af2368dc/. but in the logs i am seeing it doesn't show ".flv" extension with the file name. Am I missing some configuration while using wowza 4.0.1.

    2014-03-11 11:56:49 EDT comment server WARN 200 - MediaReaderH264.open[vod/_definst_]: Not found: C:/myfolder/flash/9af2368dc/audio-video.: java.io.FileNotFoundException: C:\myfolder\flash\9af2368dc\audio-video (The system cannot find the file specified)|at java.io.RandomAccessFile.open(Native Method)|at java.io.RandomAccessFile.<init>(RandomAccessFile.java:233)|at com.wowza.io.WowzaRandomAccessFile.<init>(WowzaRandomAccessFile.java:12)|at com.wowza.io.DirectRandomAccessReader.open(DirectRandomAccessReader.java:222)|at com.wowza.wms.mediareader.h264.MediaReaderH264.open(MediaReaderH264.java:250)| - - - 526.661 - - - - - - - - - - - - - - - - - - - - - - - - -


    here is the application.xml file -

    <?xml version="1.0" encoding="UTF-8"?>

    <Root>



    <Application>



    <Connections>



    <AutoAccept>true</AutoAccept>



    <AllowDomains/>



    </Connections>



    <Streams>



    <StreamType>default</StreamType>



    <StorageDir>C:/myfolder/flash</StorageDir>



    <Properties>


    <Property>


    <Name>seekTarget</Name>


    <Value>enhanced</Value>


    </Property>


    <Property>


    <Name>maxPendingSeekRequests</Name>


    <Value>0</Value>


    <Type>Integer</Type>


    </Property>


    </Properties>


    </Streams>



    <HTTPStreamers>cupertinostreaming,smoothstreaming</HTTPStreamers>



    <SharedObjects>



    <StorageDir/>



    </SharedObjects>



    <Client>



    <IdleFrequency>-1</IdleFrequency>



    </Client>



    <Modules>



    <Module>



    <Name>base</Name>



    <Description>Base</Description>



    <Class>com.wowza.wms.module.ModuleCore</Class>



    </Module>



    <Module>



    <Name>properties</Name>



    <Description>Properties</Description>



    <Class>com.wowza.wms.module.ModuleProperties</Class>



    </Module>



    <Module>



    <Name>logging</Name>



    <Description>Client Logging</Description>



    <Class>com.wowza.wms.module.ModuleClientLogging</Class>



    </Module>



    <Module>



    <Name>FLVPlayback</Name>



    <Description>FLVPlayback</Description>



    <Class>com.wowza.wms.module.ModuleFLVPlayback</Class>



    </Module>



    </Modules>



    <Properties>



    <!-- Properties defined here will be added to the IApplication.getProperties() and IApplicationInstance.getProperties() collections -->



    <!--
    <Property>
    <Name></Name>
    <Value></Value>
    </Property>
    -->



    </Properties>



    <HTTPStreamer>
    <Property>
    <Name>cupertinoChunkDurationTarget</Name>
    <Value>10000</Value>
    <Type>Integer</Type>
    </Property>
    </HTTPStreamer>


    </Application>
    </Root>
    Thanks
    Ritu
    Last edited by rkothari; 03-11-2014 at 09:55 AM.

  2. #2

    Default

    You may be getting this error if you are trying to playback a file that has H.264 video but in a.flv container, where as the file isn't an mp4 file. Try using flv:someFile.flv
    Note: .flv is not supported on iOS or Silverlight light clients.

    Salvadore

  3. #3
    Join Date
    Sep 2012
    Posts
    6

    Default

    Our files are h.264 within FLV. Is this change a new requirement for 4.x as these files play back fine in 3.x without the flv: prepended. We only use these streams within a flash player using FLVPlayback and don't stream them to iOS.

  4. #4
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    Yes, the default prefix has changed to "mp4:", but you can revert in the Wowza Manager > Server Setup > Basic tab > "Default Stream Prefix ". Change that to "flv" and re-start the server.

    Richard

  5. #5
    Join Date
    Sep 2012
    Posts
    6

    Default

    Quote Originally Posted by rrlanham View Post
    Yes, the default prefix has changed to "mp4:", but you can revert in the Wowza Manager > Server Setup > Basic tab > "Default Stream Prefix ". Change that to "flv" and re-start the server.

    Richard
    Great thank you so much

  6. #6
    Join Date
    Mar 2014
    Posts
    2

    Default

    Thanks everybody for the quick response!

  7. #7
    Join Date
    Apr 2014
    Posts
    2

    Default

    Hello!

    Can I reach this "Default Stream Prefix" property from config files? I mean without the Manager app?
    I having problems with the Manager application. (It does not accept user/pass for some reason)

    Thanks
    Viktor

  8. #8

    Default

    Hi Viktor, you can change this back to .flv in the [install-dir]/conf/Server.xml file, under <Streams>/<DefaultStreamPrefix>
    Also, please see this comment regarding the admin.password issue

    Salvadore

  9. #9
    Join Date
    Apr 2014
    Posts
    2

    Default

    Hello,

    I put this to the Server.xml before <ServerListeners> tag:

    <Streams>
    <DefaultStreamPrefix>flv</DefaultStreamPrefix>
    </Streams>

    And it works! Thank You Salvadore!

    Viktor

  10. #10

    Default

    Great, thanks for the update.

    Salvadore

Page 1 of 2 12 LastLast

Similar Threads

  1. VOD: File is missing 'moov' atom Module
    By dhamibirendra in forum Video On Demand Streaming Discussion
    Replies: 12
    Last Post: 05-25-2013, 07:03 AM
  2. 'moov' Atom Error
    By koobos in forum Live Streaming and Encoder Discussion
    Replies: 3
    Last Post: 10-10-2012, 05:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •