Results 1 to 4 of 4

Thread: Wowza does not start from Eclipse

  1. #1

    Question Wowza does not start from Eclipse

    Hi!

    Win7, eclipse-standard-kepler-SR2-win32-x86_64, Wowza Streaming Engine 4.0.1, jdk 1.7.0_51

    Trying to run template created by Wizard. Wowza does not start, java console says:

    Error starting: java.lang.reflect.InvocationTargetException
    java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.wowza.wms.bootstrap.Bootstrap.startServer(Bootstrap.java:555)
    at com.wowza.wms.bootstrap.Bootstrap.main(Bootstrap.java:67)
    Caused by: java.lang.NoClassDefFoundError: org/apache/commons/lang/SystemUtils
    at com.wowza.wms.bootstrap.BootstrapSystemTuningInfo.getSystemTuningInfo(BootstrapSystemTuningInfo.java :81)
    at com.wowza.wms.server.ServerTuningHandler.<init>(ServerTuningHandler.java:248)
    at com.wowza.wms.server.Server.<init>(Server.java:862)
    at com.wowza.wms.server.Server.getInstance(Server.java:907)
    at com.wowza.wms.server.Server.start(Server.java:956)
    ... 6 more
    Caused by: java.lang.ClassNotFoundException: org.apache.commons.lang.SystemUtils
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 11 more

  2. #2

    Default

    To resolve this error, right click on the project in the left menu of eclipse and choose "properties"

    Select Run/Debug Settings on the left, highlight the launch configuration and click "Edit" on the right

    Select the "Arguments" tab and ensure the following line is added to the list:
    For Windows ‐Dcom.wowza.wms.native.base="win"
    For Mac ‐Dcom.wowza.wms.native.base="osx"

    Click ok

    Salvadore

  3. #3

    Default

    Thanks a lot.

    It solved it.

  4. #4

    Default

    Wonderful! Glad I could help and thanks for the update.

    Salvadore

Similar Threads

  1. Unable to install Wowza Eclipse Software Update plugin in Eclipse
    By runenes in forum Wowza Streaming Server Java API
    Replies: 9
    Last Post: 07-25-2014, 06:23 AM
  2. Wowza plugin for Eclipse
    By GraemeBull in forum Wowza Streaming Server Java API
    Replies: 4
    Last Post: 03-19-2014, 02:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •