Results 1 to 3 of 3

Thread: Wowza 3.6.3 HLS issue

  1. #1
    Join Date
    Sep 2011
    Posts
    2

    Default Wowza 3.6.3 HLS issue

    Hi,

    I am using JWPlayer 6.8.x and trying to get HLS to work. When I reference the sample.mp4 file for an rtmp stream on the desktop it work. When I them move to an iOS device and use the following URI I get the following errors.

    URIs:
    URI (RTMP) works:
    rtmp://{servername}:1935/vod/mp4:vod/sample.mp4

    URI (HLS) doesn't work:
    http://{servername}:1935/vod/mp4:vod/sample.mp4/playlist.m3u8

    Errors:
    iOS gives the error "The operation could not be completed"

    JWPlayer gives the error "Error loading media: FIle could not be played"

    Wowza error log shows the following:
    WARN server comment 2014-03-20 10:31:52 - - - - - 7.006 - - -- - - - - HTTPStreamerAdapterCupertinoStreamer.onPlaylist: Stream not found [vod/mp4:vod/sample.mp4/playlist.m3u8]: sample.mp4
    WARN server comment 2014-03-20 10:31:52 - - - - - 7.029 - - -- - - - - HTTPStreamerAdapterCupertinoStreamer.onPlaylist: Stream not found [vod/mp4:vod/sample.mp4/chunklist_w362048998.m3u8]: sample.mp4

    Not sure what I am doing wrong. Once question I have is that there is no "playlist.m3u8" file delivered for testing. I assume this file is being generated at time of need by Wowza. Is this correct? If not and I do need a physical playlist.m3u8 file what is the process to generate that?

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Where is sample.mp4 located? Is it in the root of /content folder (StorageDir) of the application, or is it in a subfolder of /content named "vod". If it is in the root of the content folder, the HLS URL should be:

    http://{servername}:1935/vod/mp4:sample.mp4/playlist.m3u8
    If it is in a subfolder named "vod" then the url should be:

    http://{servername}:1935/vod/_definst_/mp4:vod/sample.mp4/playlist.m3u8
    Richard

  3. #3
    Join Date
    Jul 2012
    Posts
    299

    Default

    Chad,

    It looks like you have the "mp4:" prefix in the application instance section of the streaming URL. Try this:

    http://{servername}:1935/vod/_definst_/mp4:vod/sample.mp4/playlist.m3u8
    As a resource, take a look at this article:

    How to use LongTail JW Player 6 with Wowza Media Server

    -Tim

Similar Threads

  1. very urgent - HLS stream issue.
    By Harrywilson in forum Live Streaming and Encoders
    Replies: 2
    Last Post: 07-14-2014, 02:08 PM
  2. HLS playback issue on Android 4.3
    By Vincent Chan in forum Live Streaming and Encoder Discussion
    Replies: 7
    Last Post: 09-02-2013, 04:14 AM
  3. HLS issue on ipad
    By Finale in forum Video On Demand Streaming Discussion
    Replies: 3
    Last Post: 07-26-2013, 03:33 AM
  4. Issue in HLS streaming
    By sudhir in forum Live Streaming and Encoder Discussion
    Replies: 4
    Last Post: 01-21-2013, 12:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •