Results 1 to 4 of 4

Thread: Using wowza streaming engine UI - my server CPU takes more than 50 percent

  1. #1

    Default Using wowza streaming engine UI - my server CPU takes more than 50 percent


    I start using Wowza streaming engine. I have to monitoring my server cpu percentage in command line.
    When i create a new app or i restart the app after any changes or refresh the UI the CPU goes to 50%.
    If i enable the Transcoder addon the CPU goes to 100% or some times the server stops automatically.
    Last edited by vinodkumarc; 03-24-2014 at 01:36 AM. Reason: To re correct the title

  2. #2
    Join Date
    Feb 2014


    What is the hardware specs, specifically CPU? Is it an Amazon Ec2? If so, you can't use the lower ones with transcoder effectively.

  3. #3


    cat /proc/meminfo

    MemTotal: 1015428 kB
    MemFree: 85104 kB
    Buffers: 2264 kB
    Cached: 78708 kB
    SwapCached: 0 kB
    Active: 857620 kB
    Inactive: 27992 kB
    Active(anon): 804700 kB
    Inactive(anon): 220 kB
    Active(file): 52920 kB
    Inactive(file): 27772 kB
    Unevictable: 0 kB
    Mlocked: 0 kB
    SwapTotal: 0 kB
    SwapFree: 0 kB
    Dirty: 464 kB
    Writeback: 0 kB
    AnonPages: 804672 kB
    Mapped: 19960 kB
    Shmem: 280 kB
    Slab: 19936 kB
    SReclaimable: 6664 kB
    SUnreclaim: 13272 kB
    KernelStack: 3104 kB
    PageTables: 8768 kB
    NFS_Unstable: 0 kB
    Bounce: 0 kB
    WritebackTmp: 0 kB
    CommitLimit: 507712 kB
    Committed_AS: 863876 kB
    VmallocTotal: 34359738367 kB
    VmallocUsed: 2008 kB
    VmallocChunk: 34359736311 kB
    HardwareCorrupted: 0 kB
    AnonHugePages: 0 kB
    HugePages_Total: 0
    HugePages_Free: 0
    HugePages_Rsvd: 0
    HugePages_Surp: 0
    Hugepagesize: 2048 kB
    DirectMap4k: 1048576 kB
    DirectMap2M: 0 kB

    cat /proc/cpuinfo

    processor : 0
    vendor_id : AuthenticAMD
    cpu family : 21
    model : 2
    model name : AMD Opteron(tm) Processor 4332 HE
    stepping : 0
    microcode : 0x600081f
    cpu MHz : 3000.060
    cache size : 2048 KB
    fpu : yes
    fpu_exception : yes
    cpuid level : 13
    wp : yes
    flags : fpu de tsc msr pae cx8 cmov pat clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm rep_good nopl pni pclmulqdq ssse3 fma cx16 sse4_1 sse4_2 popcnt aes f16c hypervisor lahf_lm cmp_legacy extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch xop tce tbm perfctr_core perfctr_nb arat cpb hw_pstate
    bogomips : 6000.12
    TLB size : 1536 4K pages
    clflush size : 64
    cache_alignment : 64
    address sizes : 48 bits physical, 48 bits virtual
    power management: ts ttp tm 100mhzsteps hwpstate cpb eff_freq_ro

    This is my hardware specification. It is in Rackspace
    the normal live stream when i refresh the UI or restart the App the cpu goes to 50 to 60 percentage without transcoding.


  4. #4


    Hi vinothc

    You may well be hitting hardware constraints with that setup. One CPU core is on the low side. It appears that your machine also has only 1GB of memory. Please see our minimum and recommended specifications page:

    This becomes even more significant when doing transcoding, as you are witnessing. Are you able to increase resources at all?


    Wowza Media Systems Support

Similar Threads

  1. Problems with CPU performance when upgrade Wowza Engine
    By hungnguyen88 in forum Performance and Tuning
    Replies: 7
    Last Post: 08-21-2014, 01:51 AM
  2. Wowza Streaming Engine Manager not displaying the server IP
    By gavram in forum Server Administration
    Replies: 3
    Last Post: 03-28-2014, 03:26 PM
  3. High Cpu usage AMD Opteron Dual CPU Server.
    By djcenk in forum Performance Tuning Discussion
    Replies: 1
    Last Post: 11-26-2013, 08:11 AM
  4. Replies: 1
    Last Post: 01-04-2012, 09:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts