Results 1 to 4 of 4

Thread: quicksync transcoding throws error: Mfx_err_device_failed

  1. #1
    Join Date
    Jan 2013
    Posts
    1

    Default quicksync transcoding throws error: Mfx_err_device_failed

    Hi,
    i created a transcoder configuration on my main /live/ application, i'm trying to transcode a 720p signal into:

    240p @300kbps
    360p @650kbps
    576p @1.500kbps

    I am using QuickSync as driver on a Ubuntu Server with:
    CPU: Intel i7 4770, GPU: Intel HD 4600

    I get an error each time i try to start on ONLY one of the streams, at random, the error is:

    INFO server comment - JNI:TranscoderSession.videoEncoderAdd[_defaultVHost_:live/_definst_/live:240p]: Create video encoder: H.264: QuickSync
    INFO server comment - JNI:VideoEncoderH264QuickSyncHost.createDone[_defaultVHost_:live/_definst_/live:240p]: Loading shared library: /usr/local/WowzaStreamingEngine/lib-native/linux64/libwms-vencoder-h264-quicksync-drm.so
    WARN server comment - JNI:VideoEncoderH264QuickSyncHost[_defaultVHost_:live/_definst_/live:240p]: QuickSync: Init encoder failed [MFX_ERR_DEVICE_FAILED]
    WARN server comment - TranscoderWorkerVideoEncoder.setupEncoder[_defaultVHost_:live/_definst_/live:240p]: Error videoEncoderInitialize[H264]: 4293853206
    the other two streams are working perfectly.

    I tried changing config several times but no joy, the weird thing is that if i remove one of the streams i get the error anyways, i even tried only keeping one and it gives the error!
    If i try to transcode using two quicksync and one default it works.
    Thanks in advance, any help is greatly appreciated
    Last edited by joyrex; 03-24-2014 at 04:33 AM.

  2. #2
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    Reference ticket #85926

  3. #3

    Default

    Hello, we are on Windows 7 and also getting this error. Was there a solution to this issue?

  4. #4
    Join Date
    Sep 2011
    Posts
    1,920

    Default

    Hi,
    A new ticket has recently been opened for this issue which is also running Windows 7 operating system (104179).

    If this was not you, please open a ticket by sending an email to support@wowza.com.
    When opening a ticket, please include a ZIP file containing the following directories:
    [Wowza-Install]/conf/
    [Wowza-Install]/logs/
    [Wowza-Install]/transcoder/
    [Wowza-Install]/manager/logs/

    Please make sure you provide logs which show Wowza server starting.

    If you are not sure how to get this information please see the following tutorial.
    How to create a compressed zip file in Windows, OS X, and Linux

    - If you have a live stream please outline the type of encoder in use along with the encoding settings for the stream.
    - If you are using a .stream file to start re-streaming please provide this.
    - If you are using multiple bitrates (ABR) then please provide the SMIL file associated with your configuration.

    I will try to provide an update to this thread once the ticket is resolved.

    Regards,
    Jason

Similar Threads

  1. Error message while transcoding mpeg2
    By dhamibirendra in forum Server Administration Discussion
    Replies: 5
    Last Post: 04-18-2016, 01:13 AM
  2. Wowza Transcoder Intel QuickSync error
    By cegara in forum Wowza Transcoder
    Replies: 1
    Last Post: 02-19-2014, 08:50 AM
  3. QuickSync transcoding ptoblem
    By TomazLov in forum AddOn: Transcoder
    Replies: 4
    Last Post: 05-23-2012, 04:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •