Results 1 to 9 of 9

Thread: 4.0.3 Insatall Problems

  1. #1
    Join Date
    Jan 2012
    Posts
    27

    Default 4.0.3 Insatall Problems

    Hi, I just downloaded Wowza Streaming Engine 4.0.3 release and tried to install it on my mac mini.
    The installation completed and said it was launching the Wowza Configuration program. However the configuration program never displayed.
    I checked the logs directory and there are the following logs:

    -rwxrwxrwx 1 root wheel 151 Mar 31 21:36 postinstall.log
    -rw-r--r-- 1 root wheel 494 Mar 31 21:36 wowzastreamingengine_error.log
    -rw-r--r-- 1 root wheel 126 Mar 31 21:36 WowzaConf.log
    -rw-r--r-- 1 root wheel 2373 Mar 31 21:36 wowzastreamingengine_access.log
    -rw-r--r-- 1 root wheel 54 Mar 31 21:36 launchd.stderr
    -rw-r--r-- 1 root wheel 4324 Mar 31 21:36 launchd.stdout


    Then contents of launchd.stdout is:
    Picked up JAVA_TOOL_OPTIONS: -Djava.awt.headless=true
    vs00:logs jvs$ cat launchd.stdout
    Picked up JAVA_TOOL_OPTIONS: -Djava.awt.headless=true
    Tue, 1 Apr 2014 04:36:26 934 GMT, BootStrap Info: Home Directory=/Library/WowzaStreamingEngine-4.0.3/manager/lib
    Tue, 1 Apr 2014 04:36:26 948 GMT, BootStrap Info: Main-Class=net.winstone.Winstone
    Picked up JAVA_TOOL_OPTIONS: -Djava.awt.headless=true
    2014-03-31 21:36:27,374 [main] INFO net.winstone.boot.BootStrap - stage 1/3: Loading arguments...
    2014-03-31 21:36:27,375 [main] INFO net.winstone.boot.BootStrap - stage 2/3: Loading WebApplication configuration...
    2014-03-31 21:36:27,376 [main] INFO net.winstone.boot.BootStrap - stage 3/3: compute JSP classpath...
    2014-03-31 21:36:27,466 [main] INFO net.winstone.core.HostConfiguration - Beginning extraction from war file
    Configure logging: file:///Library/WowzaStreamingEngine/conf/log4j.properties
    ERROR: License key is not valid or license file does not exist and running as a service (exiting)
    ERROR server comment - ERROR: License key is not valid or license file does not exist and running as a service (exiting)
    Picked up JAVA_TOOL_OPTIONS: -Djava.awt.headless=true
    Configure logging: file:///Library/WowzaStreamingEngine/conf/log4j.properties
    2014-03-31 21:36:28,975 [main] INFO net.winstone.core.WebXmlParser - Found and enabled the local Servlet 2.5 XSD replacement
    2014-03-31 21:36:29,410 [main] WARN net.winstone.core.WebXmlParser - XML Error (Line 2): Document is invalid: no grammar found.
    2014-03-31 21:36:29,411 [main] WARN net.winstone.core.WebXmlParser - XML Error (Line 2): Document root element "web-app", must match DOCTYPE root "null".
    2014-03-31 21:36:29,552 [main] INFO net.winstone.core.WebAppConfiguration - Access logging disabled - no logger class defined
    Configure logging: file:///Library/WowzaStreamingEngine/manager/conf/log4j.properties
    INFO server comment - LicenseUpdateServer: Bind attempt ([any]:8087)
    INFO com.wowza.wms.logging.Log4jStartupListener OS Name: Mac OS X:
    INFO com.wowza.wms.logging.Log4jStartupListener OS Version: 10.7.5:
    INFO com.wowza.wms.logging.Log4jStartupListener OS Architecture: x86_64:
    INFO com.wowza.wms.logging.Log4jStartupListener Java Name: Java HotSpot(TM) 64-Bit Server VM:
    INFO com.wowza.wms.logging.Log4jStartupListener Java Vendor: Apple Inc.:
    INFO com.wowza.wms.logging.Log4jStartupListener Java Version: 1.6.0_65:
    INFO com.wowza.wms.logging.Log4jStartupListener Java VM Version: 20.65-b04-462:
    INFO com.wowza.wms.logging.Log4jStartupListener Java Spec Version: 1.6:
    INFO com.wowza.wms.logging.Log4jStartupListener Java Home: /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home:
    INFO com.wowza.wms.logging.Log4jStartupListener Java Max Heap Size: 123MB:
    INFO com.wowza.wms.logging.Log4jStartupListener Java Architecture: 64:
    INFO com.wowza.wms.logging.Log4jStartupListener Java Locale[user.language]: en:
    INFO com.wowza.wms.logging.Log4jStartupListener Java Locale[user.country]: US:
    INFO com.wowza.wms.logging.Log4jStartupListener Java Locale[file.encoding]: MacRoman:
    INFO com.wowza.wms.logging.Log4jStartupListener Java Timezone[user.timezone]: America/Los_Angeles:
    INFO com.wowza.wms.logging.Log4jStartupListener Java Args[0]: -Dcom.wowza.wms.ConfigURL="":
    INFO com.wowza.wms.logging.Log4jStartupListener Java Args[1]: -Dcom.wowza.wms.ConfigHome=/Library/WowzaStreamingEngine/manager:
    INFO com.wowza.wms.logging.Log4jStartupListener Java Args[2]: -Djava.io.tmpdir=/Library/WowzaStreamingEngine/manager/temp:
    INFO com.wowza.wms.logging.Log4jStartupListener Java Args[3]: -Dlog4j.configuration=file:///Library/WowzaStreamingEngine/manager/conf/winstone.properties:
    INFO com.wowza.wms.logging.Log4jStartupListener Java Args[4]: -Djava.net.preferIPv4Stack=true:
    2014-03-31 21:36:29,670 [main] INFO net.winstone.core.WebAppConfiguration - webapp Initializing Spring root WebApplicationContext
    INFO server comment - LicenseUpdateServer: Bind successful ([any]:8087)
    INFO server comment - RESTServer: Using configs from:/Library/WowzaStreamingEngine/
    INFO server comment - RESTServer: SSL:No
    INFO server comment - RESTServer: BasicAuth:No
    INFO server comment - RESTServer: Digest:Yes
    INFO server comment - RESTServer: XML Viewer:No
    INFO server comment - Wowza REST API started
    WowzaStreamingEngineManager (PID: 85033) is stopping.... Shutdown complete.


    The contents of WowzaConf.log:
    Entered the WowzaConfig script and about to start waiting.
    Installer exited and launching WowzaConfig.app.
    Stopping services.


    Please let me know what I need to do to get Wowza configuration to run so I can configure it. I have not been prompted to enter license key or user info for the manager.

    One thing I did notice was that the file /Library/WowzaStreamingEngine-4.0.3/bin/WowzaConfig.sh has something on the first line before the #!/bin/bash that looks suspiciously like a license key. Is that intentional?

    Regards,
    Jo

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Hi Jo,

    I think this is because you starting Wowza manager as non-root user.

    You can enter your license key manually in the /conf/Server.license file. Be sure to save it as plain text.

    Richard

  3. #3

    Default

    Hi jvstockley,

    I have deleted your post because it contains some sensitive information that probably shouldn't be made public.

    Regard,

    Roger.

  4. #4
    Join Date
    Jan 2012
    Posts
    27

    Default

    Hi Roger,
    I apologize, but that information is already public to anyone who downloads and installs Wowza on a Mac. Someone added a license key to the beginning of the startup.sh file and it is readily readable and even get printed out if you run the command.

    Could you please restore my post with the offending information removed. I am trying to get support for installing Wowza 4.0.3 so we can upgrade our production server form Wowza 3.5.2. The 4.0.3 for Mac installs but the initial config program doesn't run so I cannot set user name and password for the manager.

    Thanks & regards,
    Jo Stockley
    YourGameCam.com

  5. #5
    Join Date
    Jan 2012
    Posts
    27

    Default

    Thanks for your response Richard,
    I tried running the WowzaConfig.sh as root using sudo but it fails due being unable to find the nib file.

    I moved on and create the Server.license file with my dev license and started both Wowza Streaming Engine and Manager and was able to connect to the manager but when it gets to the Sign In page I dont know what to enter as I was never asked to set a user name & password due to the config program not running.

    Is there a file I can manually create for the manager user/password?

    Thanks,
    Jo
    YourGameCam.com

  6. #6

    Default

    Hi Jo,

    It is strange that the installer is not working correctly for you. We have not had any other reports from Mac users to say they are having installer issues.

    Can you please send an email to support@wowza.com along with a link to this thread. Please zip up and include your bin, logs, conf & manager/logs folders.

    Regards,

    Roger.

  7. #7

    Default

    Quote Originally Posted by jvstockley View Post
    Thanks for your response Richard,
    Is there a file I can manually create for the manager user/password?
    Hi Jo,

    The username and password are plain text and go into the [install-dir]/conf/admin.password file.

    The format is
    username password group
    Group should be admin or readonly

    Roger.

  8. #8

    Default

    Quote Originally Posted by roger_l View Post
    Hi Jo,

    It is strange that the installer is not working correctly for you. We have not had any other reports from Mac users to say they are having installer issues.

    Can you please send an email to support@wowza.com along with a link to this thread. Please zip up and include your bin, logs, conf & manager/logs folders.

    Regards,

    Roger.
    Hi,

    Just as an update, the installer for the 4.0.3 release has now been fixed so that this script doesn't contain the extra text at the beginning of the script.

    We still need to learn why you had problems in the first place. The extra text wasn't causing the installer to fail but you are correct in that it ultimately failed because it couldn't locate the nib file.

    Can you please respond to support@wowza.com withe the info requested and please also include details about the Mac OSX version that you are currently using.

    Regards,

    Roger.

  9. #9
    Join Date
    Jan 2012
    Posts
    27

    Default

    Quote Originally Posted by roger_l View Post
    Hi,

    Just as an update, the installer for the 4.0.3 release has now been fixed so that this script doesn't contain the extra text at the beginning of the script.

    We still need to learn why you had problems in the first place. The extra text wasn't causing the installer to fail but you are correct in that it ultimately failed because it couldn't locate the nib file.

    Can you please respond to support@wowza.com withe the info requested and please also include details about the Mac OSX version that you are currently using.

    Regards,

    Roger.
    Hi Roger,

    The version of Mac OSX we're using is 10.7.5.
    I have emailed this to support@wowza.com along with the other requested items.

    Cheers,
    Jo

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •