Results 1 to 2 of 2

Thread: Re-streaming IP Camera Vivotek

  1. #1
    Join Date
    Apr 2014
    Posts
    5

    Default Re-streaming IP Camera Vivotek

    Hello everybody,
    I have a problem with re-streaming IP camera.

    First I have 3 cameras behind firewall and on the firewall I opened 3 ports which forward to cameras IP addresses on port 554(rtsp).

    I test camera link with VLC rtsp://83.228.82.242:555/live.sdp which forward to second camera on 554 port and I have a link with no problem and I check codec information my camera use Motion JPEG Video(mjpg).

    On Wowza Streaming Engine I folow guide for re-streaming and create camera.stream file with content rtsp://83.228.82.242:555/live.sdp

    I create startup stream with name camera.stream and MediaCaster-rtp,Application-live,Instance-_definst_

    The stream file is active and into log files everything is look ok:
    2014-04-06 22:13:09 EEST comment server INFO 200 - RTPSessionDescriptionDataProviderBasic.getStreamInfo[live/_definst_]: RTSP/RTP re-streaming. Success, received SDP data.

    When I try to connect with VLC to rtmp://wowza-server-IP/live/camera.stream I don't have a connection and into log:
    2014-04-06 22:16:59 EEST connect-pending session INFO 100 92.247.200.214 - _defaultVHost_ live _definst_ 0.751 [any] 1935 rtmp://193.107.39.36:1935/live 92.247.200.214 rtmp - LNX 9,0,124,2 2144901834 3286 3073 - -- - - - - - - - - - - rtmp://193.107.39.36:1935/live -
    2014-04-06 22:16:59 EEST connect session INFO 200 92.247.200.214 - _defaultVHost_ live _definst_ 0.752 [any] 1935 rtmp://193.107.39.36:1935/live 92.247.200.214 rtmp - LNX 9,0,124,2 2144901834 3286 3073 - - -- - - - - - - - - - rtmp://193.107.39.36:1935/live -
    2014-04-06 22:16:59 EEST create stream INFO 200 - - _defaultVHost_ live _definst_ 0.001 [any] 1935 rtmp://193.107.39.36:1935/live 92.247.200.214 rtmp - LNX 9,0,124,2 2144901834 3319 3413 1 0 0 0- - - - 0 0.0 rtmp://193.107.39.36:1935/live rtmp://193.107.39.36:1935/live - rtmp://193.107.39.36:1935/live -

    When I test the live application on Wowza Streaming Engine and test this stream its say camera.stream is now published and empty blank.

    For what to watching in Live Application.xml,and any idea what is wrong and how to troubleshoot this problem.

    I want to re-stream this 3 cameras and after that to connect to stream file with some player and custemers to watch this cameras publish.

    Thanks.

  2. #2
    Join Date
    May 2013
    Posts
    680

    Default

    I'd first try adding the rtspFilterUnknownTracks property to see if you can narrow down the multiple tracks that seem to be conveying from the source.

Similar Threads

  1. Re-streaming IP Camera Vivotek
    By Assuzza in forum Assistance with live events
    Replies: 4
    Last Post: 04-07-2014, 12:41 AM
  2. Re-streaming IP Camera Vivotek
    By Assuzza in forum Integrating Wowza into your workflow
    Replies: 1
    Last Post: 04-06-2014, 11:49 PM
  3. Video Chat Multiple Camera Not Streaming For Second Camera
    By emreVeriyaz in forum Live Streaming and Encoder Discussion
    Replies: 7
    Last Post: 06-01-2012, 02:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •