Results 1 to 8 of 8

Thread: Wowza IDE updates for 4.0

  1. #1

    Default Wowza IDE updates for 4.0

    Will the Wowza IDE be updated to support changes in WSE 4.0? I have a fair amount of custom code for our current server implementation and would like to continue to use Eclipse to develop my modules.

    If the Eclipse plugin is not going to continue development, can you provide any tips on what needs to be updated to allow Eclipse to debug effectively with the new codebase?

  2. #2


    Are you have any issues in particular? Or are you just inquiring to help decide whether to upgrade or not? Because as far as I know and can tell(I have been using the IDE with 4.x) it is up to date and working as expected.


  3. #3


    Well, my project's build path & run/debug settings are all still pointing to my previous installation of 3.6 - so I assumed there could be some code incompatibilities. I would like to be able to debug my code against the new engine, but simply updating the paths didn't work.

    I am seeing some problems with my application after the upgrade, but I'll address those specifically in another thread.

  4. #4


    Make sure your project .jar file is being compiled to the correct /lib folder. Since you started the project using a previous version of Wowza that was in another location, the IDE is still compiling to the old /lib folder. The easiest way to re-set is to delete the build.xml, then delete the project leaving the check box to "delete files" unselected, then re-create the project with the same name.


  5. #5


    I attempted to start a new fresh project, with a clean installation of WSE 4.0.3, and when attempting to debug, I receive the following errors:

    Error starting: java.lang.reflect.InvocationTargetException
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(
    	at java.lang.reflect.Method.invoke(
    	at com.wowza.wms.bootstrap.Bootstrap.startServer(
    	at com.wowza.wms.bootstrap.Bootstrap.main(
    Caused by: java.lang.NoClassDefFoundError: org/apache/commons/lang/SystemUtils
    	at com.wowza.wms.bootstrap.BootstrapSystemTuningInfo.getSystemTuningInfo(
    	at com.wowza.wms.server.ServerTuningHandler.<init>(
    	at com.wowza.wms.server.Server.<init>(
    	at com.wowza.wms.server.Server.getInstance(
    	at com.wowza.wms.server.Server.start(
    	... 6 more
    Caused by: java.lang.ClassNotFoundException: org.apache.commons.lang.SystemUtils
    	at Method)
    	at java.lang.ClassLoader.loadClass(
    	at sun.misc.Launcher$AppClassLoader.loadClass(
    	at java.lang.ClassLoader.loadClass(
    	... 11 more
    I verified that the project is linking against the libs in the new WSE installation. The Run/Debug settings include the following:

    Main Class: com.wowza.wms.bootstrap.Bootstrap
    Program Args: start
    VM Args:

  6. #6


    To fix this error. In Eclipse, right click on the project in the left menu and choose "properties"
    Next, click on the Run/Debug settings on the left, highlight the launch configuration and click Edit
    Under the "arguments" tab, add the following line to the output in "VM Arguments"

    On Windows:
    On Mac:

  7. #7


    Thanks, Salvadore, that has fixed the issue. I can now launch Wowza from Eclipse again.

  8. #8


    Great! Thanks for the update and glad I could help.


Similar Threads

  1. Getting live updates from wowzamediaserver_error.log
    By niemion in forum Live Streaming and Encoder Discussion
    Replies: 6
    Last Post: 01-13-2014, 08:30 AM
  2. Overlays with updates on Windows
    By Kent WOW in forum AddOn: Transcoder
    Replies: 3
    Last Post: 03-29-2013, 05:28 PM
  3. no stream after updates, transcode erros
    By bulltv in forum Live Streaming and Encoder Discussion
    Replies: 5
    Last Post: 03-18-2013, 07:23 PM
  4. Wowza RTMP streams SLOW after updates to server
    By jedirick in forum Performance Tuning Discussion
    Replies: 7
    Last Post: 07-20-2012, 10:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts