Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Configure liverepeater reconnect behavior

  1. Default Configure liverepeater reconnect behavior

    Hi Everyone,

    I'd like to modify the reconnect behavior on my liverepeater-edge. Is there a way I can listen for the disconnect event so I can programatically determine whether to reconnect or not?

    Thanks,
    Jay

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    What player are you using, Jay?

    Richard

  3. Default

    Hi Richard,

    I'm using a number of different players and STB's. Really, I just want to prevent the liverepeater-edge from trying to reconnect to an origin I know to be unavailable. I have a multi origin network, and encoders can move between origins from time to time.

    I'm using a class that implements IMediaStreamNameAliasProvider2 to locate my origin when a stream is first requested, but if the origin application shuts down while the edge is connected, I want to be able to locate the origin again instead of having the liverepeater try to reconnect on its own.

    This needs to be entirely server side, and have no player dependency.

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Jay,

    You can send RTMP notifications from a Wowza origin to its edges. Let me look around for an example of that

    Richard

  5. Default

    Thanks Richard.

    I'm wondering though, is there nothing I can do at the edge to simply tell the repeater to not automatically reconnect?

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Jay,

    Try setting edge Application.xml StreamValidator /Enable to "false" and add /MediaCaster /streamTimeout Property set to "0"

    <Property>
    	<Name>streamTimeout</Name>
    	<Value>0</Value>
    	<Type>Integer</Type>
    </Property>
    Richard

  7. Default

    Thanks Richard.

    Is the StreamValidator config available in 3.5.x? I haven't come across that one before

  8. #8
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Jay,

    That is actually just the built-in Advanced MediaCaster Monitor in Wowza 4. In Wowza 3, if you have enabled the Advanced MediaCaster Monitor then you will want to disable that.

    Richard

  9. Default

    Great. Thanks again Richard.

  10. Default

    Hmm... seems the streamTimeout property didn't have an effect. Are there other properties available? Perhaps one that sets the number of reconnect attempts to zero?

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 11
    Last Post: 08-21-2013, 07:36 AM
  2. Transcoder does not resume on liverepeater reconnect
    By nimigeanu in forum AddOn: Transcoder
    Replies: 11
    Last Post: 11-18-2011, 04:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •