Results 1 to 4 of 4

Thread: Icecast restreams starting to skip/stutter after a few days?

  1. #1
    Join Date
    Aug 2009
    Posts
    0

    Default Icecast restreams starting to skip/stutter after a few days?

    Since upgrading from Wowza 3 to Wowza Stream Engine 4.0.3 I've been having this issue. I have about 25 Live Applications set up for Icecast re-streaming, each with their own 'uniquestationname.stream' file. Everything works fine upon initial setup and streams come up quick. In time the streams start to skip/stutter and also take a longer time to startup. It may be several hours before happening, but usually it is several days. Once it starts to happen I have to restart the Application(s) to remedy the issue. Then several hours later, to a few days later, it will start happening again. Eventually I have to restart the server.

    On a side note, I've also seen the 'Total Memory' graph climb up to 90%, over time. When I log into the server, the Task 'Service Java(TM) Platform SE binary' for 'Wowza Streaming Engine' is using 3.5GB. Restarting that Servers drops it back down to <500MB.

    Has anyone experienced this and possibly know of a solution? Thanks!

  2. #2
    Join Date
    May 2013
    Posts
    680

    Default

    You could try turning off the stream validator as there is large buffer that may be very bursty when delivering data to Wowza (in this workflow) which, under normal checking, will appear to be a broken stream. Simply modify your [install-dir]/conf/[app-name]/Application.xml file under MediaCaster/StreamValidator/StreamValidator set Enable to false:

    <StreamValidator> 
    <Enable>false</Enable>
    ...
    Then restart and test again. Should the problem persist, zip up your conf/ and logs/ directories and send them to support@wowza.com.

  3. #3
    Join Date
    Aug 2009
    Posts
    0

    Default

    matt_y: Thanks for the suggestion. I've made the adjustment to a few of the Live Applications. Will post my results/findings in a few days.

  4. #4
    Join Date
    May 2013
    Posts
    680

    Default

    Ok, great thanks.

Similar Threads

  1. Replies: 5
    Last Post: 09-13-2016, 07:38 AM
  2. Stutter HDS Playback with Captions Enabled
    By puneetdv in forum Closed Captioning
    Replies: 1
    Last Post: 08-15-2014, 02:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •