Results 1 to 7 of 7

Thread: Help cant get wowza to work with centos beesmart

  1. #1
    Join Date
    May 2014

    Default Help cant get wowza to work with centos beesmart

    Hello I am new to beesmart lite and wowza and having many problems I have done about 50 installs now.

    This is what happens - if i install centos and beesmart then in the browser type http://localhost:85/omniplay/admin) beesmart is working perfect so the next step i install wowza after and i type localhost:1935 it says wowza streaming engine but if i type localhost:8088/enginemanager i get unable to connect.

    so i installed centos without beesmart and installed yum install java-1.7.0-openjdk-devel and then wowza worked perfect so I then installed beesmart and during install it gets stuck on configuring oracle.

    so i installed again centos, then beesmart, then i installed wowza when i tried the /etc/init.d/Wowza command it said something about which and symbol

    So it seems I can install one or the other but not on the same machine.

    Can some one please explain how to get this working - this is what I am trying to do.

    1 : Install Centos and then install beesmart lite
    2 : install wowza
    3 : have them both working together

    Thank for your time
    Last edited by nightshadow36; 05-04-2014 at 03:33 PM.

  2. #2


    It sounds like there is probably a port conflict. With Wowza installed last, and started last, check the startup lines for bind errors. You can start Wowza in stand alone mode /bin/startup.bat| and view the logs in the console.

    Looking here at oracle ports:
    Oracle HTTP Server JServ Servlet Engine: 8007-8107, so Wowza is probably not binding to 8086 and 8088.

    Every VHost.xml /HostPort /IpAddress must be unique within Wowza (as compared to other HostPorts in the same file or other VHost.xml files if there are multile VHosts) and outside Wowza. Another application cannot bind to the same IPAddress/Port as any Wowza HostPort. If there is any duplication there will be bind ERROR messages in the log file after startup.


  3. #3
    Join Date
    May 2014


    Thank you for the reply I am going to do a fresh install and see if I can find the problem with your information.

  4. #4
    Join Date
    May 2014


    Hi I am getting a binging error, is there a post on how to change the default port from 8088 to another port?


  5. #5


    if you have two IPs available, assign one to oracle and the other to Wowza in VHost.xml /HostPort /IpAddress or, use different ports in Wowza:
    Configuring streaming ports


  6. #6
    Join Date
    May 2014


    ok I have been trying this for 3 days now changeing what ever I can think off does any one know what the problem is here is part of the Log.
    It does not tell me what port is in use.

    if i verify on wowza-ip-address:1935 it says running engine 4

    but when i use wowza-ip-address:8088/enginemanager I get.....
    http page unable to connect any ideas ?????

    Thank you.

    INFO server comment - RESTServer: Bind attempt ([any]:8087)
    INFO server comment - RESTServer: Bind successful ([any]:8087)
    INFO server comment - Wowza REST API started
    ERROR server comment - REST API: Server request (GET): IP WhiteList blocked ([/url]
    INFO server comment - RESTServer: Using configs from:/usr/local/WowzaStreamingEngine/
    INFO server comment - RESTServer: SSL:No
    INFO server comment - RESTServer: BasicAuth:No
    INFO server comment - RESTServer: Digest:Yes
    INFO server comment - RESTServer: XML Viewer:No
    INFO server comment - CMDInterface now listening: [any]:8083
    ERROR server comment - server core failure: Address already in use Address already in use
    at Method)
    at org.apache.mina.transport.socket.nio.SocketAcceptor.registerNew(
    at org.apache.mina.transport.socket.nio.SocketAcceptor.access$1100(
    at org.apache.mina.transport.socket.nio.SocketAcceptor$
    INFO server comment - MediaCache[MediaCache]: Thread pool size: [writer/readahead]:4/2
    INFO server comment - MediaCache[MediaCache]: MAX Pending size: [writer/readahead]:500M/25M
    INFO server comment - MediaCache[MediaCache]: Add store: path:/usr/local/WowzaStreamingEngine/mediacache maxSize:10737418240
    INFO server comment - MediaCache[MediaCache]: Add source[dvrorigin]: prefix:dvrorigin/ basePath:http://
    INFO server comment - MediaCache[MediaCache]: Flushing cache: start
    INFO server comment - MediaCache[MediaCache]: Flushing cache: done
    INFO server comment - MediaCache[MediaCache]: Start MediaCache GC
    INFO server comment - MediaCache[MediaCache]: Started
    INFO vhost vhost-start _defaultVHost_ -
    INFO server comment - _defaultVHost_ threads[h/t]:0/0 home:/usr/local/WowzaStreamingEngine
    INFO vhost comment _defaultVHost_ Bind attempt ([any]:1935:4)
    INFO vhost comment _defaultVHost_ Bind successful ([any]:1935)
    INFO vhost comment _defaultVHost_ Bind attempt ([any]:8086:2)
    INFO vhost comment _defaultVHost_ Bind successful ([any]:8086)
    INFO server comment - Server.startShutdownHook: Start server shutdown hook
    INFO server comment - StatsManager:startManager() Enabled=true
    INFO server comment - Wowza Streaming Engine is started!
    Last edited by nightshadow36; 05-05-2014 at 03:34 PM.

  7. #7


    In your router you need to port forward TCP port 1935 to the computer running Wowza. Or on your network you need to map port 1935 to the server running Wowza.
    If using a router, this site may be helpful in setting the router correctly:


Similar Threads

  1. centos for wowza?
    By bobmane in forum Server Administration Discussion
    Replies: 1
    Last Post: 08-15-2012, 02:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts