Dear Wowza Support/ Community,

We are facing a bug since we have updated to WowzaStreamingEngine 4.

We are using one server (let's call it production server) to deliver four multicast streams. This server is still in version 3.5.0.

On a second server (the Monitoring Server), we are repeating the four streams sent by the Production Server to create a monitoring view of each output. This server has been updated to version 4.

The monitoring server's Wowza service is always started since it delivers other streams whereas the service on production server is started only during a specific time slot.

It happens randomly that we have no sound for one or more of the four repeated streams.
In the logs, we get messages such as: (on monitoring server)
WARN    server  comment 2014-05-06      15:12:30        -       -       -       -       -       15.109  -       -       -       - SanJosePacketHandler.handlePacket[HTV/_definst_/]: Timecode out of order [audio]: 31572806:31641802
( We know it indicates encoder error but it is well configured)

The only way to solve this is to restart Wowza service on the monitoring server. But this is not an acceptable solution to us because it also stops other streams delivered by the monitoring server.

I have tried to restart only the application within the brand new Enginemanager GUI but it removes each stream files configured in the StartupStreams for this application. So the application is no more able to stream…

I have also tried to reset stream within the old streammanager interface but it has no positive impact on the stream.

This was working fine when the Monitoring Server was in version 3.5.0

I hope I was clear enough.
Is anyone facing the same issue?
Is there any workaround?

Many thanks in advance for your help,