Results 1 to 8 of 8

Thread: wowza > jw player not working on mobile, Internet Explorer

  1. #1
    Join Date
    May 2014
    Posts
    15

    Default wowza > jw player not working on mobile, Internet Explorer

    Howdy - pretty happy how far i've gotten so quickly in getting our Axis IP cameras to be streaming nicely through Wowza & JW Player.

    However, it only works on Webkit & Mozilla browsers (Chrome, Firefox, Safari, Opera).
    It does not work on any mobile device, (Android or iOS), either. Here are my settings:

    We have 8 cameras, all setup via stream files
    rtsp://[username]:[password]@[camera_ip]:[camera_port]/axis-media/media.amp?videocodec=h264

    everything in Wowza looks great - all streams marked as active and i can see them in the test players.

    Here is my jw player code that i put on our website:

    <script src='http://jwpsrv.com/library/[random trial key].js'></script>
    <div style='margin:0 auto; width: 480px;'>
        <div id='jw_player'></div>
    </div>
    <script type='text/javascript'>
    jwplayer('jw_player').setup({
        autostart: 'true', 
        sources: [{ 
            file: 'rtmp://[wowza ip address]:1935/[application]/[stream_name].stream'
        },]
    });
    </script>
    Again - this works perfectly in Chrome, Firefox, opera and Safari, but not on my mobile or Internet Explorer.

    The stream works if I pull up the Live Video Streaming page in IE: http://www.wowza.com/resources/3.6.0...er/player.html and connect to my wowza server.
    Also, i get a stream if I dial in the rtsp:// link (I find this on the Mobile tab of the test browsers in the web UI) directly on my android device.

    But nothing through the jw player. I get a "Error loading player: No playable sources found" error message.

    Is the trial version of jw player limited in any way? And what are my options other than jw player? Can I embed the stream on all these browsers and devices another (less expensive) way?

    Thanks in advance,
    gw

  2. #2
    Join Date
    Jul 2012
    Posts
    299

    Default

    Hi Graham,

    It looks like you need to add an HLS/HTML5 configuration to your JW Player. Take a look at this article, which explains the setup:

    How to use JW Player with Wowza Streaming Engine

    In particular, note the code example under "Simple RTMP and Apple HLS streaming."

    -Tim

  3. #3
    Join Date
    May 2014
    Posts
    15

    Default

    Quote Originally Posted by tim_d View Post
    Hi Graham,

    It looks like you need to add an HLS/HTML5 configuration to your JW Player. Take a look at this article, which explains the setup:

    How to use JW Player with Wowza Streaming Engine

    In particular, note the code example under "Simple RTMP and Apple HLS streaming."

    -Tim
    thanks for the quick reply, Tim.

    Seen this page many times, but that section refers to VOD only. how do i change/massage those links to refer to my live streams?

    Thanks again.
    gw

  4. #4
    Join Date
    May 2014
    Posts
    15

    Default

    Bump!

    Can anyone help with this?

    TIA, gw

  5. #5
    Join Date
    Jul 2012
    Posts
    299

    Default

    Graham,

    Live and VOD playback is very similar. This is how the JW Player code will look for a live stream:

    <body>
    
    <div id="player"><a href="rtsp://[wowza-ip-address]:1935/live/myStream">RTSP Link</a></div>
    
    <script type="text/javascript">
    	jwplayer("player").setup({
    		sources: [{
    			file: "rtmp://[wowza-ip-address]:1935/live/myStream"
    		},{
    			file: "http://[wowza-ip-address]:1935/live/myStream/playlist.m3u8"
    		}],
    		rtmp: {
    			bufferlength: 3
    		},
    		fallback: false
    	});
    </script>
    </body>
    Be sure that you have a functional, live stream coming from Wowza that will stream in our test RTMP player and an iOS device.

    -Tim

  6. #6
    Join Date
    May 2014
    Posts
    15

    Default

    OK great - thanks Tim. I now have it working on iOS devices. Still nothing on IE or Android.

    Correction: both IE and Android do provide the link to the rtsp stream.
    Clicking on that link streams properly on Android. IE gives me an error.

    Viewing my stream via the test RTMP player works in IE, but still nothing through JW Player. Frustrating.

    Thanks again much appreciated,
    gw

  7. #7
    Join Date
    May 2014
    Posts
    15

    Default

    UPDATE - turns out i was using Flash v11. Which i guess does not work with JW6. Updated flash to v13 and looks like we are fully good to go.

    Thanks again, Tim.

  8. #8
    Join Date
    Jul 2012
    Posts
    299

    Default

    Graham,

    Excellent progress. Thank you for the update.

    -Tim

Similar Threads

  1. Strange sound using Internet explorer with latest flash (11.8.800)
    By henkhenk in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 09-19-2013, 07:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •