Results 1 to 4 of 4

Thread: SMIL Scheduling Problems

  1. #1
    Join Date
    Jul 2011
    Posts
    20

    Default SMIL Scheduling Problems

    Hi everyone,

    I've finished this morning the installation of new Wowza Streaming Engine and now I'm configuring it so that we have same applications running that we had in Wowza Media Server3. I've set up my application, step by step, just as this tutorial explains,
    ( http://www.wowza.com/forums/content....ge=13#comments ), but I'm having some troubles with scheduled vod contents. The problem is that I have some files in the "content" dir, but some others are in a subdirectory called "demo". In Wowza Media Server3 I had this working. This was my SMIL file lines for this "nested" contents:
    [...]
    <stream name="ERCBA"></stream>
    <playlist name="pl32" playOnStream="ERCBA" repeat="true" scheduled="2009-12-11 16:30:00">
    <video src="demo/mp4:20110815ExposcionRetratoCBA.mov" start="0" length="-1"/>
    </playlist>
    [...]
    I tried with "/demo/mp4:20110815ExposcionRetratoCBA.mov"
    also with "/_definst_/demo/mp4:20110815ExposcionRetratoCBA.mov"

    But none of these options is working. Java throws this exception (error_log file)

    MediaReaderH264.open[playlists/_definst_]: Not found: C:/Program Files (x86)/Wowza Media Systems/Wowza Streaming Engine 4.0.3/content/20110815ExposcionRetratoCBA.mov.: java.io.FileNotFoundException: C:\Program Files (x86)\Wowza Media Systems\Wowza Streaming Engine 4.0.3\content\20110815ExposcionRetratoCBA.mov (El sistema no puede encontrar el archivo especificado)|at java.io.RandomAccessFile.open(Native Method)|at java.io.RandomAccessFile.<init>(RandomAccessFile.java:233)|at com.wowza.io.WowzaRandomAccessFile.<init>(WowzaRandomAccessFile.java:12)|at com.wowza.io.DirectRandomAccessReader.open(DirectRandomAccessReader.java:222)|at com.wowza.wms.mediareader.h264.MediaReaderH264.open(MediaReaderH264.java:250)|

    It seems like is not trying to get this content from "demo" subdir. How can I fix that?

    Many thanks
    Javier.

  2. #2
    Join Date
    Sep 2011
    Posts
    1,920

    Default

    Hi,
    The sub dir need to be specified after the mp4: prefix.
    Try adjusting the .smil file so it looks like the example below.
    <video src="mp4:demo/20110815ExposcionRetratoCBA.mov" start="0" length="-1"/>
    Regards,
    Jason

  3. #3
    Join Date
    Jul 2011
    Posts
    20

    Default

    Hi Jason,

    thank you very much, now my schedule is working fine.

    Regards.
    Javier

  4. #4
    Join Date
    Sep 2011
    Posts
    1,920

    Default

    Hi,
    Thanks for the update.

    Regards,
    Jason

Similar Threads

  1. Problems setting up Wowza for scheduled publishing with SMIL
    By gunjorge in forum Server-side Modules and Code Samples Discussion
    Replies: 12
    Last Post: 06-28-2013, 05:55 AM
  2. iOS Adaptive Bit Rate streaming using Smil file problems
    By grantk in forum AddOn: Transcoder
    Replies: 4
    Last Post: 05-23-2012, 01:18 PM
  3. Problems with playlist schedule.smil
    By Javier in forum Tutorials Discussion
    Replies: 2
    Last Post: 02-06-2012, 07:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •