Results 1 to 8 of 8

Thread: Upgrade from Wowza 2 to Wowza3 or Wowza Streaming Engine (on Amazon EC2) not working.

  1. #1

    Default Upgrade from Wowza 2 to Wowza3 or Wowza Streaming Engine (on Amazon EC2) not working.

    We have been a "Wowza EC2" user for over 3 years. We're a small publishing shop that sometimes does NO livestreaming for weeks, then some days we can stream 4 simultaneous events. As such, we find that the on-demand options of Amazon EC2 is the best choice, and not a perpetual licence, as our usage is quite sporadic.


    In the past, we've only used Wowza 2 to do livestreaming, and we publish our recorded videos using Amazon Cloudfront.


    99% of our livestreaming efforts are done using Wirecast 4/5, and we've not had any problems.


    For the past 3 years, we've always been using the same Wowza 2 EC2 ami (ami-5c649835)- we do so for simplicity, I guess. We like the ease of use, and we really only need the Cacti logs to see how many people logged on to watch our stream. We record our streams locally on a hard drive, and then stream them via Cloudfront after the event.


    Now, it seems all the Wowza 2 AMI have been retired, so to speak.


    I upgraded to Wowza Streaming Engine last week, but I'm having problems.


    We're on the US East Coast, so we use the US East ami-4b889222


    But it isn't working (at least with the ease of use we had with the Wowza 2 licence).


    I use the same settings I used for Wowza2, but Wirecast error message states "Cannot connect to RTMP/Flash Server at the given IP address. [-4018]"


    I wonder if it's an issue with the way in which I upgraded from Wowza 2 to Wowza Streaming Engine?


    My Amazon subscription page says I pay $5 per month for Wowza Streaming Engine - http://chilp.it/df2d7e
    But the Wowza info page states that it should be $15 per month - http://goo.gl/fv01C7


    Was there an error in the way I upgraded from Wowza 2 to Wowza Streaming Engine?


    Last week, when we first found we couldn't use our old Wowza 3 ami, we quickly started up a Wowza 3 ami, but we found out we could only use 10 concurrent streams at one time. I've tried to upgrade to Wowza 3 as well (the way I see it, since we only use Wowza for the streaming, and not the nDVR and transcoder, it doesn't really matter if we use Streaming Engine or Wowza 3). But we can't seem to get Wowza 3 (with EC2) working for us either.


    What are we doing wrong?

  2. #2
    Join Date
    Jul 2012
    Posts
    302

    Default

    Hi Jason,

    Thank you for being a long-time Wowza customer. We appreciate your business.

    The upgrade to Wowza Streaming Engine was a wise move. You will benefit from the many fixes and features added since version 2.

    This error:

    Cannot connect to RTMP/Flash Server at the given IP address
    By default, Wowza Streaming Engine requires a username and password be appended to the live encoding workflow. This is probably the issue. These credentials are accessible in Wowza Streaming Engine Manager by accessing Server>Publishers. Here are some useful instructions from the Quick Start Guide:

    Managing Sign-In credentials

    Alternatively, you may disable the username/password requirement in the application configuration, again, using WSEM, and accessing Application>[application]>Incoming Security and setting RTMP publishing to Open. here are some instructions:

    How to configure security using Wowza Streaming Engine Manager - RTMP Publishing

    I hope you find this helpful.

    -Tim

  3. #3

    Default

    Tim,

    Thanks for the reply.

    You know I'm using Wowza on EC2, correct? I didn't know there was a way for me to access the Streaming Engine interface when using an EC2 AMI. I thought it was all built in to the pre-configed AMI.

    You'll have to excuse my ignorance, but I don't know my username and password, as I just am using the Community AMI. I am currently at the sign in page - http://ec2-xx-xx-xx-xxx.compute-1.am...ftu/signin.htm

    But I don't know the credentials?

  4. #4
    Join Date
    Jul 2012
    Posts
    302

    Default

    Jason,

    I did respond in support request #91229, thank you.

    You may access Wowza Streaming Engine Manager using this url:

    http://[wowza-ip-address]:8088

    The username is "wowza" and the password is the Instance ID, which is accessible in the Instances page of the Management Console in EC2.

    To quickly startup Wowza in EC2 with open authentication for applications, I would suggest using a custom startup package that contains application settings with open authentication. For more information on how to create a startup package, see the chapter on Wowza Media Server Configuration Startup Packages in the Wowza Media Server for Amazon EC2 Edition User's Guide.

    -Tim

  5. #5

    Default

    Tim,

    I've tried to log into the Wowza Streaming Engine, but I think I may know why it doesn't allow me to do so.

    Page 28 of the user manual - http://www.wowza.com/resources/Wowza...UsersGuide.pdf

    "Note: A web server isn't included in Wowza Media Server for Amazon EC2 AMIs."

    I'm using the Amazon Marketplace - Standard licence. http://www.wowza.com/products/stream...place-standard

    ... or is there a way for me to log into the Streaming Engine?
    Last edited by jstobbe; 05-20-2014 at 07:41 PM.

  6. #6
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    If you start up a new Wowza 4 using pre-built AMIs (either devpay or licKey, or Marketplace standard or BYOYL), you can log onto the Manager at this address:

    http://[ec2-public-dns]:8088

    The default login is: wowza
    The default password is: [instance-id]

    You can get the [instance-id] from the AWS console, EC2 interface, Running Instances

    Richard

  7. #7

    Default

    I've replied to "support@wowza", as I did not want to give away my instance ID on this forum.

    I've tried exactly what you're saying, and it does not connect.
    My instance id is ec2-xx-xx-xx-xx.compute-1.amazonaws.com
    What I did:
    1. Went to http://ec2-xx-xx-xx-40.compute-1.amazonaws.com:8088/enginemanager/login.htm
    2. Signed in with: wowza / ec2-xx-xx-230-40.compute-1.amazonaws.com


    Am greeted with "Your user name or password is incorrect, please try again."

  8. #8
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    You are using the Public DNS as the password. The instance ID is what you need. You can get it in the AWS console, in the EC2 running instances tab. It looks something like this: i-c6abxxxx

    Richard

Similar Threads

  1. Replies: 3
    Last Post: 03-21-2014, 10:52 PM
  2. Wowza Streaming Engine on EC2 no more c1.medium
    By flyfishtom in forum Wowza Streaming Engine in the Cloud
    Replies: 6
    Last Post: 03-17-2014, 04:48 PM
  3. Wowza Streaming Engine and AWS EC2
    By mmoscovich in forum Wowza Streaming Engine in the Cloud
    Replies: 1
    Last Post: 02-19-2014, 03:50 PM
  4. Wowza Streaming Engine EC2 AMI - is it available?
    By yardfire in forum Wowza Streaming Engine in the Cloud
    Replies: 3
    Last Post: 02-18-2014, 01:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •