Results 1 to 2 of 2

Thread: Hotlink Denial Module and loadbalancer

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Sep 2013
    Posts
    1

    Default Hotlink Denial Module and loadbalancer

    Hello,

    I have a problem with using Hotlink Denial Module.
    I have origin and many edge servers. On origin server I created live application and redirect application. In live application I used Hotlink Denial Module and set some domains.
    When I connect to live application from JWplayer from a domain wich is allowed, it works good. But If I try to connect to redirect application, Wowza denied Edge IP's, even if I set this IP's in property value.

    My config:

    <Property>
    				<Name>domainLock</Name>
    				<Value>[*.*.*.118],127.0.0.1,*domain.com,</Value>
    </Property>
    There are logs:

    2014-05-23	09:12:31	CEST	connect-pending	session	INFO	100	*.*.*.118	-	_defaultVHost_	live	_definst_	0.003	[any]	1935	rtmp://*.*.*.36:1935/live/_definst_	*.*.*.118	wowz	WowzaProLiveRepeater	WIN 10,0,12,36	669860504	3408	3073	-	-	-	-	-	-	-	-	-	-	-	-	-	rtmp://*.*.*.*:1935/live/_definst_	-
    
    2014-05-23	09:12:31	CEST	comment	application	INFO	200	-	ModuleHotlinkDenial Client Rejected. IP: *.*.*.118: domainLock: *.*.*.118,127.0.0.1,*domain.com: pageUrl: 	_defaultVHost_	live	_definst_	44.998	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-	-
    
    2014-05-23	09:12:31	CEST	connect	session	INFO	401	*.*.*.118	-	_defaultVHost_	live	_definst_	0.004	[any]	1935	rtmp://*.*.*.36:1935/live/_definst_	*.*.*.118	wowz	WowzaProLiveRepeater	WIN 10,0,12,36	669860504	3408	3073	-	-	-	-	-	-	-	-	-	-	-	-	-	rtmp://*.*.*.36:1935/live/_definst_	-
    
    2014-05-23	09:12:31	CEST	disconnect	session	INFO	200	669860504	-	_defaultVHost_	live	_definst_	0.006	[any]	1935	rtmp://*.*.*.36:1935/live/_definst_	*.*.*.118	wowz	WowzaProLiveRepeater	WIN 10,0,12,36	669860504	3408	3246	-	-	-	-	-	-	-	-	-	-	-	-	-	rtmp://*.*.*.36:1935/live/_definst_	-
    *.*.*.36 - is origin IP
    *.*.*.118 - is one of edges IP

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    You should not enable this module on an origin, just the edge servers. Flash clients shouldn't be connecting directly to the origin.

    Wildcard support is very simple in this module, and the form you are using is not supported. I think IP addresses are supported, but wildcards are only supported in the form "*mycompany.com". So for an IP address it would have to be "*.118" for example. That should work, looking at the source, though only domains are mentioned in the module's guide.

    Richard

Similar Threads

  1. Hotlink Denial Module denies anyway
    By namesys_ in forum General Forum
    Replies: 3
    Last Post: 08-24-2012, 03:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •