Results 1 to 6 of 6

Thread: ERROR: Can not detect Format video after Recording a live stream

  1. #1

    Default ERROR: Can not detect Format video after Recording a live stream

    Hi everyone,

    I have a problem with my HTTPLiveStreamRecord.
    Sometimes, my mp4 file can not detect the format when I finished a recording of a live stream. Although my live stream still works well.
    I check the properties of the mp4 file, details tabs and see no value in video property and audio property.
    What problems with my recording?

    Thank your help.

  2. #2
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    Hi,
    LiveStreamRecord usually only records what it receives.
    Please show/paste the details of the recording's video and audio
    codec information, using ffprobe -i ( from ffmpeg) or use a gui tool such
    as mediainfo or gspot.

    Daren

  3. #3

    Default

    Hi Daren
    Here there are the codec information. which is recorded normally.
    General
    Complete name : D:\s4_30_5_Profile_4.mp4
    Format : MPEG-4
    Format profile : Adobe Flash
    Codec ID : f4v
    File size : 5.90 GiB
    Duration : 7h 49mn
    Overall bit rate mode : Variable
    Overall bit rate : 1 798 Kbps
    Encoded date : UTC 2014-05-30 09:00:31
    Tagged date : UTC 2014-05-31 02:06:08

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : High@L3.1
    Format settings, CABAC : Yes
    Format settings, ReFrames : 4 frames
    Codec ID : avc1
    Codec ID/Info : Advanced Video Coding
    Duration : 7h 49mn
    Bit rate mode : Constant
    Bit rate : 315 bps
    Nominal bit rate : 1 620 Kbps
    Width : 720 pixels
    Height : 576 pixels
    Display aspect ratio : 4:3
    Frame rate mode : Variable
    Frame rate : 25.000 fps
    Minimum frame rate : 24.390 fps
    Maximum frame rate : 55.556 fps
    Standard : PAL
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Progressive
    Bits/(Pixel*Frame) : 0.000
    Stream size : 1.06 MiB (0%)
    Title : WowzaMediaServerPro
    Language : English
    Encoded date : UTC 2014-05-30 09:00:31
    Tagged date : UTC 2014-05-30 09:00:31
    Color primaries : BT.601 PAL
    Transfer characteristics : BT.470 System B, BT.470 System G
    Matrix coefficients : BT.601

    Audio
    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format profile : LC
    Codec ID : 40
    Duration : 7h 49mn
    Source duration : 3s 798ms
    Bit rate mode : Variable
    Channel(s) : 2 channels
    Channel positions : Front: L R
    Sampling rate : 48.0 KHz
    Compression mode : Lossy
    Stream size : 0.00 Byte (0%)
    Source stream size : 1.07 MiB (0%)
    Title : WowzaMediaServerPro
    Language : English
    Encoded date : UTC 2014-05-30 09:00:31
    Tagged date : UTC 2014-05-30 09:00:31
    mdhd_Duration : 28186020

    Hungnguyen

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Hi Hungnguyen,

    I don't understand, what does not detect the format? What is the "details tab" you are looking at? Can you play one of these files back in Wowza vod application?

    Richard

  5. #5

    Default

    Hi Richard,

    I'm sorry, if it has a confusion.

    The detail information above is of the mp4 file which is recorded successfully. The mp4 files, which are identified the encode format, can not be played with my Wowza vod application.
    Therefore I can not use them as video source for my vod application.

    The following is the codec details of a error record, I used Mediainfo to check it.

    General
    Complete name : D:\SCTV1_310514_Profile_4.mp4
    Format : MPEG-4
    Format profile : Adobe Flash
    Codec ID : f4v
    File size : 10.6 MiB

    Can I fill the codec informations which are short?
    Thank your help.

    Hungnguyen.

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Hungnguyen,

    It sounds like the recording is corrupt. This can happen because of network problems during the recording. Do you see any problems in the access log for the problem recording?

    Richard

Similar Threads

  1. Is there a way to detect bad video stream?
    By sergei19 in forum Live Streaming and Encoder Discussion
    Replies: 0
    Last Post: 06-11-2012, 03:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •