Results 1 to 10 of 10

Thread: HTTPTranscoderThumbnail suddenly stopped working

  1. #1

    Exclamation HTTPTranscoderThumbnail suddenly stopped working

    I was trying to implement thumbnail preview for our live streams, and stumbled upon the new feature of using HTTPTranscoderThumbnail with Transcoder AddOn to grab thumbnails.

    I followed instructions on this URL:
    http://www.wowza.com/forums/content....-HTTP-Provider

    And it worked instantly, so I was very happy! But then, around 15-20 minutes later, it just stopped working. I've tried going through every part of the installation again, and it's all as it should be.

    When I fetch the URL that should return a thumbnail, I get a 404 response instead. This is my URL format:

    http://10.10.10.73:8086/transcoderth...g&size=640x480

    Anyone who can shed some light on this mystery?

    I have tried reconfiguring transcoder app profile, restarting the application, restarting the Wowza service, and even rebooting the entire server.

    Best regards
    Thomas

  2. #2

    Default

    Hi Thomas,
    You might check to make sure all elements are correct, i.e. application name is correct and case sensitivity accounted for and the stream name is correct. Also, I see in your URL you have "jpg" try changing this to "jpeg".

    I hope this helps.
    Salvadore

  3. #3

    Default

    Quote Originally Posted by salvadore View Post
    Hi Thomas,
    You might check to make sure all elements are correct, i.e. application name is correct and case sensitivity accounted for and the stream name is correct. Also, I see in your URL you have "jpg" try changing this to "jpeg".
    Hi Salvadore. I have checked that everything is correct cased, and I have tried both with jpg, jpeg and png. None of it works.

    In the access log on the server, I now find the following entry:

    2014-06-11 15:06:41 CEST comment server WARN 200 - HTTPTranscoderThumbnail.onHTTPRequest[GNOLLive/_definst_]: Stream not found: 2103248 - - - 101.517 - - - - - - - - - - - - - - - - - - - - - - - - -

    Which is strange, since the stream is active in the list:



    As mentioned, it ran fine - and then suddenly stopped. I have no idea why.

  4. #4

    Default

    It looks like you are trying to access the source stream with the HTTPProvider, before running it trough the Transcoder,
    Try using the transcoded stream, 2103248_HLS as the stream name in the URL.

    Salvadore

  5. #5

    Default

    Quote Originally Posted by salvadore View Post
    It looks like you are trying to access the source stream with the HTTPProvider, before running it trough the Transcoder,
    Try using the transcoded stream, 2103248_HLS as the stream name in the URL.

    Salvadore
    I have tried that too. Here is the log entry for that request:

    2014-06-11 15:30:45 CEST comment server WARN 200 - HTTPTranscoderThumbnail.onHTTPRequest[GNOLLive/_definst_/2103248_HLS]: Live stream encoder not found - - - 1545.804 - - - - - - - - - - - - - - - - - - - - - - - - -

  6. #6

    Default

    Typically, when calling a stream from the transcoder, you would have created a label for that stream in your transcoder template (i.e. "_360p" which would be "2103248_360p" in your URL). Have you successfully setup the Transcoder? For more information, see this tutorial on How to set up and run Wowza Transcoder AddOn for live streaming.

    If this doesn't help, please create a support ticket by sending an email to support@wowza.com. Include a copy of your [install-dir]/conf and /logs folders as a .zip file (or other archive) so we can take a closer look at your configuration and server activity. Also, please include a reference to this post.

    Thank you,

    Salvadore

  7. #7

    Default

    I have solved the issue now, here are my findings.

    I have setup the Transcoder AddOn to create a stream called: mp4:${SourceStreamName}_HLS

    This gives me a stream called 2103248_HLS, when my stream name is 2103248.

    This encode is setup to use pass-through video and convert audio to AAC 48000 bps.

    With this setup, it doesn't work.

    I added a second encode to the same profile, and used the name: mp4:${SourceStreamName}_thumb

    The name has no significance, but the profile is setup with H.264 instead of pass-through, with the lowest possible bit rate (10000 bps). Audio is set to disabled.

    With this encode profile in place, the screen shot works.

    So my theory is that either the pass-through video or AAC audio conversion is somehow interferring with the snapshot mechanics. My guess would be the pass-through video, but I will let you guys at Wowza investigate further. I have to deploy this solution tomorrow, but feel free to contact me if you need more info about my setup.

    Thanks for putting me on the right track to resolve this issue.

    Best regards,
    Thomas

  8. #8

    Default

    Thomas
    Yes, you have to be running the Wowza Transcoder and actively transcoding the stream you want to extract images from, Passthru of the video will not generate thumbnails from the stream.
    There is another technique that does not involve the Transcoder:
    How to take a single-frame snapshot of a live stream for thumbnail creation (ModuleCreateSnapshot)

    Glad to hear you are on the right track, and I hope you find this information helpful.

    Salvadore

  9. #9

    Default

    Hello Salvadore,

    Can you offer some assistance? I am having the exact same issue and I have tried the steps Thomas implemented but I am still unable to get any thumbnail/snapshots. I have already made sure my URl is correct and that I am using the encoded stream, (not the original source).

  10. #10

    Default

    Within the (http://www.wowza.com/forums/content....-HTTP-Provider) Server Side API code, I noticed that the onGrab() function is not being triggered when I manually enter the URL into my browser while a live encoded stream is running. Can you offer some guidance?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •