Results 1 to 3 of 3

Thread: Server crashing

  1. #1

    Default Server crashing

    Hi!

    We get server crash (Application gets destructor called) when:

    1.) Using Adobe HDS
    2.) Transcoder running on server
    3.) Player is Flowplayer

    The crash is caused through one of the clients having troubles with connection or display. I cant exactly pinpoint the cause but we know it is the player, because I was able to reset the application when playing around with the flowplayer.

    Thanks!
    Atmapuri

  2. #2

    Default

    Hello there,

    What version of Wowza are you running?
    Have you followed the Tuning Guide ?
    Can you determine any pattern? For example, if it crashes during a playlist change or after a certain number viewers, or some resource (RAM/CPU) usage?
    Do you have any custom modules running?

    Salvadore

  3. #3

    Default

    Hello Salvadore,

    Wowza Version 4.03.
    Tunning Guide OK.

    Patterns: If I fiddle with Flowplayer config long enough I can crash Wowza app.
    The amount of CPU and memory available is much greater than Wowza usage.
    The custom modules is the server side playlist scheduler. The resulting stream from that scheduler is fed in to transcoder and when connection with Adobe HDS protocol via using Flowplayer is made to Wowza it can boom.

    Other issues I noticed in the last week:
    1.) Memory usage is relatively fixed around 1.5GB Commit Size. 300 viewer no change in memory allocation. CPU usage mostly due to the transcoder.
    2.) Transcoder is "fragile".

    a.) When audio transcoding is enabled on the server and you try to send mono, the result is some squeaking sound.
    b.) If the source audio is mp3, and transcoder has AAC defined for the target, the result is no audio.
    c.) If the transcoding is used including _source profile in to the group, the player cant always allign the video when switching from lower bitrate to _source and the player and the server can crash. This happens, when the stream source is truly live, not only playlist on a live stream. I worked around this problem, by removing _source from the group.
    d.) The renaming of recording does not work. It works for simple tests but sometimes I see files without header and sometimes files named like MyStream_X.mp4, MyStream_Y.mp4... which are not what the OnWrite event expects. Namely: MyStream.mp4
    e.) When source stream entering transcoder switches to different audio format and the transcoder passes "source" quality, a noticeable audio delay can be introduced which remains permanently until the application is restarted. I am not quite sure where the delay is coming from. I turned off KeyFrameFromSource and specified same KeyFrameInterval for all transcoded files. It looks OK for now, but it could a day before errors accumulate.

    Kind Regards!
    Atmapuri
    Last edited by Atmapuri; 06-24-2014 at 04:00 AM.

Similar Threads

  1. Crashing on CentOS 6.1?
    By streamingguy in forum AddOn: Transcoder
    Replies: 12
    Last Post: 01-16-2012, 06:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •