Results 1 to 3 of 3

Thread: Audio transcoding problems

  1. #1

    Default Audio transcoding problems

    Hi!

    In the transcoder template we have for all bitrates (H.264 video):

    <Audio>
    <!-- AAC, PassThru, Disable -->
    <Codec>PassThru</Codec>
    <Bitrate>${SourceAudioBitrate}</Bitrate>
    <Parameters></Parameters>
    </Audio>

    As soon as I specify AAC for codec and bitrate other than source, the audio is toast. Here is what we tried:

    1.) Transcoder template set to AAC, 96Kbps. Source mp3, 128kbps, stereo, 16bit, 44.1KHz. Result: no audio on transcoder output.
    2.) Transcoder template set to AAC, 96Kbps. Source AAC LC, 128Kbps, 44.1kHz stereo. Result: pitch shift
    3.) Transcoder template set to AAC, 96Kbps. Source AAC LC 44.1kHz mono. Result: heavy audio distortion.

    I tried also some other bitrates for transcoder template like 32Kbps, 64kbps and 128Kbps, but no improvement.

    Question:

    1.) What should audio transcoder be capable off? It seems that all I tried is a failure.
    2.) Is it possible on the transcoder to change sampling frequency?
    3.) Can I convert two stereo channels to one mono?
    4.) Can I convert mono to stereo in the transcoder?
    5.) Can I change bit depth with transcoder?

    For low bitrate streams we could use 32Kbps, 44.1Khz, 16bit, mono. Input can be stereo or mono, AAC or mp3 from 32Kbps to 128Kbps, 16bit. Is that something that we can hope to achieve with Wowza?

    Thanks!
    Atmapuri

  2. #2

    Default

    Hi there Atmapuri,

    To better understand your issue, we will need to see your log files. Please open a support ticket by sending an email to support@wowza.com. Include a reference to this post and please include a copy of the following files as a .zip (or other archive):

    [install-dir]/conf
    [install-dir]/logs
    [install-dir]/transcoder
    [install-dir]/manager/logs

    Thank you,

    Salvadore

  3. #3

    Default

    Hello Salvadore,

    After some info from support, here is what seems to be problem (if I understood this right):

    "The transcoder in general is not able to follow change of audio/video format in the source."

    If we have a playlist and two consecutive items in the playlist do not use the same audio codec (or parameters), the transcoder can get confused.

    We noticed that the transcoder seems to be able to follow, if the resolution of video changes down (and other parameters remain more or less the same).
    It is not able to follow increase of resolution and there might be some unwanted side-effects because the transcoder was not made to support this yet.
    This all is somewhat unfortunate and at least in my view should be mentioned as one of the limitations of the transcoder on the corresponding web page.

    Kind Regards!
    Atmapuri

Similar Threads

  1. Audio transcoding problems
    By AlSoft in forum AddOn: Transcoder
    Replies: 5
    Last Post: 01-26-2013, 07:15 AM
  2. WOWZA 3.5 Origin-Edge Transcoding Problems
    By James nNewman in forum General Forum
    Replies: 3
    Last Post: 12-03-2012, 09:48 AM
  3. Audio transcoding problem
    By i101111 in forum AddOn: Transcoder
    Replies: 3
    Last Post: 11-23-2012, 07:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •