Results 1 to 10 of 15

Thread: Please help before i go insane,

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default Please help before i go insane,

    Right so ive installed Wowza on my PC to test it out as im currently have adobe but thinking of switching so using Wowza media Server 3.
    Ive set everything up perfectly except for this damn hotlinking mod,

    Here's a step by step guide of what i have done:

    • I downloaded this mod like it says: downloaded that module and unzipped it
    • Placed it in (install dir)-lib folder
    • Then went to (install dir) >> conf >> Application.xml opened that and went to where it says modules and added this:

    <Name>Hotlink Denial</Name>
    <Description>Hotlink Denial Module</Description>

    • Then went to the bottom where it says properties and added this:

    <Value>FM,WIN,Wirecast</Value> <!--FM, Wirecast-->

    • Saved it and restarted Wowza

    but it doesnt work, i tried hotlinking it on another site and it works on that site so what am i doing wrong, Heres what the bottom of my Application.xml file looks like:
    Please help before i go insane as been trying this all damn day lol

  2. #2


    Hello there,

    I know you said you thought it was working for one domain but not the other. But your description suggests that you enabled the module inside the default Application.xml file at the root level of the /conf directory as opposed to [install-dir]/conf/[your-application]/Application.xml.

    Can you please confirm which application.xml file you are modifying?

    You can also enable extra debug logging for the module with the property <hotlinkLogConnections> as described in the article you referenced.

    Will be waiting to hear back from you on this issue, thanks.


  3. #3


    It was the Application File in the actual Conf folder so the exact path is: Program Files (x86)\Wowza Media Systems\Wowza Media Server 3\conf and the Application.xml file thats actually in the Conf folder, not the one thats in the conf/live/application.xml no not that one, but the one in the conf, here is a screenshot:

    So is that the right one?? Also how do i enable debug logging for the module exactly and do i need to do that or?
    Thanks and look forward to hearing from you.

  4. #4


    No, that would be the wrong Application.xml file to modify. You will need to add the module to the Application.xml file of a specified application.

    Each application has its own Application.xml file. When creating a new application, you create 2 directories with the name of the application, one goes in the [install-dir]/applications directory, and the other goes in the [install-dir] /conf directory.

    the structure would look like this:
    Please see our Quick Start guide for detailed instructions for creating new applications in Wowza.

    I hope this helps.


  5. #5


    Sorry, forgot to add the step where you copy the Application.xml file from /conf into the newly created application folder inside of /conf.

    Again the Quick start Guide explains this process in detail.


  6. #6


    Or, if you choose to add the module to one of the applications provided by Wowza(VOD or live) you would edit the Application.xml file in the /conf/vod or /conf/live directory.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts