Results 1 to 6 of 6

Thread: multiple streams

  1. #1
    Join Date
    Sep 2010
    Posts
    12

    Default multiple streams

    I am running the latest wowza on windows. I have 8 live streams encoded with Niagra Viewcast and am sending them to the wowza server just fine. As I start each one i open the wowza and check the stream. Stream 1 2 and 3 work fine. The 4th stream is being rec'd by wowza but it will not stream out from wowza. It does not matter which 3 streams I start, the 4th is non-functional. I tried setting a different port on each stream but that was not successful. 1 2 and 3 are working fine on port 1935. I played around with the ports on the virtual host but nothing worked there either. Does anybody know the limit on number of live streams. It is a BIG brand new dell server with 32 gig ram. I have streamed all 8 out for years from an apple mini-mac server. Can anyone please help? Thanks.

  2. #2

    Default

    Hi there, please forgive me if I get this wrong but what you are describing sounds like you are running a developer license?
    A developer license allows for 3 incoming streams (as I recall) which would explain why your 4th stream does not work.

    Is this a safe assessment of your set up?

    Salvadore

  3. #3
    Join Date
    Sep 2010
    Posts
    12

    Default

    I have current licensing but I downloaded a 'trial' copy for the windows. Will upgrade with license file asap. Hope that will fix it. Thanks.

  4. #4

    Default

    Sure thing! I think that will solve your issue for you. If not we will be here to help.

    Thanks for the update.

    Salvadore

  5. #5
    Join Date
    Sep 2010
    Posts
    12

    Default

    I have upgraded licensing to full. I have 8 feeds coming from a niagara viewcast encoder. The eight encoded streams come into the wowza thusly: rtmp://10.10.64.62:1935/stream1/stream1.f4v...rtmp://10.10.64.62:1935/stream8/stream8.f4v all coming into their own sub-directory under/live. I might add that all eight are viewable in on the test page. I have "Allow RTP Datagram port sharing" enabled. All eight streams work fine UNTIL there is activity on two or more stream at once. if stream1 and stream2 are live and an ios client selects my link to stream1 then STREAM1 AND STREAM2 can be heard! Does each incoming feed from the encoder need a different port? Where is that set? Please help. I not only moved from an Apple server but also to newer Wowza software and I am totally lost now. Can someone please give me an example of a Wowza server serving more than one stream? Thanks to any and all that can help.

  6. #6
    Join Date
    Jan 2015
    Posts
    357

    Default

    Hi,

    You should not need a different port for each incoming stream. There may be other issues involved. Please submit a support ticket and include the zipped contents of the following directories:
    [install-dir]/conf/, logs/, transcoder/ and manager/logs

    Please also include information regarding your stream/encoder. Thank you.

    Michelle

Similar Threads

  1. Multiple streams
    By terjehal in forum Live Streaming and Encoders
    Replies: 6
    Last Post: 04-15-2014, 11:58 PM
  2. Multiple smil files for multiple live streams
    By haarvik in forum Live Streaming and Encoder Discussion
    Replies: 4
    Last Post: 05-23-2012, 06:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •