Results 1 to 9 of 9

Thread: url recording

  1. #1
    Join Date
    Jul 2014
    Posts
    15

    Default url recording

    Hello,

    I trying to record using the url recording method.


    http://[username]:[password]@[wowza-ip-address]:8086/livestreamrecord?app=live&streamname=myStream&action=startRecording

    has redirected me to:

    http://[wowza-address]:8086/livestreamrecord/index.html

    page shows

    livestreamconst[stop recording][split recording]
    Recording in progress
    Recording Option = Version
    File = null/null

    and in the error log I see:


    HTTPRequestAdapter.service : java.lang.NullPointerException|at java.lang.String.<init>(Unknown Source)|at com.wowza.wms.authentication.AuthenticateBasic.authenticateHTTPProvider(AuthenticateBasic.java:167)|at com.wowza.wms.http.HTTProvider2Base.doHTTPAuthentication(HTTProvider2Base.java:280)|at com.wowza.wms.livestreamrecord.http.HTTPLiveStreamRecord.onHTTPRequest(HTTPLiveStreamRecord.java:101)|at com.wowza.wms.http.HTTPRequestAdapter.service(HTTPRequestAdapter.java:33)|
    No file is being created in the default location, but it still says "Recording in progress" any suggestions on what would be wrong would be great.

    Regards,

    Ben

  2. #2

    Default

    Hello Ben,

    Can you please verify that your query string is entered correctly and that the user name and password are also correct. Also, are you able to play back the live stream that you are attempting to record?

    Salvadore

  3. #3
    Join Date
    Jul 2014
    Posts
    15

    Default

    Hi Salvadore,

    Yes the live stream is running and I am able to play it. Double checked the password which I am using and this is also correct, can I also check what Access Level this user would need?

    On the livestreamrecord/index.html page if I stop the recording which didn't start from the url method and hit start recording manually then a file is created correctly.

    Ben

  4. #4
    Join Date
    Jun 2012
    Posts
    723

    Default

    Hi Ben,

    Can you check in your conf/VHost.xml file what kind of authentication method you have configured for the "livestreamrecord" http listener, which is configured for port 8086?

    Here are the default settings:
    <HTTPProvider>
          <BaseClass>com.wowza.wms.livestreamrecord.http.HTTPLiveStreamRecord</BaseClass>
          <RequestFilters>livestreamrecord*</RequestFilters>
          <AuthenticationMethod>admin-digest</AuthenticationMethod>
    </HTTPProvider>
    Zoran

  5. #5
    Join Date
    Jul 2014
    Posts
    15

    Default

    Hi Zoran,

    It is set to, admin-basic, I changed it back to admin-digest but that comes up with an addition pop-up box asking for username and password again. If i do type in the user name and password again I see,

    livestreamconst[stop recording][split recording]
    Recording in progress
    Recording Option = Version
    File = null/null

    On the page.

    Ben

  6. #6

    Default

    Hello Ben, for the most efficient troubleshooting support I think it would be best to open a support ticket.

    Please re-start Wowza, re-test your recording procedure, and then zip up the /conf and /log folders and send them to support@wowza.com
    Provide as much detail about your streaming and server configurations, the problems you are experiencing, and a link to this thread as a reference.

    Thanks.

    Salvadore

  7. #7
    Join Date
    Jul 2014
    Posts
    15

    Default

    Been pointed to the solution the url method but doesn't like being used on edges but will work on the origin in an origin-edge set-up.

    Thanks all who tried to help.

  8. #8
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    It will work on a Wowza edge, but the stream name will have to be .stream file and be pre-started with the MediaCaster system using MediaCaster type "liverepeater". If you are using the Application.xml /OriginURL and a simple stream name in the player, you have to use .stream file instead, with the whole rtmp url. For example a file named origin.stream in the /content folder with contents: "rtmp://[wowza-origin-server]/liveorigin/myStream". Then use origin.stream as the streamname.

    Richard

  9. #9
    Join Date
    Jul 2014
    Posts
    15

    Default

    Ok,

    Thank you for the information, I'll give that a try.

    Ben

Similar Threads

  1. Recording live streams with URL queries v4
    By novazion in forum Wowza Streaming Server Java API
    Replies: 2
    Last Post: 03-11-2014, 10:44 AM
  2. Avoid redirection while using recording with URL queries
    By stream4life in forum General Forum
    Replies: 2
    Last Post: 02-13-2014, 05:52 AM
  3. recording live streams using URL queries
    By kurtkurt in forum Live Streaming and Encoder Discussion
    Replies: 10
    Last Post: 02-23-2013, 11:41 AM
  4. Recording live streams using URL queries issue
    By rush0143 in forum General Forum
    Replies: 5
    Last Post: 01-19-2013, 07:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •