Results 1 to 9 of 9

Thread: Trying to connect s3 bucket.

  1. #1
    Join Date
    Jul 2014
    Posts
    18

    Default Trying to connect s3 bucket.

    Hello i am trying to use the vod3 module on the ec2 instance of wowza to access files stored on my s3 bucket. I have edited the MediaCache.xml file and put in my awsAccessKeyId and awsSecretAccessKey but when i try and play myfile i get the error "source stream or file not found or access denied"
    the file location in my s3 bucket is
    https://s3.amazonaws.com/Mediaforwowza/Film/test.mp4
    and the address in the player is

    http://SERVER_IP:1935/vod3/_definst_/mp4:amazons3/Mediaforwowza/Film/test.mp4/manifest.f4m
    or
    http://SERVER_IP:1935/vod3/_definst_/mp4:amazons3/Mediaforwowza/Film/test.mp4
    Any help with this would be greatly appreciated.

    Thanks

  2. #2
    Join Date
    Jul 2014
    Posts
    18

    Default

    Oh. I have also granted authenticated users to my s3 bucket, but this has not helped.

  3. #3
    Join Date
    Jul 2014
    Posts
    18

    Default

    I tried opening the rtsp stream in vlc and got this error
    RTSP connection failed:
    Access to the stream is denied by the server configuration.
    Your input can't be opened:
    VLC is unable to open the MRL 'rtsp://SERVER_IP:1935/vod3/_definst_/amazons3/Mediaforwowza/Film/test.mp4'

  4. #4
    Join Date
    Jun 2012
    Posts
    724

    Default

    Hi,

    Did you configure your Media Cache application using the instructions described in the "How to scale video on demand streaming with Media Cache" forum article?
    Here is the direct link to the section describing how to add the S3 source.

    Zoran

  5. #5
    Join Date
    Jul 2014
    Posts
    18

    Default

    Quote Originally Posted by zoran_u View Post
    Hi,

    Did you configure your Media Cache application using the instructions described in the "How to scale video on demand streaming with Media Cache" forum article?
    Here is the direct link to the section describing how to add the S3 source.

    Zoran
    Hello thanks for the reply.

    I followed these steps an i think i have found the problem. the check box which states "use amazon S3 bucket name in domain" is checked. When this is checked i notice the address resolved is wrong for finding the file on the bucked as the address given is,
    http://mybucket.s3.amazonaws.com/mypath/sample.mp4
    But when it is unchecked the domain is correct.
    http://s3.amazonaws.com/mybucket/mypath/sample.mp4
    Only problem is i cannot seem to uncheck this button, i uncheck it, save my config, and re-enter into config page and see that the button is checked again?

  6. #6
    Join Date
    Jul 2014
    Posts
    18

    Default

    I have managed to remove this checkbox manually by editing the MediaCache.xml file and changing the value from true to false as shown below. I can view the stream directly with the link provided http://SERVER_IP:8088/enginemanager/...st_/mediaCache ----> Validate Configuration but not when trying to use the server address in the test player or vlc the file will still not play.

    <Property>
    <Name>s3BucketNameInDomain</Name>
    <Value>false</Value>
    <Type>Boolean</Type>
    </Property>

  7. #7
    Join Date
    Jul 2014
    Posts
    18

    Default

    I have noticed a few errors in the log file which appear each time i try and play the file, maybee they can help.

    Application folder ([install-location]/applications/vod3) is missing
    WARN	server	comment	2014-07-29	20:32:02	-	-	-	-	-	9313.413	-	-	-	-	--	-	-	HTTPStreamerAdapterSanJoseStreamer.onPlaylist: Application context not loaded [[vod3/_definst_/mp4:amazons3/Mediaforwowza/Film/BigBuckBunny_115k.mov/manifest.f4m]: vod3/_definst_]: vod3/_definst_

  8. #8
    Join Date
    Jul 2014
    Posts
    18

    Default

    just asnswered my own question and have it working now
    ([install-location]/applications/vod3) is missing
    tells me i have a spelling error "vod3" should be "vods3"
    Got it working FINALLY!!

  9. #9
    Join Date
    Sep 2011
    Posts
    1,919

    Default

    Hi,
    Thanks for the update, glad to hear that you have this working.

    Regards,
    Jason

Similar Threads

  1. How to check source stream status - MediaCasterConnection.connect: Failed to connect
    By herkules in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 11-20-2013, 07:11 PM
  2. mounting amazon s3 bucket
    By welbyobeng in forum Video On Demand Streaming Discussion
    Replies: 7
    Last Post: 05-18-2012, 03:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •