Results 1 to 6 of 6

Thread: Can't build JWPlayer with secured token

  1. #1

    Default Can't build JWPlayer with secured token

    Hi,
    I followed the tutorials, tryed many ways to build jwplayer 6 with a secure token, under windows 7 or linux ubuntu server 14.04, but i never succeed.
    I can build the html5 file with success, but building the swf file always fails.

    On my Linux server, it says that the following line (line 74) of my src/flash/com/longtailvideo/jwplayer/player/Player.as File has an error :

    protected function newController(mod:Model, vw:View):Controller {
    Apparantly, "Controller" type is not recognized.

    I am using java 6 jdk, flex sdk 4.1, ant 1.7.
    Last edited by tiberghv; 08-01-2014 at 08:10 AM.

  2. #2

    Default

    Hi,

    Unfortunately (so to speak) it compiles ok for me. Running Ubuntu Linux 14.04, JW Player 6.9.0 source, Flex SDK 4.6.0 and ant 1.9.3. What are your build properties?


    Paul

  3. #3

    Default

    Quote Originally Posted by Paul_S View Post
    Hi,

    Unfortunately (so to speak) it compiles ok for me. Running Ubuntu Linux 14.04, JW Player 6.9.0 source, Flex SDK 4.6.0 and ant 1.9.3. What are your build properties?


    Paul
    Thank you for your answer Paul.
    I have tryed with ant 1.9 too, doesn't work either.
    Flex SDK is just a repertory that i copy/pasted on the computer, not an install through apt-get (i also tryed to install flex with "apt-get install flex", but it doesnt help)

    My build properties are the following :

    # -----------------------------------------------------------------
    # User-Defined Variables
    #
    # Modify these path values to reflect paths on your system
    # -----------------------------------------------------------------
    
    # The location of the Flex SDK on your sytem.
    # flexsdk = C:/Program Files/Adobe/Flash Builder 4/sdks/4.1.0
    # Replace the above line with the following for unix / OS X, replacing the path
    # flexsdk = /Applications/Adobe-Flash-Builder-4/sdks/4.1.0
    #flexsdk = /Developer/SDKs/flex_sdk_4
    flexsdk = /usr/local/bin/flex_sdk_4.1/
    #flexsdk = /usr/local/bin/flex_sdk_4.5
    # Extension for Windows setups
    # execextension = .exe
    # Value should be left blank for Unix / OS X
    execextension =
    
    # Flash player target
    flexsdk.target = 10.1.0
    
    # -----------------------------------------------------------------
    # Project Settings - DO NOT MODIFY
    # -----------------------------------------------------------------
    application.package = com/longtailvideo/jwplayer/player
    application.class = Player
    application.majorversion = 6
    application.minorversion = 9
    flexsdk.bin.dir = ${flexsdk}/bin
    flexsdk.lib.dir = ${flexsdk}/frameworks/libs
    asdoc.exe = ${flexsdk.bin.dir}/asdoc${execextension}
    compc.exe = ${flexsdk.bin.dir}/compc${execextension}
    mxmlc.exe = ${flexsdk.bin.dir}/mxmlc${execextension}
    src.dir = ${basedir}/src/flash
    release.dir = ${basedir}/bin-release
    debug.dir = ${basedir}/bin-debug
    sdk.dir = ${release.dir}/sdk
    ~
    Last edited by tiberghv; 08-01-2014 at 08:09 AM.

  4. #4

    Default

    Regarding your flexsdk.target, do you actually have a 10.x.x in [flex-install-path]/frameworks/libs/player? My flex install only has 11.1 so I've flexsdk.target=11.1. Just wondering if you've the latest install. This is on a Linux box so no "execextension = .exe". I've not tried building jwplayer on a Windows box though.

    Paul

  5. #5

    Default

    Quote Originally Posted by Paul_S View Post
    Regarding your flexsdk.target, do you actually have a 10.x.x in [flex-install-path]/frameworks/libs/player? My flex install only has 11.1 so I've flexsdk.target=11.1. Just wondering if you've the latest install. This is on a Linux box so no "execextension = .exe". I've not tried building jwplayer on a Windows box though.

    Paul
    Thank you for this idea.
    I have both a 10.1 and 10.0 folders in my [flex-install-path]/frameworks/libs/player directory.
    I have tryed changing the flexsdk.target parameter to 10.0 or 10.1, but the result is the same : build fails with the same error message.

    The execextension is already setted to null.

  6. #6

    Default

    Did you install Flex Sdk with "apt-get install flex" or did you just copy/paste the folder ?
    and if i may ask, wich version of Java jdk are you using ? and wich package did you install it with ?

Similar Threads

  1. repeating from a Secured Origin
    By tavius in forum Live Streaming and Encoders
    Replies: 3
    Last Post: 05-05-2014, 08:38 PM
  2. Dynamic Switch between public and secured stream
    By wtoolbox in forum Showcase
    Replies: 0
    Last Post: 05-05-2014, 01:39 PM
  3. Secured RTMP authentication integration
    By tan-tan in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 09-09-2013, 03:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •