Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Streaming from vbrick via RTMP with authentication requirement

  1. #1
    Join Date
    Aug 2014
    Posts
    2

    Default Streaming from vbrick via RTMP with authentication requirement

    I can successfully stream from my vbrick using RTMP port 1935 if I use open authentication, but when I turn on "require password authentication" the stream never shows up in the Wowza "Incoming streams" page and I get the message "Source stream or file could not be found or access was denied." in the test players and "myStream not found" in the JWplayer. I've tried different publishers and I've tried copy/pasting the password so I know it isn't an incorrect password issue. But I can't figure out whether the issue is with vbrick or wowza. Vbrick shows that the stream is in transmitting state but no data/packets are actually transmitting when authentication is turned on.

  2. #2

    Default

    Hi,

    Does the vbrick advertise itself with a specific Flash version string? If you're using user authentication in Incoming Security then Wowza will check for one of its known Flash version strings, FM for Adobe, Wirecast etc. You can look at your logs for connect or connect-pending entries and see if there's a specific version string in there. If so, add it in [App Name] > Incoming Security > Edit > Flash Version String.


    Kind regards,

    Paul

  3. #3
    Join Date
    Aug 2014
    Posts
    2

    Default

    Paul,

    I was only recently given responsibility for all things Wowza here, so please bear with me. Are the log files accessible via the browser interface, or do I need to access them from the server directly?

    Thanks for your assistance.

  4. #4

    Default

    Hi,

    At the moment, you will need to view the log files directly on the server.

    There will be a log file viewer in a future version if the Manager.

    Roger.

  5. #5
    Join Date
    Apr 2015
    Posts
    9

    Default

    Hi,

    I'm actually having the same or similar issue. I can stream from our VBrick encoders without issue when RTMP authentication is open, but not when a password is required.
    We're currently up to date on Wowza 4.2 and our VBrick encoders are also running the latest firmware. I've checked the log files, I was able to see a pending connection it had FMLE listed, along with FMSc, I made sure the VBrick was set to FMLE but still didnt work. Again, only when authentication required is active. Any ideas?
    Thanks!

  6. Default

    Can you post the Wowza log entries from when you try to connect from VBrick?

  7. #7
    Join Date
    Apr 2015
    Posts
    9

    Default

    Quote Originally Posted by SiggDev View Post
    Can you post the Wowza log entries from when you try to connect from VBrick?
    PDT app-start application INFO 200 _definst_ Test/_definst_ - - - 44378.715 - - - - - - - - - - - - - - - - - - - - - - - - -
    2015-07-29 12:15:56 PDT connect-pending session INFO 100 165.107.90.65 - _defaultVHost_ Test _definst_ 0.42 165.107.32.175 1935 rtmp://LegStream05.calegis.net/Test 165.107.90.65 rtmp rtmp://LegStream05.calegis.net/Test FMLE/3.0 - VBrick/4.2.0b (compatible; FMSc/1.0) 417273419 3291 3073 - - - - - - - - - - - - - rtmp://LegStream05.calegis.net/Test -
    2015-07-29 12:15:56 PDT connect session INFO 401 165.107.90.65 - _defaultVHost_ Test _definst_ 0.426 165.107.32.175 1935 rtmp://LegStream05.calegis.net/Test 165.107.90.65 rtmp rtmp://LegStream05.calegis.net/Test FMLE/3.0 - VBrick/4.2.0b (compatible; FMSc/1.0) 417273419 3291 3073 - - - - - - - - - - - - - rtmp://LegStream05.calegis.net/Test -
    2015-07-29 12:15:56 PDT disconnect session INFO 200 417273419 - _defaultVHost_ Test _definst_ 0.505 165.107.32.175 1935 rtmp://LegStream05.calegis.net/Test 165.107.90.65 rtmp rtmp://LegStream05.calegis.net/Test FMLE/3.0 - VBrick/4.2.0b (compatible; FMSc/1.0) 417273419 3307 3312 - - - - - - - - - - - - - rtmp://LegStream05.calegis.net/Test -
    2015-07-29 12:16:17 PDT connect-pending session INFO 100 165.107.90.65 - _defaultVHost_ Test _definst_ 0.08 165.107.32.175 1935 rtmp://LegStream05.calegis.net/Test 165.107.90.65 rtmp rtmp://LegStream05.calegis.net/Test FMLE/3.0 - VBrick/4.2.0b (compatible; FMSc/1.0) 292443871 3291 3073 - - - - - - - - - - - - - rtmp://LegStream05.calegis.net/Test -
    2015-07-29 12:16:17 PDT connect session INFO 401 165.107.90.65 - _defaultVHost_ Test _definst_ 0.081 165.107.32.175 1935 rtmp://LegStream05.calegis.net/Test 165.107.90.65 rtmp rtmp://LegStream05.calegis.net/Test FMLE/3.0 - VBrick/4.2.0b (compatible; FMSc/1.0) 292443871 3291 3073 - - - - - - - - - - - - - rtmp://LegStream05.calegis.net/Test -
    2015-07-29 12:16:17 PDT disconnect session INFO 200 292443871 - _defaultVHost_ Test _definst_ 0.183 165.107.32.175 1935 rtmp://LegStream05.calegis.net/Test 165.107.90.65 rtmp rtmp://LegStream05.calegis.net/Test FMLE/3.0 - VBrick/4.2.0b (compatible; FMSc/1.0) 292443871 3307 3312 - - - - - - - - - - - - - rtmp://LegStream05.calegis.net/Test -
    2015-07-29 12:16:37 PDT connect-pending session INFO 100 165.107.90.65 - _defaultVHost_ Test _definst_ 0.066 165.107.32.175 1935 rtmp://LegStream05.calegis.net/Test 165.107.90.65 rtmp rtmp://LegStream05.calegis.net/Test FMLE/3.0 - VBrick/4.2.0b (compatible; FMSc/1.0) 1959483150 3291 3073 - - - - - - - - - - - - - rtmp://LegStream05.calegis.net/Test -
    2015-07-29 12:16:37 PDT connect session INFO 401 165.107.90.65 - _defaultVHost_ Test _definst_ 0.067 165.107.32.175 1935 rtmp://LegStream05.calegis.net/Test 165.107.90.65 rtmp rtmp://LegStream05.calegis.net/Test FMLE/3.0 - VBrick/4.2.0b (compatible; FMSc/1.0) 1959483150 3291 3073 - - - - - - - - - - - - - rtmp://LegStream05.calegis.net/Test -
    2015-07-29 12:16:38 PDT disconnect session INFO 200 1959483150 - _defaultVHost_ Test _definst_ 0.168 165.107.32.175 1935 rtmp://LegStream05.calegis.net/Test 165.107.90.65 rtmp rtmp://LegStream05.calegis.net/Test FMLE/3.0 - VBrick/4.2.0b (compatible; FMSc/1.0) 1959483150 3307 3312 - - - - - - - - - - - - - rtmp://LegStream05.calegis.net/Test -
    2015-07-29 12:16:58 PDT connect-pending session INFO 100 165.107.90.65 - _defaultVHost_ Test _definst_ 0.066 165.107.32.175 1935 rtmp://LegStream05.calegis.net/Test 165.107.90.65 rtmp rtmp://LegStream05.calegis.net/Test FMLE/3.0 - VBrick/4.2.0b (compatible; FMSc/1.0) 1779315265 3291 3073 - - - - - - - - - - - - - rtmp://LegStream05.calegis.net/Test -
    2015-07-29 12:16:58 PDT connect session INFO 401 165.107.90.65 - _defaultVHost_ Test _definst_ 0.066 165.107.32.175 1935 rtmp://LegStream05.calegis.net/Test 165.107.90.65 rtmp rtmp://LegStream05.calegis.net/Test FMLE/3.0 - VBrick/4.2.0b (compatible; FMSc/1.0) 1779315265 3291 3073 - - - - - - - - - - - - - rtmp://LegStream05.calegis.net/Test -
    2015-07-29 12:16:58 PDT disconnect session INFO 200 1779315265 - _defaultVHost_ Test _definst_ 0.178 165.107.32.175 1935 rtmp://LegStream05.calegis.net/Test 165.107.90.65 rtmp rtmp://LegStream05.calegis.net/Test FMLE/3.0 - VBrick/4.2.0b (compatible; FMSc/1.0) 1779315265 3307 3312 - - - - - - - - - - - - - rtmp://LegStream05.calegis.net/Test -
    2015-07-29 12:17:12 PDT comment server WARN 200 - REST API: exists(): File (C:/Program Files (x86)/Wowza Media Systems/Wowza Streaming Engine 4.1.0/internalVHost/conf/VHost.xml) does not exist - - - 44454.728 - - - - - - - - - - - - - - - - - - - - - - - - -

  8. #8
    Join Date
    Apr 2015
    Posts
    9

    Default

    Quote Originally Posted by SiggDev View Post
    Can you post the Wowza log entries from when you try to connect from VBrick?
    Any help ?

  9. Default

    Sorry, not at the moment. I was expecting to see something useful in the logs, but that's not the case. Hopefully, I'll be able to make a test with vbrick at some point to find out more.

  10. Default

    Any news on this?

    I also get the 401 response. Snooping the network shows wowza sending back a packet that includes:

    ..e)..MR.............&%..............&%..................................................._error.?.. .........level...error..code...NetConnection.Connect.Rejected..description..C[ AccessManager.Reject ] : [ code=403 need auth; authmod=adobe ] : ..


    I'm guessing the vbrick isn't attempting to authenticate at all, or is doing so incorrectly.


    -jonathan

Page 1 of 2 12 LastLast

Similar Threads

  1. authentication for Flash RTMP and control access to Apple HTTP Streaming
    By Yuri!! in forum Server-side Modules and Code Samples Discussion
    Replies: 2
    Last Post: 05-13-2013, 06:35 AM
  2. RTMP authentication, RTSP authentication => problem
    By nvanhaute1 in forum Server Administration Discussion
    Replies: 4
    Last Post: 11-09-2011, 03:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •