Results 1 to 6 of 6

Thread: Google Compute Engine - Asia to USA - could not send 4Mbps stream

  1. #1
    Join Date
    Aug 2014
    Posts
    3

    Default Google Compute Engine - Asia to USA - could not send 4Mbps stream

    Hi,

    I am transcoding a 4Mbps stream to 2 additional bitrates in a Google compute engine(GCE) asia-eastb instance(WowzaSE 4.0.4-Debian Image). I am able to pull all the streams properly to a server in Singapore & India, but the source stream(4Mbps) is not reaching another GCE instance in us-central region properly. The lower quality streams work fine. I tried this with both public IP and internal IP of the GCE instances.

    Generally, I am not able to pull a live stream with a bitrate higher than 2Mbps properly between asia and usa. I signed up for GCE just because this issue happens between two ad-hoc servers between India & USA, but the situation is the same even with GCE. Is this an RTMP issue or am I missing something? Is there any other mode of origin-edge configuration which can work properly ? Has anyone faced such issues and resolved it?

    Thanks,
    Prem

  2. #2

    Default

    Hi,

    Are you able to conduct any bandwidth tests between the two nodes? It would be useful if you could confirm that you can sustain a 4+ Mbit/sec throughput outside of Wowza. Something simple like netcat may help.


    It may also be useful to examine your logs at the time you're seeing issues with the stream failing. Post them here if they show anything of interest.


    Kind regards,

    Paul

  3. #3

    Default

    Hi,

    Also, the high latency (ping time) between the two locations combined with the default network settings for Wowza may be causing the issue. There are some adjustments that you can make which may improve things.

    The default settings use a fixed size for the TCP send and receive buffers which normally works fine for low to medium latencies but can cause issues for high latency connections when streaming high bitrate streams.

    By setting the Wowza servers use the OS automatic settings for the buffer sizes, you will allow the OS to adjust them to suit the individual streams which should improve things.

    To do this, set the sendBufferSize and receiveBufferSize to 0 for the streaming HostPort and NetConnections. Don't change the readBufferSize setting form the default value.

    The streaming HostPort setting can be changed in the Manager from Server > Performance Tuning > Virtual Host Ports > Properties.
    The NetConnection setting can be changed from Server > Virtual Host Setup > Properties

    Roger.

  4. #4
    Join Date
    Aug 2014
    Posts
    3

    Default

    Thanks Paul & Roger for your support.

    I could get 30-40Mbps throughput between the GCE instances using netcat. I'll set the buffersizes to zero and test. Will post the results here.

    Warm Regards,
    Prem

  5. #5
    Join Date
    Aug 2014
    Posts
    3

    Default

    Hi,

    After setting the sendBufferSize and receiveBufferSize to 0 for the streaming HostPort and NetConnections in conf/VHost.xml file, I am able to stream 4Mbps without issues. I did the changes in both the instances. Thanks for your support. If there are any additional setting which would help to improve the throughput, pls let me know.

    Thanks & Warm Regards,
    Prem

  6. #6

    Default

    Hi,

    Good to hear that these settings worked for you.

    Roger.

Similar Threads

  1. Replies: 5
    Last Post: 10-23-2014, 03:04 PM
  2. Google Compute Engine trouble when trying to set up wowza streaming engine
    By CBBrewCo in forum Wowza Streaming Engine in the Cloud
    Replies: 1
    Last Post: 06-27-2014, 02:55 PM
  3. fast in USA - not abroad
    By bobmane in forum General Forum
    Replies: 8
    Last Post: 11-15-2012, 09:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •