Results 1 to 9 of 9

Thread: Problems with Datavideo NVS-20

  1. #1

    Default Problems with Datavideo NVS-20

    Hello!

    I have a Datavideo NVS-20 encoder and sending RTMP stream to Wowza server. The box does not have many parameters, just video inout, resolution, bitrate and mpeg profile.

    When I choose 720p50 with 4mbit/s the clients experience constant and regular freezes and drops in the video stream. Upstream bandwidth from my site is 10mbit/s and the Wowza server has 1gbit/s connection. Server bandwidth during the live streaming was around 600mbit/s - and I had other events with up to 850mbit/s without any problems but encoded with FMLE at 1mbit/s

    When I lowered the bitrate in steps of 500kbit/s the drops decreased but never vanished completely.
    I will now try 2mbit/s but I don't want to go lower because then the quality will be bad.

    Do you have any experience with this Datavideo encoder or is there something special to tune for high bitrate streams?
    And how to troubleshoot this kind of problems at all?

    thanx and greetings,
    Stephan

  2. #2

    Default

    Hi Stephan,

    Can you try setting your FMLE at 2mbit/s as you suggested and see how that works for you.

    You could also look at experimenting with different sort buffer values, say 4000 (4 seconds) and lower.


    Paul

  3. #3

    Default

    OK, I configured the sort buffer but it did not change the quality or stability with the NVS-20 encoder at 2mbit/s
    Then I streamed from FMLE with 4mbit/s and guess what? absoluteley fine and stable.

    I also tried the NVS-20 with local streaming mode and I connected a player directly to it - no problems.

    My guess is that maybe the IP stack in the NVS-20 is not so efficient over WAN with Path MTU discovery, MSS size, etc ....

    Will next try and install a Wowza in my LAN and see if the problems persist.

    Greetings,
    Stephan

  4. #4

    Default

    Update: same problems when streaming at 4 mbit/s over a 1gbit/s LAN to a local Wowza instance

    ===> NVS-20 is crap!

    Best,
    Stephan

  5. #5

    Default

    Hi Stephan,

    Thanks for the update. It may also be worthwhile passing your findings on to Datavideo to see if they have suggestions with regards to your setup, if you haven't done that already.


    Paul

  6. #6

    Default

    yep, I am in contact with Datavideo Europe already.
    This is what the Wowza says constantly when using the NVS-20:

    2014-08-09 01:00:06 CEST comment server INFO 200 - TranscodingSession.updateBehindFilter[LamaOle/_definst_/live]: Video behind filter state change. New state: SKIP1FRAME - - - 122472.506 - - - -
    2014-08-09 01:00:11 CEST comment server INFO 200 - TranscodingSession.updateBehindFilter[LamaOle/_definst_/live]: Video behind filter state change. New state: ALLFRAMESON - - - 122477.654 - - - -
    2014-08-09 01:00:25 CEST comment server INFO 200 - TranscodingSession.updateBehindFilter[LamaOle/_definst_/live]: Video behind filter state change. New state: SKIP1FRAME - - - 122490.895 - - - -
    2014-08-09 01:00:34 CEST comment server INFO 200 - TranscodingSession.updateBehindFilter[LamaOle/_definst_/live]: Video behind filter state change. New state: ALLFRAMESON - - - 122500.023 - - - -
    2014-08-09 01:00:44 CEST comment server INFO 200 - TranscodingSession.updateBehindFilter[LamaOle/_definst_/live]: Video behind filter state change. New state: SKIP1FRAME - - - 122510.2 - - - -
    2014-08-09 01:00:53 CEST comment server INFO 200 - TranscodingSession.updateBehindFilter[LamaOle/_definst_/live]: Video behind filter state change. New state: ALLFRAMESON - - - 122519.423 - - - -

  7. #7
    Join Date
    Dec 2011
    Posts
    14

    Default

    I tested this coder too, the quality of video is very ugly even on high bitrates.

  8. #8
    Join Date
    May 2013
    Posts
    680

    Default

    These INFO messages "TranscodingSession.updateBehindFilter" typically indicate that Wowza Media Server is overworked and can't process the packets in time. Typically occurs when CPU utilization or GPU utilization for acceleration is at maximum capacity or beyond workable threshold. Ensure you review the transcoder benchmarks as a basis for your available transcoding capacity.

  9. #9

    Default

    Datavideo NVS-20 supports wowza server?

    I was informed by my local Datavideo vendor that NVS-20 doesn't support Wowza Server or even Akamai Server.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •