Hello everybody !

I'm trying the kickflip.io opensource framework to stream using Google Glass,

The framework seems to use :
  • RTMP protocol
  • mp4a-latm audio ecoder
  • H.264 Advanced Video Coding video encoder
  • 30fps
  • 3 seconds between I-frames
  • Video Resolution 320 * 240
  • Video Bitrate 300 * 1000
  • Audio Bitrate 192 * 1000

When I stream to wowza, in the monitoring part I see packets arriving, so far so good.
When I open the RTMP stream on VLC, I can see the stream video/audio but there are a 5 seconds delays.

I need to have less than 2 seconds delay, so I have checked on internet and it seems that in order to reduce this delay I should use a flash player and reduce the buffer size.

My current problem is that I cant see my stream on any flash player !

I tried on the wowza rtmp flashplayer, I also have tried with flowplayer and jw player, it doesnt seem to work.
On wowza "test players" I have the message "Started playing my stream" but I have a black screen... ad nothing happen

What is weird is that it works on VLC..

Could help me ?

Thank you