Results 1 to 7 of 7

Thread: HLS push/pull to Edgecast

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default HLS push/pull to Edgecast


    I'm trying to push HLS out to Edgecasts ingest servers with wowza but I'm not seeing how to do that. And reading other posts here it looks like the feature is unavailable. We're a start up company not trying to spend 10k on encoders to publish to IOS & Mobile devices. Can anyone advise on how to do this? We are presently pushing RTMP flash no problem already. Edgecast does have HLS transmuxing but want $500 a month to do that on their servers.
    Last edited by BargainsBeyond; 08-21-2014 at 12:06 PM.

  2. #2


    Hi there and welcome to the Wowza support forum.
    I do not think that the Push Publish Add On supports this at present.

    With that said, this forum user claims to have made it work for them:
    Push Publish add on edgecast

    Someone with more information or a solution should be along to add to this if there is anything to add.


  3. #3


    Thank you for the link, I have done some research and found that edgecast only pulls HLS (HTTP streaming), and part of these settings are done in under the HTTP Large -> Customers Origin ip: port. Now I'm just trying to setup Wowza so it directs the incoming request to the right stream since the /live/mystream/playlist.m38u portion of the path was not configurable on the edgecast panel.

    I'm still trying to figure out where thats configured and referring to the manual.. Maybe alias map or vhost?

    I'll update everyone as soon as I find out. Because honestly when I called edgecast they were looking around at this forum for answers too so maybe this will come in handy for their own staff someday.
    Last edited by BargainsBeyond; 08-22-2014 at 04:25 PM.

  4. #4
    Join Date
    Aug 2014


    It sounds like we are doing something similar. Were you ever able to get this to work? Further, did you ever try the HLS transmux? Below is my thread.

  5. #5


    I finally figured it out.. See on edgecast it let me input the application directory (1), ip and port of origin - which is the wowza server, but no where did I see where i could configure the remainder of the path which was something like /livestream/myStream/playlist.m3u8. Finally I just guessed and inserted this into the jwplayer source path (2) and it started working.

    (1) /wowza
    (2) Http://

    I never paid Edgecast for the HLS transmux service if thats what you meant, it was to expensive so we are transmuxing with Wowza and they are pulling it and caching it for distribution on their servers. So far I have 26 second latency with full video and audio synced.

    Thanks for all your help man.. I hope this helps others too..
    Last edited by BargainsBeyond; 08-26-2014 at 09:26 PM.

  6. #6


    Thanks for the update and information. We are glad you got this working.


  7. #7
    Join Date
    Aug 2014


    Yeah, we are doing the same thing. I think you can lower the latency by reducing the amount of chunks that JWplayer using to buffer. Default is 3, which I think comes out to be about 30 seconds.

Similar Threads

  1. Wowza to push SmoothStreaming Content to Edgecast
    By Terrycheung in forum Live Streaming and Encoders
    Replies: 2
    Last Post: 09-24-2014, 11:50 PM
  2. Pull HLS stream and restream
    By vineethkdlr in forum General Forum
    Replies: 1
    Last Post: 10-15-2013, 01:15 PM
  3. Push Publish add on edgecast
    By el3anchoke in forum AddOn: Other AddOns
    Replies: 4
    Last Post: 08-21-2013, 11:52 AM
  4. HLS pushing to Edgecast
    By el3anchoke in forum Live Streaming and Encoder Discussion
    Replies: 2
    Last Post: 10-02-2012, 01:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts